SUSE Security Update: Security update for rust
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:0200-1
Rating:             moderate
References:         #1194767 
Cross-References:   CVE-2022-21658
CVSS scores:
                    CVE-2022-21658 (SUSE): 6.2 CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Affected Products:
                    SUSE Linux Enterprise Server for SAP 15
                    SUSE Linux Enterprise Server 15-LTSS
                    SUSE Linux Enterprise High Performance Computing 15-LTSS
                    SUSE Linux Enterprise High Performance Computing 15-ESPOS
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for rust fixes the following issues:

   - CVE-2022-21658: Fixed race condition in std::fs::remove_dir_all
     (bsc#1194767).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Server for SAP 15:

      zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-2022-200=1

   - SUSE Linux Enterprise Server 15-LTSS:

      zypper in -t patch SUSE-SLE-Product-SLES-15-2022-200=1

   - SUSE Linux Enterprise High Performance Computing 15-LTSS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-2022-200=1

   - SUSE Linux Enterprise High Performance Computing 15-ESPOS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-2022-200=1



Package List:

   - SUSE Linux Enterprise Server for SAP 15 (ppc64le x86_64):

      cargo-1.53.0-3.40.1
      cargo-debuginfo-1.53.0-3.40.1
      rust-1.53.0-3.40.1
      rust-debuginfo-1.53.0-3.40.1
      rust-gdb-1.53.0-3.40.1

   - SUSE Linux Enterprise Server for SAP 15 (noarch):

      rust-src-1.53.0-3.40.1

   - SUSE Linux Enterprise Server for SAP 15 (x86_64):

      rls-1.53.0-3.40.1
      rust-analysis-1.53.0-3.40.1

   - SUSE Linux Enterprise Server 15-LTSS (aarch64 s390x):

      cargo-1.53.0-3.40.1
      cargo-debuginfo-1.53.0-3.40.1
      rust-1.53.0-3.40.1
      rust-debuginfo-1.53.0-3.40.1
      rust-gdb-1.53.0-3.40.1

   - SUSE Linux Enterprise Server 15-LTSS (aarch64):

      rls-1.53.0-3.40.1
      rust-analysis-1.53.0-3.40.1

   - SUSE Linux Enterprise Server 15-LTSS (noarch):

      rust-src-1.53.0-3.40.1

   - SUSE Linux Enterprise High Performance Computing 15-LTSS (aarch64 x86_64):

      cargo-1.53.0-3.40.1
      cargo-debuginfo-1.53.0-3.40.1
      rls-1.53.0-3.40.1
      rust-1.53.0-3.40.1
      rust-analysis-1.53.0-3.40.1
      rust-debuginfo-1.53.0-3.40.1
      rust-gdb-1.53.0-3.40.1

   - SUSE Linux Enterprise High Performance Computing 15-LTSS (noarch):

      rust-src-1.53.0-3.40.1

   - SUSE Linux Enterprise High Performance Computing 15-ESPOS (aarch64 x86_64):

      cargo-1.53.0-3.40.1
      cargo-debuginfo-1.53.0-3.40.1
      rls-1.53.0-3.40.1
      rust-1.53.0-3.40.1
      rust-analysis-1.53.0-3.40.1
      rust-debuginfo-1.53.0-3.40.1
      rust-gdb-1.53.0-3.40.1

   - SUSE Linux Enterprise High Performance Computing 15-ESPOS (noarch):

      rust-src-1.53.0-3.40.1


References:

   https://www.suse.com/security/cve/CVE-2022-21658.html
   https://bugzilla.suse.com/1194767