SUSE: 2022:1297-1 swtpm | LinuxSecurity.com

   SUSE Security Update: Security update for swtpm
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:1297-1
Rating:             low
References:         #1196240 
Cross-References:   CVE-2022-23645
CVSS scores:
                    CVE-2022-23645 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Affected Products:
                    SUSE Linux Enterprise High Performance Computing 15-SP3
                    SUSE Linux Enterprise Micro 5.1
                    SUSE Linux Enterprise Module for Server Applications 15-SP3
                    SUSE Linux Enterprise Server 15-SP3
                    SUSE Linux Enterprise Server for SAP Applications 15-SP3
                    SUSE Manager Proxy 4.2
                    SUSE Manager Server 4.2
                    openSUSE Leap 15.3
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for swtpm fixes the following issues:

   - Update to version 0.5.3
       - CVE-2022-23645: Check header size indicator against expected size
         (bsc#1196240).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-1297=1

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2022-1297=1

   - SUSE Linux Enterprise Module for Server Applications 15-SP3:

      zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP3-2022-1297=1

   - SUSE Linux Enterprise Micro 5.1:

      zypper in -t patch SUSE-SUSE-MicroOS-5.1-2022-1297=1



Package List:

   - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

      swtpm-0.5.3-150300.3.3.1
      swtpm-debuginfo-0.5.3-150300.3.3.1
      swtpm-debugsource-0.5.3-150300.3.3.1
      swtpm-devel-0.5.3-150300.3.3.1

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      swtpm-0.5.3-150300.3.3.1
      swtpm-debuginfo-0.5.3-150300.3.3.1
      swtpm-debugsource-0.5.3-150300.3.3.1
      swtpm-devel-0.5.3-150300.3.3.1

   - SUSE Linux Enterprise Module for Server Applications 15-SP3 (aarch64 ppc64le s390x x86_64):

      swtpm-0.5.3-150300.3.3.1
      swtpm-debuginfo-0.5.3-150300.3.3.1
      swtpm-debugsource-0.5.3-150300.3.3.1
      swtpm-devel-0.5.3-150300.3.3.1

   - SUSE Linux Enterprise Micro 5.1 (aarch64 s390x x86_64):

      swtpm-0.5.3-150300.3.3.1
      swtpm-debuginfo-0.5.3-150300.3.3.1
      swtpm-debugsource-0.5.3-150300.3.3.1


References:

   https://www.suse.com/security/cve/CVE-2022-23645.html
   https://bugzilla.suse.com/1196240

SUSE: 2022:1297-1 swtpm

April 21, 2022
An update that fixes one vulnerability is now available

Summary

This update for swtpm fixes the following issues: - Update to version 0.5.3 - CVE-2022-23645: Check header size indicator against expected size (bsc#1196240). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.4: zypper in -t patch openSUSE-SLE-15.4-2022-1297=1 - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2022-1297=1 - SUSE Linux Enterprise Module for Server Applications 15-SP3: zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP3-2022-1297=1 - SUSE Linux Enterprise Micro 5.1: zypper in -t patch SUSE-SUSE-MicroOS-5.1-2022-1297=1 Package List: - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64): swtpm-0.5.3-150300.3.3.1 swtpm-debuginfo-0.5.3-150300.3.3.1 swtpm-debugsource-0.5.3-150300.3.3.1 swtpm-devel-0.5.3-150300.3.3.1 - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64): swtpm-0.5.3-150300.3.3.1 swtpm-debuginfo-0.5.3-150300.3.3.1 swtpm-debugsource-0.5.3-150300.3.3.1 swtpm-devel-0.5.3-150300.3.3.1 - SUSE Linux Enterprise Module for Server Applications 15-SP3 (aarch64 ppc64le s390x x86_64): swtpm-0.5.3-150300.3.3.1 swtpm-debuginfo-0.5.3-150300.3.3.1 swtpm-debugsource-0.5.3-150300.3.3.1 swtpm-devel-0.5.3-150300.3.3.1 - SUSE Linux Enterprise Micro 5.1 (aarch64 s390x x86_64): swtpm-0.5.3-150300.3.3.1 swtpm-debuginfo-0.5.3-150300.3.3.1 swtpm-debugsource-0.5.3-150300.3.3.1

References

#1196240

Cross- CVE-2022-23645

CVSS scores:

CVE-2022-23645 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Affected Products:

SUSE Linux Enterprise High Performance Computing 15-SP3

SUSE Linux Enterprise Micro 5.1

SUSE Linux Enterprise Module for Server Applications 15-SP3

SUSE Linux Enterprise Server 15-SP3

SUSE Linux Enterprise Server for SAP Applications 15-SP3

SUSE Manager Proxy 4.2

SUSE Manager Server 4.2

openSUSE Leap 15.3

openSUSE Leap 15.4

https://www.suse.com/security/cve/CVE-2022-23645.html

https://bugzilla.suse.com/1196240

Severity
Announcement ID: SUSE-SU-2022:1297-1
Rating: low

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.