SUSE Security Update: Security update for tar
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:1548-1
Rating:             moderate
References:         #1029961 #1120610 #1130496 #1181131 
Cross-References:   CVE-2018-20482 CVE-2019-9923 CVE-2021-20193
                   
CVSS scores:
                    CVE-2018-20482 (NVD) : 4.7 CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H
                    CVE-2018-20482 (SUSE): 5.5 CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
                    CVE-2019-9923 (NVD) : 7.5 CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
                    CVE-2019-9923 (SUSE): 3.3 CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
                    CVE-2021-20193 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
                    CVE-2021-20193 (SUSE): 3.3 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L

Affected Products:
                    SUSE Linux Enterprise Desktop 15-SP3
                    SUSE Linux Enterprise High Performance Computing 15-SP3
                    SUSE Linux Enterprise Micro 5.0
                    SUSE Linux Enterprise Micro 5.1
                    SUSE Linux Enterprise Micro 5.2
                    SUSE Linux Enterprise Module for Basesystem 15-SP3
                    SUSE Linux Enterprise Realtime Extension 15-SP2
                    SUSE Linux Enterprise Server 15-SP3
                    SUSE Linux Enterprise Server for SAP Applications 15-SP3
                    SUSE Manager Proxy 4.2
                    SUSE Manager Server 4.2
                    openSUSE Leap 15.3
______________________________________________________________________________

   An update that solves three vulnerabilities and has one
   errata is now available.

Description:

   This update for tar fixes the following issues:

   - CVE-2021-20193: Fixed a memory leak in read_header() in list.c
     (bsc#1181131).
   - CVE-2019-9923: Fixed a null-pointer dereference in pax_decode_header in
     sparse.c (bsc#1130496).
   - CVE-2018-20482: Fixed infinite read loop in sparse_dump_region in
     sparse.c (bsc#1120610).

   - Update to GNU tar 1.34:
     * Fix extraction over pipe
     * Fix memory leak in read_header (CVE-2021-20193) (bsc#1181131)
     * Fix extraction when . and .. are unreadable
     * Gracefully handle duplicate symlinks when extracting
     * Re-initialize supplementary groups when switching to user privileges

   - Update to GNU tar 1.33:
     * POSIX extended format headers do not include PID by default
     * --delay-directory-restore works for archives with reversed member
       ordering
     * Fix extraction of a symbolic link hardlinked to another symbolic link
     * Wildcards in exclude-vcs-ignore mode don't match slash
     * Fix the --no-overwrite-dir option
     * Fix handling of chained renames in incremental backups
     * Link counting works for file names supplied with -T
     * Accept only position-sensitive (file-selection) options in file list
       files

   - prepare usrmerge (bsc#1029961)

   - Update to GNU 1.32
     * Fix the use of --checkpoint without explicit --checkpoint-action
     * Fix extraction with the -U option
     * Fix iconv usage on BSD-based systems
     * Fix possible NULL dereference (savannah bug #55369) [bsc#1130496]
       [CVE-2019-9923]
     * Improve the testsuite

   - Update to GNU 1.31
     * Fix heap-buffer-overrun with --one-top-level, bug introduced with the
       addition of that option in 1.28
     * Support for zstd compression
     * New option '--zstd' instructs tar to use zstd as compression program.
       When listing, extractng and comparing, zstd compressed archives are
       recognized automatically. When '-a' option is in effect, zstd
       compression is selected if the destination archive name ends in '.zst'
       or '.tzst'.
     * The -K option interacts properly with member names given in the
       command line. Names of members to extract can be specified along with
       the "-K NAME" option. In this case, tar will extract NAME and those of
       named members that appear in the archive after it, which is consistent
       with the semantics of the option. Previous versions of tar extracted
       NAME, those of named members that appeared before it, and everything
       after it.
     * Fix CVE-2018-20482 - When creating archives with the --sparse
       option, previous versions of tar would loop endlessly if a sparse file
        had been truncated while being archived.


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2022-1548=1

   - SUSE Linux Enterprise Realtime Extension 15-SP2:

      zypper in -t patch SUSE-SLE-Product-RT-15-SP2-2022-1548=1

   - SUSE Linux Enterprise Module for Basesystem 15-SP3:

      zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP3-2022-1548=1

   - SUSE Linux Enterprise Micro 5.2:

      zypper in -t patch SUSE-SUSE-MicroOS-5.2-2022-1548=1

   - SUSE Linux Enterprise Micro 5.1:

      zypper in -t patch SUSE-SUSE-MicroOS-5.1-2022-1548=1

   - SUSE Linux Enterprise Micro 5.0:

      zypper in -t patch SUSE-SUSE-MicroOS-5.0-2022-1548=1



Package List:

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      tar-1.34-150000.3.12.1
      tar-debuginfo-1.34-150000.3.12.1
      tar-debugsource-1.34-150000.3.12.1
      tar-rmt-1.34-150000.3.12.1
      tar-rmt-debuginfo-1.34-150000.3.12.1
      tar-tests-1.34-150000.3.12.1
      tar-tests-debuginfo-1.34-150000.3.12.1

   - openSUSE Leap 15.3 (noarch):

      tar-backup-scripts-1.34-150000.3.12.1
      tar-doc-1.34-150000.3.12.1
      tar-lang-1.34-150000.3.12.1

   - SUSE Linux Enterprise Realtime Extension 15-SP2 (x86_64):

      tar-1.34-150000.3.12.1
      tar-debuginfo-1.34-150000.3.12.1
      tar-debugsource-1.34-150000.3.12.1
      tar-rmt-1.34-150000.3.12.1
      tar-rmt-debuginfo-1.34-150000.3.12.1

   - SUSE Linux Enterprise Realtime Extension 15-SP2 (noarch):

      tar-lang-1.34-150000.3.12.1

   - SUSE Linux Enterprise Module for Basesystem 15-SP3 (aarch64 ppc64le s390x x86_64):

      tar-1.34-150000.3.12.1
      tar-debuginfo-1.34-150000.3.12.1
      tar-debugsource-1.34-150000.3.12.1
      tar-rmt-1.34-150000.3.12.1
      tar-rmt-debuginfo-1.34-150000.3.12.1

   - SUSE Linux Enterprise Module for Basesystem 15-SP3 (noarch):

      tar-lang-1.34-150000.3.12.1

   - SUSE Linux Enterprise Micro 5.2 (aarch64 s390x x86_64):

      tar-1.34-150000.3.12.1
      tar-debuginfo-1.34-150000.3.12.1
      tar-debugsource-1.34-150000.3.12.1

   - SUSE Linux Enterprise Micro 5.1 (aarch64 s390x x86_64):

      tar-1.34-150000.3.12.1
      tar-debuginfo-1.34-150000.3.12.1
      tar-debugsource-1.34-150000.3.12.1

   - SUSE Linux Enterprise Micro 5.0 (aarch64 x86_64):

      tar-1.34-150000.3.12.1
      tar-debuginfo-1.34-150000.3.12.1
      tar-debugsource-1.34-150000.3.12.1


References:

   https://www.suse.com/security/cve/CVE-2018-20482.html
   https://www.suse.com/security/cve/CVE-2019-9923.html
   https://www.suse.com/security/cve/CVE-2021-20193.html
   https://bugzilla.suse.com/1029961
   https://bugzilla.suse.com/1120610
   https://bugzilla.suse.com/1130496
   https://bugzilla.suse.com/1181131