SUSE: 2022:1855-1 suse/sle15 Security Update | LinuxSecurity.com
SUSE Container Update Advisory: suse/sle15
-----------------------------------------------------------------
Container Advisory ID : SUSE-CU-2022:1855-1
Container Tags        : suse/sle15:15.1 , suse/sle15:15.1.6.2.656
Container Release     : 6.2.656
Severity              : important
Type                  : security
References            : 1196167 1199223 1199224 1200735 1200737 1202020 CVE-2021-4209
                        CVE-2022-2509 CVE-2022-27781 CVE-2022-27782 CVE-2022-32206 CVE-2022-32208
-----------------------------------------------------------------

The container suse/sle15 was updated. The following patches have been included in this update:

-----------------------------------------------------------------
Advisory ID: SUSE-SU-2022:2829-1
Released:    Wed Aug 17 13:33:11 2022
Summary:     Security update for curl
Type:        security
Severity:    important
References:  1199223,1199224,1200735,1200737,CVE-2022-27781,CVE-2022-27782,CVE-2022-32206,CVE-2022-32208
This update for curl fixes the following issues:

- CVE-2022-27781: Fixed an issue where curl will get stuck in an infinite
  loop when trying to retrieve details about a TLS server's certificate chain (bnc#1199223).
- CVE-2022-27782: Fixed an issue where TLS and SSH connections would
  be reused even when a related option had been changed (bsc#1199224).
- CVE-2022-32206: Fixed an uncontrolled memory consumption issue caused
  by an unbounded number of compression layers (bsc#1200735).
- CVE-2022-32208: Fixed an incorrect message verification issue when
  performing FTP transfers using krb5 (bsc#1200737).

-----------------------------------------------------------------
Advisory ID: SUSE-SU-2022:2830-1
Released:    Wed Aug 17 14:36:26 2022
Summary:     Security update for gnutls
Type:        security
Severity:    important
References:  1196167,1202020,CVE-2021-4209,CVE-2022-2509
This update for gnutls fixes the following issues:

- CVE-2022-2509: Fixed a double free issue during PKCS7 verification (bsc#1202020).
- CVE-2021-4209: Fixed null pointer dereference in MD_UPDATE (bsc#1196167). 


The following package changes have been done:

- libcurl4-7.60.0-150000.33.1 updated
- libgnutls30-3.6.7-150000.6.45.2 updated

SUSE: 2022:1855-1 suse/sle15 Security Update

August 18, 2022
The container suse/sle15 was updated

Summary

Advisory ID: SUSE-SU-2022:2829-1 Released: Wed Aug 17 13:33:11 2022 Summary: Security update for curl Type: security Severity: important Advisory ID: SUSE-SU-2022:2830-1 Released: Wed Aug 17 14:36:26 2022 Summary: Security update for gnutls Type: security Severity: important

References

References : 1196167 1199223 1199224 1200735 1200737 1202020 CVE-2021-4209

CVE-2022-2509 CVE-2022-27781 CVE-2022-27782 CVE-2022-32206 CVE-2022-32208

1199223,1199224,1200735,1200737,CVE-2022-27781,CVE-2022-27782,CVE-2022-32206,CVE-2022-32208

This update for curl fixes the following issues:

- CVE-2022-27781: Fixed an issue where curl will get stuck in an infinite

loop when trying to retrieve details about a TLS server's certificate chain (bnc#1199223).

- CVE-2022-27782: Fixed an issue where TLS and SSH connections would

be reused even when a related option had been changed (bsc#1199224).

- CVE-2022-32206: Fixed an uncontrolled memory consumption issue caused

by an unbounded number of compression layers (bsc#1200735).

- CVE-2022-32208: Fixed an incorrect message verification issue when

performing FTP transfers using krb5 (bsc#1200737).

1196167,1202020,CVE-2021-4209,CVE-2022-2509

This update for gnutls fixes the following issues:

- CVE-2022-2509: Fixed a double free issue during PKCS7 verification (bsc#1202020).

- CVE-2021-4209: Fixed null pointer dereference in MD_UPDATE (bsc#1196167).

The following package changes have been done:

- libcurl4-7.60.0-150000.33.1 updated

- libgnutls30-3.6.7-150000.6.45.2 updated

Severity
Container Advisory ID : SUSE-CU-2022:1855-1
Container Tags : suse/sle15:15.1 , suse/sle15:15.1.6.2.656
Container Release : 6.2.656
Severity : important
Type : security

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.