SUSE Security Update: Security update for rubygem-yajl-ruby
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:1918-1
Rating:             moderate
References:         #1198405 
Cross-References:   CVE-2022-24795
CVSS scores:
                    CVE-2022-24795 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
                    CVE-2022-24795 (SUSE): 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Affected Products:
                    SUSE OpenStack Cloud Crowbar 8
                    SUSE OpenStack Cloud Crowbar 9
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:


   This update for rubygem-yajl-ruby fixes the following issue:

   -CVE-2022-24795: Fixed a heap-based buffer overflow when handling large
    inputs due to an integer overflow (bsc#1198405)


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE OpenStack Cloud Crowbar 9:

      zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2022-1918=1

   - SUSE OpenStack Cloud Crowbar 8:

      zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-8-2022-1918=1



Package List:

   - SUSE OpenStack Cloud Crowbar 9 (x86_64):

      ruby2.1-rubygem-yajl-ruby-1.3.1-4.6.1
      ruby2.1-rubygem-yajl-ruby-debuginfo-1.3.1-4.6.1
      rubygem-yajl-ruby-debugsource-1.3.1-4.6.1

   - SUSE OpenStack Cloud Crowbar 8 (x86_64):

      ruby2.1-rubygem-yajl-ruby-1.3.1-4.6.1
      ruby2.1-rubygem-yajl-ruby-debuginfo-1.3.1-4.6.1
      rubygem-yajl-ruby-debugsource-1.3.1-4.6.1


References:

   https://www.suse.com/security/cve/CVE-2022-24795.html
   https://bugzilla.suse.com/1198405