SUSE: 2022:2197-1 moderate: openssl-1_0_0

Advisories


   SUSE Security Update: Security update for openssl-1_0_0
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:2197-1
Rating:             moderate
References:         #1199166 #1200550 
Cross-References:   CVE-2022-1292 CVE-2022-2068
CVSS scores:
                    CVE-2022-1292 (NVD) : 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-1292 (SUSE): 6.7 CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-2068 (SUSE): 6.7 CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Affected Products:
                    SUSE Linux Enterprise High Performance Computing
                    SUSE Linux Enterprise Module for Legacy Software 12
                    SUSE Linux Enterprise Server
                    SUSE Linux Enterprise Server for SAP 12-SP3
                    SUSE Linux Enterprise Server for SAP 12-SP4
                    SUSE Linux Enterprise Server for SAP 12-SP5
                    SUSE Linux Enterprise Server for SAP Applications
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for openssl-1_0_0 fixes the following issues:

   - CVE-2022-1292: Fixed command injection in c_rehash (bsc#1199166).
   - CVE-2022-2068: Fixed more shell code injection issues in c_rehash.
     (bsc#1200550)


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Server for SAP 12-SP5:

      zypper in -t patch SUSE-SLE-SAP-12-SP5-2022-2197=1

   - SUSE Linux Enterprise Server for SAP 12-SP4:

      zypper in -t patch SUSE-SLE-SAP-12-SP4-2022-2197=1

   - SUSE Linux Enterprise Server for SAP 12-SP3:

      zypper in -t patch SUSE-SLE-SAP-12-SP3-2022-2197=1

   - SUSE Linux Enterprise Module for Legacy Software 12:

      zypper in -t patch SUSE-SLE-Module-Legacy-12-2022-2197=1



Package List:

   - SUSE Linux Enterprise Server for SAP 12-SP5 (x86_64):

      compat-openssl098-debugsource-0.9.8j-106.36.1
      libopenssl0_9_8-0.9.8j-106.36.1
      libopenssl0_9_8-debuginfo-0.9.8j-106.36.1

   - SUSE Linux Enterprise Server for SAP 12-SP4 (x86_64):

      compat-openssl098-debugsource-0.9.8j-106.36.1
      libopenssl0_9_8-0.9.8j-106.36.1
      libopenssl0_9_8-debuginfo-0.9.8j-106.36.1

   - SUSE Linux Enterprise Server for SAP 12-SP3 (x86_64):

      compat-openssl098-debugsource-0.9.8j-106.36.1
      libopenssl0_9_8-0.9.8j-106.36.1
      libopenssl0_9_8-debuginfo-0.9.8j-106.36.1

   - SUSE Linux Enterprise Module for Legacy Software 12 (s390x x86_64):

      compat-openssl098-debugsource-0.9.8j-106.36.1
      libopenssl0_9_8-0.9.8j-106.36.1
      libopenssl0_9_8-32bit-0.9.8j-106.36.1
      libopenssl0_9_8-debuginfo-0.9.8j-106.36.1
      libopenssl0_9_8-debuginfo-32bit-0.9.8j-106.36.1


References:

   https://www.suse.com/security/cve/CVE-2022-1292.html
   https://www.suse.com/security/cve/CVE-2022-2068.html
   https://bugzilla.suse.com/1199166
   https://bugzilla.suse.com/1200550

SUSE: 2022:2197-1 moderate: openssl-1_0_0

June 28, 2022
An update that fixes two vulnerabilities is now available

Summary

This update for openssl-1_0_0 fixes the following issues: - CVE-2022-1292: Fixed command injection in c_rehash (bsc#1199166). - CVE-2022-2068: Fixed more shell code injection issues in c_rehash. (bsc#1200550) Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - SUSE Linux Enterprise Server for SAP 12-SP5: zypper in -t patch SUSE-SLE-SAP-12-SP5-2022-2197=1 - SUSE Linux Enterprise Server for SAP 12-SP4: zypper in -t patch SUSE-SLE-SAP-12-SP4-2022-2197=1 - SUSE Linux Enterprise Server for SAP 12-SP3: zypper in -t patch SUSE-SLE-SAP-12-SP3-2022-2197=1 - SUSE Linux Enterprise Module for Legacy Software 12: zypper in -t patch SUSE-SLE-Module-Legacy-12-2022-2197=1 Package List: - SUSE Linux Enterprise Server for SAP 12-SP5 (x86_64): compat-openssl098-debugsource-0.9.8j-106.36.1 libopenssl0_9_8-0.9.8j-106.36.1 libopenssl0_9_8-debuginfo-0.9.8j-106.36.1 - SUSE Linux Enterprise Server for SAP 12-SP4 (x86_64): compat-openssl098-debugsource-0.9.8j-106.36.1 libopenssl0_9_8-0.9.8j-106.36.1 libopenssl0_9_8-debuginfo-0.9.8j-106.36.1 - SUSE Linux Enterprise Server for SAP 12-SP3 (x86_64): compat-openssl098-debugsource-0.9.8j-106.36.1 libopenssl0_9_8-0.9.8j-106.36.1 libopenssl0_9_8-debuginfo-0.9.8j-106.36.1 - SUSE Linux Enterprise Module for Legacy Software 12 (s390x x86_64): compat-openssl098-debugsource-0.9.8j-106.36.1 libopenssl0_9_8-0.9.8j-106.36.1 libopenssl0_9_8-32bit-0.9.8j-106.36.1 libopenssl0_9_8-debuginfo-0.9.8j-106.36.1 libopenssl0_9_8-debuginfo-32bit-0.9.8j-106.36.1

References

#1199166 #1200550

Cross- CVE-2022-1292 CVE-2022-2068

CVSS scores:

CVE-2022-1292 (NVD) : 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

CVE-2022-1292 (SUSE): 6.7 CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

CVE-2022-2068 (SUSE): 6.7 CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Affected Products:

SUSE Linux Enterprise High Performance Computing

SUSE Linux Enterprise Module for Legacy Software 12

SUSE Linux Enterprise Server

SUSE Linux Enterprise Server for SAP 12-SP3

SUSE Linux Enterprise Server for SAP 12-SP4

SUSE Linux Enterprise Server for SAP 12-SP5

SUSE Linux Enterprise Server for SAP Applications

https://www.suse.com/security/cve/CVE-2022-1292.html

https://www.suse.com/security/cve/CVE-2022-2068.html

https://bugzilla.suse.com/1199166

https://bugzilla.suse.com/1200550

Severity
Announcement ID: SUSE-SU-2022:2197-1
Rating: moderate

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.