SUSE: 2022:2199-1 bci/nodejs Security Update | LinuxSecurity.com
SUSE Container Update Advisory: bci/nodejs
-----------------------------------------------------------------
Container Advisory ID : SUSE-CU-2022:2199-1
Container Tags        : bci/node:16 , bci/node:16-9.29 , bci/node:latest , bci/nodejs:16 , bci/nodejs:16-9.29 , bci/nodejs:latest
Container Release     : 9.29
Severity              : moderate
Type                  : security
References            : 1200303 1200517 1201710 1202382 1202383 CVE-2022-29244 CVE-2022-31150
                        CVE-2022-35948 CVE-2022-35949 
-----------------------------------------------------------------

The container bci/nodejs was updated. The following patches have been included in this update:

-----------------------------------------------------------------
Advisory ID: SUSE-SU-2022:3250-1
Released:    Mon Sep 12 09:06:45 2022
Summary:     Security update for nodejs16
Type:        security
Severity:    moderate
References:  1200303,1200517,1201710,1202382,1202383,CVE-2022-29244,CVE-2022-31150,CVE-2022-35948,CVE-2022-35949
This update for nodejs16 fixes the following issues:

- CVE-2022-35949: Fixed SSRF when an application takes in user input into the path/pathname option of undici.request (bsc#1202382).
- CVE-2022-35948: Fixed CRLF injection via Content-Type (bsc#1202383).
- CVE-2022-29244: Fixed npm pack ignores root-level .gitignore and .npmignore file exclusion directives when run in a workspace (bsc#1200517).
- CVE-2022-31150: Fixed CRLF injection in node-undici (bsc#1201710).

Bugfixes:

- Enable crypto-policies for SLE15 SP4+ and TW (bsc#1200303)


The following package changes have been done:

- nodejs16-16.17.0-150400.3.6.1 updated
- npm16-16.17.0-150400.3.6.1 updated

SUSE: 2022:2199-1 bci/nodejs Security Update

September 13, 2022
The container bci/nodejs was updated

Summary

Advisory ID: SUSE-SU-2022:3250-1 Released: Mon Sep 12 09:06:45 2022 Summary: Security update for nodejs16 Type: security Severity: moderate

References

References : 1200303 1200517 1201710 1202382 1202383 CVE-2022-29244 CVE-2022-31150

CVE-2022-35948 CVE-2022-35949

1200303,1200517,1201710,1202382,1202383,CVE-2022-29244,CVE-2022-31150,CVE-2022-35948,CVE-2022-35949

This update for nodejs16 fixes the following issues:

- CVE-2022-35949: Fixed SSRF when an application takes in user input into the path/pathname option of undici.request (bsc#1202382).

- CVE-2022-35948: Fixed CRLF injection via Content-Type (bsc#1202383).

- CVE-2022-29244: Fixed npm pack ignores root-level .gitignore and .npmignore file exclusion directives when run in a workspace (bsc#1200517).

- CVE-2022-31150: Fixed CRLF injection in node-undici (bsc#1201710).

Bugfixes:

- Enable crypto-policies for SLE15 SP4+ and TW (bsc#1200303)

The following package changes have been done:

- nodejs16-16.17.0-150400.3.6.1 updated

- npm16-16.17.0-150400.3.6.1 updated

Severity
Container Advisory ID : SUSE-CU-2022:2199-1
Container Tags : bci/node:16 , bci/node:16-9.29 , bci/node:latest , bci/nodejs:16 , bci/nodejs:16-9.29 , bci/nodejs:latest
Container Release : 9.29
Severity : moderate
Type : security

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.