SUSE: 2022:2277-1 moderate: haproxy | LinuxSecurity.com

Advisories


   SUSE Security Update: Security update for haproxy
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:2277-1
Rating:             moderate
References:         #1196408 
Cross-References:   CVE-2022-0711
CVSS scores:
                    CVE-2022-0711 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
                    CVE-2022-0711 (SUSE): 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Affected Products:
                    SUSE Linux Enterprise High Availability 15-SP4
                    SUSE Linux Enterprise High Performance Computing 15-SP4
                    SUSE Linux Enterprise Server 15-SP4
                    SUSE Linux Enterprise Server for SAP Applications 15-SP4
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for haproxy fixes the following issues:

   - CVE-2022-0711: haproxy: Denial of service via set-cookie2 header
     (bsc#1196408).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-2277=1

   - SUSE Linux Enterprise High Availability 15-SP4:

      zypper in -t patch SUSE-SLE-Product-HA-15-SP4-2022-2277=1



Package List:

   - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

      haproxy-2.4.8+git0.d1f8d41e0-150400.3.3.13
      haproxy-debuginfo-2.4.8+git0.d1f8d41e0-150400.3.3.13
      haproxy-debugsource-2.4.8+git0.d1f8d41e0-150400.3.3.13

   - SUSE Linux Enterprise High Availability 15-SP4 (aarch64 ppc64le s390x x86_64):

      haproxy-2.4.8+git0.d1f8d41e0-150400.3.3.13
      haproxy-debuginfo-2.4.8+git0.d1f8d41e0-150400.3.3.13
      haproxy-debugsource-2.4.8+git0.d1f8d41e0-150400.3.3.13


References:

   https://www.suse.com/security/cve/CVE-2022-0711.html
   https://bugzilla.suse.com/1196408

SUSE: 2022:2277-1 moderate: haproxy

July 6, 2022
An update that fixes one vulnerability is now available

Summary

This update for haproxy fixes the following issues: - CVE-2022-0711: haproxy: Denial of service via set-cookie2 header (bsc#1196408). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.4: zypper in -t patch openSUSE-SLE-15.4-2022-2277=1 - SUSE Linux Enterprise High Availability 15-SP4: zypper in -t patch SUSE-SLE-Product-HA-15-SP4-2022-2277=1 Package List: - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64): haproxy-2.4.8+git0.d1f8d41e0-150400.3.3.13 haproxy-debuginfo-2.4.8+git0.d1f8d41e0-150400.3.3.13 haproxy-debugsource-2.4.8+git0.d1f8d41e0-150400.3.3.13 - SUSE Linux Enterprise High Availability 15-SP4 (aarch64 ppc64le s390x x86_64): haproxy-2.4.8+git0.d1f8d41e0-150400.3.3.13 haproxy-debuginfo-2.4.8+git0.d1f8d41e0-150400.3.3.13 haproxy-debugsource-2.4.8+git0.d1f8d41e0-150400.3.3.13

References

#1196408

Cross- CVE-2022-0711

CVSS scores:

CVE-2022-0711 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

CVE-2022-0711 (SUSE): 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Affected Products:

SUSE Linux Enterprise High Availability 15-SP4

SUSE Linux Enterprise High Performance Computing 15-SP4

SUSE Linux Enterprise Server 15-SP4

SUSE Linux Enterprise Server for SAP Applications 15-SP4

openSUSE Leap 15.4

https://www.suse.com/security/cve/CVE-2022-0711.html

https://bugzilla.suse.com/1196408

Severity
Announcement ID: SUSE-SU-2022:2277-1
Rating: moderate

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.