SUSE: 2022:2298-1 important: liblouis

Advisories


   SUSE Security Update: Security update for liblouis
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:2298-1
Rating:             important
References:         #1197085 #1200120 
Cross-References:   CVE-2022-26981 CVE-2022-31783
CVSS scores:
                    CVE-2022-26981 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2022-26981 (SUSE): 7.1 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:H
                    CVE-2022-31783 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
                    CVE-2022-31783 (SUSE): 6.1 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:H

Affected Products:
                    SUSE Linux Enterprise Desktop 15-SP4
                    SUSE Linux Enterprise High Performance Computing 15-SP4
                    SUSE Linux Enterprise Module for Desktop Applications 15-SP4
                    SUSE Linux Enterprise Server 15-SP4
                    SUSE Linux Enterprise Server for SAP Applications 15-SP4
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for liblouis fixes the following issues:

   - CVE-2022-26981: fix buffer overrun in compilePassOpcode (bsc#1197085).
   - CVE-2022-31783: prevent an invalid memory write in compileRule
     (bsc#1200120).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-2298=1

   - SUSE Linux Enterprise Module for Desktop Applications 15-SP4:

      zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-SP4-2022-2298=1



Package List:

   - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

      liblouis-debuginfo-3.20.0-150400.3.3.1
      liblouis-debugsource-3.20.0-150400.3.3.1
      liblouis-devel-3.20.0-150400.3.3.1
      liblouis-doc-3.20.0-150400.3.3.1
      liblouis-tools-3.20.0-150400.3.3.1
      liblouis-tools-debuginfo-3.20.0-150400.3.3.1
      liblouis20-3.20.0-150400.3.3.1
      liblouis20-debuginfo-3.20.0-150400.3.3.1
      python3-louis-3.20.0-150400.3.3.1

   - openSUSE Leap 15.4 (noarch):

      liblouis-data-3.20.0-150400.3.3.1

   - SUSE Linux Enterprise Module for Desktop Applications 15-SP4 (aarch64 ppc64le s390x x86_64):

      liblouis-debuginfo-3.20.0-150400.3.3.1
      liblouis-debugsource-3.20.0-150400.3.3.1
      liblouis-devel-3.20.0-150400.3.3.1
      liblouis20-3.20.0-150400.3.3.1
      liblouis20-debuginfo-3.20.0-150400.3.3.1
      python3-louis-3.20.0-150400.3.3.1

   - SUSE Linux Enterprise Module for Desktop Applications 15-SP4 (noarch):

      liblouis-data-3.20.0-150400.3.3.1


References:

   https://www.suse.com/security/cve/CVE-2022-26981.html
   https://www.suse.com/security/cve/CVE-2022-31783.html
   https://bugzilla.suse.com/1197085
   https://bugzilla.suse.com/1200120

SUSE: 2022:2298-1 important: liblouis

July 6, 2022
An update that fixes two vulnerabilities is now available

Summary

This update for liblouis fixes the following issues: - CVE-2022-26981: fix buffer overrun in compilePassOpcode (bsc#1197085). - CVE-2022-31783: prevent an invalid memory write in compileRule (bsc#1200120). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.4: zypper in -t patch openSUSE-SLE-15.4-2022-2298=1 - SUSE Linux Enterprise Module for Desktop Applications 15-SP4: zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-SP4-2022-2298=1 Package List: - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64): liblouis-debuginfo-3.20.0-150400.3.3.1 liblouis-debugsource-3.20.0-150400.3.3.1 liblouis-devel-3.20.0-150400.3.3.1 liblouis-doc-3.20.0-150400.3.3.1 liblouis-tools-3.20.0-150400.3.3.1 liblouis-tools-debuginfo-3.20.0-150400.3.3.1 liblouis20-3.20.0-150400.3.3.1 liblouis20-debuginfo-3.20.0-150400.3.3.1 python3-louis-3.20.0-150400.3.3.1 - openSUSE Leap 15.4 (noarch): liblouis-data-3.20.0-150400.3.3.1 - SUSE Linux Enterprise Module for Desktop Applications 15-SP4 (aarch64 ppc64le s390x x86_64): liblouis-debuginfo-3.20.0-150400.3.3.1 liblouis-debugsource-3.20.0-150400.3.3.1 liblouis-devel-3.20.0-150400.3.3.1 liblouis20-3.20.0-150400.3.3.1 liblouis20-debuginfo-3.20.0-150400.3.3.1 python3-louis-3.20.0-150400.3.3.1 - SUSE Linux Enterprise Module for Desktop Applications 15-SP4 (noarch): liblouis-data-3.20.0-150400.3.3.1

References

#1197085 #1200120

Cross- CVE-2022-26981 CVE-2022-31783

CVSS scores:

CVE-2022-26981 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE-2022-26981 (SUSE): 7.1 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:H

CVE-2022-31783 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

CVE-2022-31783 (SUSE): 6.1 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:H

Affected Products:

SUSE Linux Enterprise Desktop 15-SP4

SUSE Linux Enterprise High Performance Computing 15-SP4

SUSE Linux Enterprise Module for Desktop Applications 15-SP4

SUSE Linux Enterprise Server 15-SP4

SUSE Linux Enterprise Server for SAP Applications 15-SP4

openSUSE Leap 15.4

https://www.suse.com/security/cve/CVE-2022-26981.html

https://www.suse.com/security/cve/CVE-2022-31783.html

https://bugzilla.suse.com/1197085

https://bugzilla.suse.com/1200120

Severity
Announcement ID: SUSE-SU-2022:2298-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.