SUSE: 2022:2718-1 moderate: ncurses | LinuxSecurity.com

Advisories


   SUSE Security Update: Security update for ncurses
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:2718-1
Rating:             moderate
References:         #1198627 
Cross-References:   CVE-2022-29458
CVSS scores:
                    CVE-2022-29458 (NVD) : 7.1 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
                    CVE-2022-29458 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Affected Products:
                    SUSE Linux Enterprise Server 12-SP5
                    SUSE Linux Enterprise Server for SAP Applications 12-SP5
                    SUSE Linux Enterprise Software Development Kit 12-SP5
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for ncurses fixes the following issues:

   - CVE-2022-29458: Fixed segfaulting out-of-bounds read in convert_strings
     in tinfo/read_entry.c (bsc#1198627).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Software Development Kit 12-SP5:

      zypper in -t patch SUSE-SLE-SDK-12-SP5-2022-2718=1

   - SUSE Linux Enterprise Server 12-SP5:

      zypper in -t patch SUSE-SLE-SERVER-12-SP5-2022-2718=1



Package List:

   - SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 ppc64le s390x x86_64):

      ncurses-debugsource-5.9-78.1
      ncurses-devel-5.9-78.1
      ncurses-devel-debuginfo-5.9-78.1

   - SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64):

      libncurses5-5.9-78.1
      libncurses5-debuginfo-5.9-78.1
      libncurses6-5.9-78.1
      libncurses6-debuginfo-5.9-78.1
      ncurses-debugsource-5.9-78.1
      ncurses-devel-5.9-78.1
      ncurses-devel-debuginfo-5.9-78.1
      ncurses-utils-5.9-78.1
      ncurses-utils-debuginfo-5.9-78.1
      tack-5.9-78.1
      tack-debuginfo-5.9-78.1
      terminfo-5.9-78.1
      terminfo-base-5.9-78.1

   - SUSE Linux Enterprise Server 12-SP5 (s390x x86_64):

      libncurses5-32bit-5.9-78.1
      libncurses5-debuginfo-32bit-5.9-78.1
      libncurses6-32bit-5.9-78.1
      libncurses6-debuginfo-32bit-5.9-78.1
      ncurses-devel-32bit-5.9-78.1
      ncurses-devel-debuginfo-32bit-5.9-78.1


References:

   https://www.suse.com/security/cve/CVE-2022-29458.html
   https://bugzilla.suse.com/1198627

SUSE: 2022:2718-1 moderate: ncurses

August 9, 2022
An update that fixes one vulnerability is now available

Summary

This update for ncurses fixes the following issues: - CVE-2022-29458: Fixed segfaulting out-of-bounds read in convert_strings in tinfo/read_entry.c (bsc#1198627). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - SUSE Linux Enterprise Software Development Kit 12-SP5: zypper in -t patch SUSE-SLE-SDK-12-SP5-2022-2718=1 - SUSE Linux Enterprise Server 12-SP5: zypper in -t patch SUSE-SLE-SERVER-12-SP5-2022-2718=1 Package List: - SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 ppc64le s390x x86_64): ncurses-debugsource-5.9-78.1 ncurses-devel-5.9-78.1 ncurses-devel-debuginfo-5.9-78.1 - SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64): libncurses5-5.9-78.1 libncurses5-debuginfo-5.9-78.1 libncurses6-5.9-78.1 libncurses6-debuginfo-5.9-78.1 ncurses-debugsource-5.9-78.1 ncurses-devel-5.9-78.1 ncurses-devel-debuginfo-5.9-78.1 ncurses-utils-5.9-78.1 ncurses-utils-debuginfo-5.9-78.1 tack-5.9-78.1 tack-debuginfo-5.9-78.1 terminfo-5.9-78.1 terminfo-base-5.9-78.1 - SUSE Linux Enterprise Server 12-SP5 (s390x x86_64): libncurses5-32bit-5.9-78.1 libncurses5-debuginfo-32bit-5.9-78.1 libncurses6-32bit-5.9-78.1 libncurses6-debuginfo-32bit-5.9-78.1 ncurses-devel-32bit-5.9-78.1 ncurses-devel-debuginfo-32bit-5.9-78.1

References

#1198627

Cross- CVE-2022-29458

CVSS scores:

CVE-2022-29458 (NVD) : 7.1 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H

CVE-2022-29458 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Affected Products:

SUSE Linux Enterprise Server 12-SP5

SUSE Linux Enterprise Server for SAP Applications 12-SP5

SUSE Linux Enterprise Software Development Kit 12-SP5

https://www.suse.com/security/cve/CVE-2022-29458.html

https://bugzilla.suse.com/1198627

Severity
Announcement ID: SUSE-SU-2022:2718-1
Rating: moderate

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.