SUSE: 2022:2765-1 important: rubygem-tzinfo | LinuxSecurity.com

Advisories


   SUSE Security Update: Security update for rubygem-tzinfo
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:2765-1
Rating:             important
References:         #1201835 
Cross-References:   CVE-2022-31163
CVSS scores:
                    CVE-2022-31163 (NVD) : 8.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-31163 (SUSE): 7.5 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Affected Products:
                    SUSE OpenStack Cloud Crowbar 8
                    SUSE OpenStack Cloud Crowbar 9
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for rubygem-tzinfo fixes the following issues:

   - CVE-2022-31163: Fixed relative path traversal vulnerability that allows
     TZInfo::Timezone.get to load arbitrary files (bsc#1201835).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE OpenStack Cloud Crowbar 9:

      zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2022-2765=1

   - SUSE OpenStack Cloud Crowbar 8:

      zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-8-2022-2765=1



Package List:

   - SUSE OpenStack Cloud Crowbar 9 (x86_64):

      ruby2.1-rubygem-tzinfo-1.2.2-3.3.1

   - SUSE OpenStack Cloud Crowbar 8 (x86_64):

      ruby2.1-rubygem-tzinfo-1.2.2-3.3.1


References:

   https://www.suse.com/security/cve/CVE-2022-31163.html
   https://bugzilla.suse.com/1201835

SUSE: 2022:2765-1 important: rubygem-tzinfo

August 10, 2022
An update that fixes one vulnerability is now available

Summary

This update for rubygem-tzinfo fixes the following issues: - CVE-2022-31163: Fixed relative path traversal vulnerability that allows TZInfo::Timezone.get to load arbitrary files (bsc#1201835). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - SUSE OpenStack Cloud Crowbar 9: zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2022-2765=1 - SUSE OpenStack Cloud Crowbar 8: zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-8-2022-2765=1 Package List: - SUSE OpenStack Cloud Crowbar 9 (x86_64): ruby2.1-rubygem-tzinfo-1.2.2-3.3.1 - SUSE OpenStack Cloud Crowbar 8 (x86_64): ruby2.1-rubygem-tzinfo-1.2.2-3.3.1

References

#1201835

Cross- CVE-2022-31163

CVSS scores:

CVE-2022-31163 (NVD) : 8.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

CVE-2022-31163 (SUSE): 7.5 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Affected Products:

SUSE OpenStack Cloud Crowbar 8

SUSE OpenStack Cloud Crowbar 9

https://www.suse.com/security/cve/CVE-2022-31163.html

https://bugzilla.suse.com/1201835

Severity
Announcement ID: SUSE-SU-2022:2765-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.