SUSE: 2022:3583-1 important: python-waitress | LinuxSecurity.com

   SUSE Security Update: Security update for python-waitress
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:3583-1
Rating:             important
References:         #1197255 
Cross-References:   CVE-2022-24761
CVSS scores:
                    CVE-2022-24761 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
                    CVE-2022-24761 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Affected Products:
                    SUSE OpenStack Cloud 9
                    SUSE OpenStack Cloud Crowbar 9
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for python-waitress fixes the following issues:

   - CVE-2022-24761: Fixed a bug to avoid inconsistent interpretation of HTTP
     requests leading to request smuggling. (bsc#1197256)


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE OpenStack Cloud Crowbar 9:

      zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2022-3583=1

   - SUSE OpenStack Cloud 9:

      zypper in -t patch SUSE-OpenStack-Cloud-9-2022-3583=1



Package List:

   - SUSE OpenStack Cloud Crowbar 9 (noarch):

      python-waitress-1.4.3-3.6.1

   - SUSE OpenStack Cloud 9 (noarch):

      python-waitress-1.4.3-3.6.1


References:

   https://www.suse.com/security/cve/CVE-2022-24761.html
   https://bugzilla.suse.com/1197255

SUSE: 2022:3583-1 important: python-waitress

October 14, 2022
An update that fixes one vulnerability is now available

Summary

This update for python-waitress fixes the following issues: - CVE-2022-24761: Fixed a bug to avoid inconsistent interpretation of HTTP requests leading to request smuggling. (bsc#1197256) Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - SUSE OpenStack Cloud Crowbar 9: zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2022-3583=1 - SUSE OpenStack Cloud 9: zypper in -t patch SUSE-OpenStack-Cloud-9-2022-3583=1 Package List: - SUSE OpenStack Cloud Crowbar 9 (noarch): python-waitress-1.4.3-3.6.1 - SUSE OpenStack Cloud 9 (noarch): python-waitress-1.4.3-3.6.1

References

#1197255

Cross- CVE-2022-24761

CVSS scores:

CVE-2022-24761 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

CVE-2022-24761 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Affected Products:

SUSE OpenStack Cloud 9

SUSE OpenStack Cloud Crowbar 9

https://www.suse.com/security/cve/CVE-2022-24761.html

https://bugzilla.suse.com/1197255

Severity
Announcement ID: SUSE-SU-2022:3583-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.