SUSE: 2022:3628-1 important: the Linux Kernel (Live Patch 1 for SLE...

   SUSE Security Update: Security update for the Linux Kernel (Live Patch 1 for SLE 15 SP4)
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:3628-1
Rating:             important
References:         #1203067 #1203994 #1204290 #1204291 #1204292 
                    
Cross-References:   CVE-2022-39189 CVE-2022-41674 CVE-2022-42719
                    CVE-2022-42720 CVE-2022-42721
CVSS scores:
                    CVE-2022-39189 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-39189 (SUSE): 7 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-41674 (NVD) : 8.1 CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
                    CVE-2022-41674 (SUSE): 8.8 CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-42719 (NVD) : 8.8 CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-42719 (SUSE): 7.5 CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-42720 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-42720 (SUSE): 7.5 CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-42721 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
                    CVE-2022-42721 (SUSE): 7.5 CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Affected Products:
                    SUSE Linux Enterprise High Performance Computing 15-SP4
                    SUSE Linux Enterprise Module for Live Patching 15-SP4
                    SUSE Linux Enterprise Server 15-SP4
                    SUSE Linux Enterprise Server for SAP Applications 15-SP4
______________________________________________________________________________

   An update that fixes 5 vulnerabilities is now available.

Description:

   This update for the Linux Kernel 5.14.21-150400_24_11 fixes several issues.

   The following security issues were fixed:

   - CVE-2022-41674: Fixed buffer overflow that can be triggered by injected
     WLAN frames (bsc#1203994).
   - CVE-2022-42719: Fixed use-after-free in the mac80211 stack when parsing
     a multi-BSSID element (bsc#1204292).
   - CVE-2022-42720: Fixed refcounting bugs in the multi-BSS handling of the
     mac80211 stack (bsc#1204291).
   - CVE-2022-42721: Fixed list management bug in BSS handling of the
     mac80211 stack (bsc#1204290).
   - CVE-2022-39189: Fixed mishandled TLB flush operation in certain
     KVM_VCPU_PREEMPTED situations (bsc#1203067).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Module for Live Patching 15-SP4:

      zypper in -t patch SUSE-SLE-Module-Live-Patching-15-SP4-2022-3628=1 SUSE-SLE-Module-Live-Patching-15-SP4-2022-3632=1



Package List:

   - SUSE Linux Enterprise Module for Live Patching 15-SP4 (ppc64le s390x x86_64):

      kernel-livepatch-5_14_21-150400_22-default-7-150400.4.18.3
      kernel-livepatch-5_14_21-150400_22-default-debuginfo-7-150400.4.18.3
      kernel-livepatch-5_14_21-150400_24_11-default-4-150400.2.1
      kernel-livepatch-5_14_21-150400_24_11-default-debuginfo-4-150400.2.1
      kernel-livepatch-SLE15-SP4_Update_0-debugsource-7-150400.4.18.3
      kernel-livepatch-SLE15-SP4_Update_1-debugsource-4-150400.2.1


References:

   https://www.suse.com/security/cve/CVE-2022-39189.html
   https://www.suse.com/security/cve/CVE-2022-41674.html
   https://www.suse.com/security/cve/CVE-2022-42719.html
   https://www.suse.com/security/cve/CVE-2022-42720.html
   https://www.suse.com/security/cve/CVE-2022-42721.html
   https://bugzilla.suse.com/1203067
   https://bugzilla.suse.com/1203994
   https://bugzilla.suse.com/1204290
   https://bugzilla.suse.com/1204291
   https://bugzilla.suse.com/1204292

SUSE: 2022:3628-1 important: the Linux Kernel (Live Patch 1 for SLE 15 SP4)

October 18, 2022
An update that fixes 5 vulnerabilities is now available

Summary

This update for the Linux Kernel 5.14.21-150400_24_11 fixes several issues. The following security issues were fixed: - CVE-2022-41674: Fixed buffer overflow that can be triggered by injected WLAN frames (bsc#1203994). - CVE-2022-42719: Fixed use-after-free in the mac80211 stack when parsing a multi-BSSID element (bsc#1204292). - CVE-2022-42720: Fixed refcounting bugs in the multi-BSS handling of the mac80211 stack (bsc#1204291). - CVE-2022-42721: Fixed list management bug in BSS handling of the mac80211 stack (bsc#1204290). - CVE-2022-39189: Fixed mishandled TLB flush operation in certain KVM_VCPU_PREEMPTED situations (bsc#1203067). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - SUSE Linux Enterprise Module for Live Patching 15-SP4: zypper in -t patch SUSE-SLE-Module-Live-Patching-15-SP4-2022-3628=1 SUSE-SLE-Module-Live-Patching-15-SP4-2022-3632=1 Package List: - SUSE Linux Enterprise Module for Live Patching 15-SP4 (ppc64le s390x x86_64): kernel-livepatch-5_14_21-150400_22-default-7-150400.4.18.3 kernel-livepatch-5_14_21-150400_22-default-debuginfo-7-150400.4.18.3 kernel-livepatch-5_14_21-150400_24_11-default-4-150400.2.1 kernel-livepatch-5_14_21-150400_24_11-default-debuginfo-4-150400.2.1 kernel-livepatch-SLE15-SP4_Update_0-debugsource-7-150400.4.18.3 kernel-livepatch-SLE15-SP4_Update_1-debugsource-4-150400.2.1

References

#1203067 #1203994 #1204290 #1204291 #1204292

Cross- CVE-2022-39189 CVE-2022-41674 CVE-2022-42719

CVE-2022-42720 CVE-2022-42721

CVSS scores:

CVE-2022-39189 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

CVE-2022-39189 (SUSE): 7 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

CVE-2022-41674 (NVD) : 8.1 CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

CVE-2022-41674 (SUSE): 8.8 CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

CVE-2022-42719 (NVD) : 8.8 CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

CVE-2022-42719 (SUSE): 7.5 CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

CVE-2022-42720 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

CVE-2022-42720 (SUSE): 7.5 CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

CVE-2022-42721 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

CVE-2022-42721 (SUSE): 7.5 CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Affected Products:

SUSE Linux Enterprise High Performance Computing 15-SP4

SUSE Linux Enterprise Module for Live Patching 15-SP4

SUSE Linux Enterprise Server 15-SP4

SUSE Linux Enterprise Server for SAP Applications 15-SP4

https://www.suse.com/security/cve/CVE-2022-39189.html

https://www.suse.com/security/cve/CVE-2022-41674.html

https://www.suse.com/security/cve/CVE-2022-42719.html

https://www.suse.com/security/cve/CVE-2022-42720.html

https://www.suse.com/security/cve/CVE-2022-42721.html

https://bugzilla.suse.com/1203067

https://bugzilla.suse.com/1203994

https://bugzilla.suse.com/1204290

https://bugzilla.suse.com/1204291

https://bugzilla.suse.com/1204292

Severity
Announcement ID: SUSE-SU-2022:3628-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.