SUSE: 2022:4240-1 important: sudo | LinuxSecurity.com

   SUSE Security Update: Security update for sudo
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:4240-1
Rating:             important
References:         #1197998 #1203201 #1204986 
Cross-References:   CVE-2022-43995
CVSS scores:
                    CVE-2022-43995 (NVD) : 7.1 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H
                    CVE-2022-43995 (SUSE): 7.1 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H

Affected Products:
                    SUSE Linux Enterprise Server 12-SP3-BCL
                    SUSE Linux Enterprise Server 12-SP4-LTSS
                    SUSE Linux Enterprise Server for SAP 12-SP4
                    SUSE OpenStack Cloud 9
                    SUSE OpenStack Cloud Crowbar 9
______________________________________________________________________________

   An update that solves one vulnerability and has two fixes
   is now available.

Description:

   This update for sudo fixes the following issues:

   Security fixes:

   - CVE-2022-43995: Fixed a potential heap-based buffer over-read when
     entering a password of seven characters or fewer and using the crypt()
     password backend (bsc#1204986).

   Other:

   - Make sure SIGCHLD is not ignored when sudo is executed; fixes race
     condition (bsc#1203201).
   - Change sudo-ldap schema from ASCII to UTF8 (bsc#1197998).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE OpenStack Cloud Crowbar 9:

      zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2022-4240=1

   - SUSE OpenStack Cloud 9:

      zypper in -t patch SUSE-OpenStack-Cloud-9-2022-4240=1

   - SUSE Linux Enterprise Server for SAP 12-SP4:

      zypper in -t patch SUSE-SLE-SAP-12-SP4-2022-4240=1

   - SUSE Linux Enterprise Server 12-SP4-LTSS:

      zypper in -t patch SUSE-SLE-SERVER-12-SP4-LTSS-2022-4240=1

   - SUSE Linux Enterprise Server 12-SP3-BCL:

      zypper in -t patch SUSE-SLE-SERVER-12-SP3-BCL-2022-4240=1



Package List:

   - SUSE OpenStack Cloud Crowbar 9 (x86_64):

      sudo-1.8.20p2-3.33.1
      sudo-debuginfo-1.8.20p2-3.33.1
      sudo-debugsource-1.8.20p2-3.33.1

   - SUSE OpenStack Cloud 9 (x86_64):

      sudo-1.8.20p2-3.33.1
      sudo-debuginfo-1.8.20p2-3.33.1
      sudo-debugsource-1.8.20p2-3.33.1

   - SUSE Linux Enterprise Server for SAP 12-SP4 (ppc64le x86_64):

      sudo-1.8.20p2-3.33.1
      sudo-debuginfo-1.8.20p2-3.33.1
      sudo-debugsource-1.8.20p2-3.33.1

   - SUSE Linux Enterprise Server 12-SP4-LTSS (aarch64 ppc64le s390x x86_64):

      sudo-1.8.20p2-3.33.1
      sudo-debuginfo-1.8.20p2-3.33.1
      sudo-debugsource-1.8.20p2-3.33.1

   - SUSE Linux Enterprise Server 12-SP3-BCL (x86_64):

      sudo-1.8.20p2-3.33.1
      sudo-debuginfo-1.8.20p2-3.33.1
      sudo-debugsource-1.8.20p2-3.33.1


References:

   https://www.suse.com/security/cve/CVE-2022-43995.html
   https://bugzilla.suse.com/1197998
   https://bugzilla.suse.com/1203201
   https://bugzilla.suse.com/1204986

SUSE: 2022:4240-1 important: sudo

November 28, 2022
An update that solves one vulnerability and has two fixes is now available

Summary

This update for sudo fixes the following issues: Security fixes: - CVE-2022-43995: Fixed a potential heap-based buffer over-read when entering a password of seven characters or fewer and using the crypt() password backend (bsc#1204986). Other: - Make sure SIGCHLD is not ignored when sudo is executed; fixes race condition (bsc#1203201). - Change sudo-ldap schema from ASCII to UTF8 (bsc#1197998). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - SUSE OpenStack Cloud Crowbar 9: zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2022-4240=1 - SUSE OpenStack Cloud 9: zypper in -t patch SUSE-OpenStack-Cloud-9-2022-4240=1 - SUSE Linux Enterprise Server for SAP 12-SP4: zypper in -t patch SUSE-SLE-SAP-12-SP4-2022-4240=1 - SUSE Linux Enterprise Server 12-SP4-LTSS: zypper in -t patch SUSE-SLE-SERVER-12-SP4-LTSS-2022-4240=1 - SUSE Linux Enterprise Server 12-SP3-BCL: zypper in -t patch SUSE-SLE-SERVER-12-SP3-BCL-2022-4240=1 Package List: - SUSE OpenStack Cloud Crowbar 9 (x86_64): sudo-1.8.20p2-3.33.1 sudo-debuginfo-1.8.20p2-3.33.1 sudo-debugsource-1.8.20p2-3.33.1 - SUSE OpenStack Cloud 9 (x86_64): sudo-1.8.20p2-3.33.1 sudo-debuginfo-1.8.20p2-3.33.1 sudo-debugsource-1.8.20p2-3.33.1 - SUSE Linux Enterprise Server for SAP 12-SP4 (ppc64le x86_64): sudo-1.8.20p2-3.33.1 sudo-debuginfo-1.8.20p2-3.33.1 sudo-debugsource-1.8.20p2-3.33.1 - SUSE Linux Enterprise Server 12-SP4-LTSS (aarch64 ppc64le s390x x86_64): sudo-1.8.20p2-3.33.1 sudo-debuginfo-1.8.20p2-3.33.1 sudo-debugsource-1.8.20p2-3.33.1 - SUSE Linux Enterprise Server 12-SP3-BCL (x86_64): sudo-1.8.20p2-3.33.1 sudo-debuginfo-1.8.20p2-3.33.1 sudo-debugsource-1.8.20p2-3.33.1

References

#1197998 #1203201 #1204986

Cross- CVE-2022-43995

CVSS scores:

CVE-2022-43995 (NVD) : 7.1 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H

CVE-2022-43995 (SUSE): 7.1 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H

Affected Products:

SUSE Linux Enterprise Server 12-SP3-BCL

SUSE Linux Enterprise Server 12-SP4-LTSS

SUSE Linux Enterprise Server for SAP 12-SP4

SUSE OpenStack Cloud 9

SUSE OpenStack Cloud Crowbar 9

https://www.suse.com/security/cve/CVE-2022-43995.html

https://bugzilla.suse.com/1197998

https://bugzilla.suse.com/1203201

https://bugzilla.suse.com/1204986

Severity
Announcement ID: SUSE-SU-2022:4240-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.