SUSE: 2022:4280-1 important: sudo | LinuxSecurity.com

   SUSE Security Update: Security update for sudo
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:4280-1
Rating:             important
References:         #1197998 #1203201 #1204986 
Cross-References:   CVE-2022-43995
CVSS scores:
                    CVE-2022-43995 (NVD) : 7.1 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H
                    CVE-2022-43995 (SUSE): 7.1 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H

Affected Products:
                    SUSE Linux Enterprise Server 12-SP5
                    SUSE Linux Enterprise Server for SAP Applications 12-SP5
                    SUSE Linux Enterprise Software Development Kit 12-SP5
______________________________________________________________________________

   An update that solves one vulnerability and has two fixes
   is now available.

Description:

   This update for sudo fixes the following issues:

   Security fixes:

   - CVE-2022-43995: Fixed a potential heap-based buffer over-read when
     entering a password of seven characters or fewer and using the crypt()
     password backend (bsc#1204986).

   Other:

   - Make sure SIGCHLD is not ignored when sudo is executed; fixes race
     condition (bsc#1203201).
   - Change sudo-ldap schema from ASCII to UTF8 (bsc#1197998).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Software Development Kit 12-SP5:

      zypper in -t patch SUSE-SLE-SDK-12-SP5-2022-4280=1

   - SUSE Linux Enterprise Server 12-SP5:

      zypper in -t patch SUSE-SLE-SERVER-12-SP5-2022-4280=1



Package List:

   - SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 ppc64le s390x x86_64):

      sudo-debuginfo-1.8.27-4.30.1
      sudo-debugsource-1.8.27-4.30.1
      sudo-devel-1.8.27-4.30.1

   - SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64):

      sudo-1.8.27-4.30.1
      sudo-debuginfo-1.8.27-4.30.1
      sudo-debugsource-1.8.27-4.30.1


References:

   https://www.suse.com/security/cve/CVE-2022-43995.html
   https://bugzilla.suse.com/1197998
   https://bugzilla.suse.com/1203201
   https://bugzilla.suse.com/1204986

SUSE: 2022:4280-1 important: sudo

November 29, 2022
An update that solves one vulnerability and has two fixes is now available

Summary

This update for sudo fixes the following issues: Security fixes: - CVE-2022-43995: Fixed a potential heap-based buffer over-read when entering a password of seven characters or fewer and using the crypt() password backend (bsc#1204986). Other: - Make sure SIGCHLD is not ignored when sudo is executed; fixes race condition (bsc#1203201). - Change sudo-ldap schema from ASCII to UTF8 (bsc#1197998). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - SUSE Linux Enterprise Software Development Kit 12-SP5: zypper in -t patch SUSE-SLE-SDK-12-SP5-2022-4280=1 - SUSE Linux Enterprise Server 12-SP5: zypper in -t patch SUSE-SLE-SERVER-12-SP5-2022-4280=1 Package List: - SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 ppc64le s390x x86_64): sudo-debuginfo-1.8.27-4.30.1 sudo-debugsource-1.8.27-4.30.1 sudo-devel-1.8.27-4.30.1 - SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64): sudo-1.8.27-4.30.1 sudo-debuginfo-1.8.27-4.30.1 sudo-debugsource-1.8.27-4.30.1

References

#1197998 #1203201 #1204986

Cross- CVE-2022-43995

CVSS scores:

CVE-2022-43995 (NVD) : 7.1 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H

CVE-2022-43995 (SUSE): 7.1 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H

Affected Products:

SUSE Linux Enterprise Server 12-SP5

SUSE Linux Enterprise Server for SAP Applications 12-SP5

SUSE Linux Enterprise Software Development Kit 12-SP5

https://www.suse.com/security/cve/CVE-2022-43995.html

https://bugzilla.suse.com/1197998

https://bugzilla.suse.com/1203201

https://bugzilla.suse.com/1204986

Severity
Announcement ID: SUSE-SU-2022:4280-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.