SUSE: 2022:4457-1 moderate: libtpms | LinuxSecurity.com

   SUSE Security Update: Security update for libtpms
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:4457-1
Rating:             moderate
References:         #1187767 #1204556 
Cross-References:   CVE-2021-3623
CVSS scores:
                    CVE-2021-3623 (NVD) : 6.1 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:H
                    CVE-2021-3623 (SUSE): 6.1 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:H

Affected Products:
                    SUSE Enterprise Storage 7.1
                    SUSE Linux Enterprise High Performance Computing 15-SP3
                    SUSE Linux Enterprise High Performance Computing 15-SP4
                    SUSE Linux Enterprise Micro 5.1
                    SUSE Linux Enterprise Micro 5.2
                    SUSE Linux Enterprise Micro 5.3
                    SUSE Linux Enterprise Module for Server Applications 15-SP3
                    SUSE Linux Enterprise Module for Server Applications 15-SP4
                    SUSE Linux Enterprise Server 15-SP3
                    SUSE Linux Enterprise Server 15-SP4
                    SUSE Linux Enterprise Server for SAP Applications 15-SP3
                    SUSE Linux Enterprise Server for SAP Applications 15-SP4
                    SUSE Manager Proxy 4.2
                    SUSE Manager Proxy 4.3
                    SUSE Manager Retail Branch Server 4.2
                    SUSE Manager Retail Branch Server 4.3
                    SUSE Manager Server 4.2
                    SUSE Manager Server 4.3
                    openSUSE Leap 15.3
                    openSUSE Leap 15.4
                    openSUSE Leap Micro 5.2
                    openSUSE Leap Micro 5.3
______________________________________________________________________________

   An update that solves one vulnerability and has one errata
   is now available.

Description:

   This update for libtpms fixes the following issues:

   - CVE-2021-3623: Fixed out-of-bounds access when trying to resume the
     state of the vTPM (bsc#1187767)


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap Micro 5.3:

      zypper in -t patch openSUSE-Leap-Micro-5.3-2022-4457=1

   - openSUSE Leap Micro 5.2:

      zypper in -t patch openSUSE-Leap-Micro-5.2-2022-4457=1

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-4457=1

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2022-4457=1

   - SUSE Linux Enterprise Module for Server Applications 15-SP4:

      zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP4-2022-4457=1

   - SUSE Linux Enterprise Module for Server Applications 15-SP3:

      zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP3-2022-4457=1

   - SUSE Linux Enterprise Micro 5.3:

      zypper in -t patch SUSE-SLE-Micro-5.3-2022-4457=1

   - SUSE Linux Enterprise Micro 5.2:

      zypper in -t patch SUSE-SUSE-MicroOS-5.2-2022-4457=1

   - SUSE Linux Enterprise Micro 5.1:

      zypper in -t patch SUSE-SUSE-MicroOS-5.1-2022-4457=1



Package List:

   - openSUSE Leap Micro 5.3 (aarch64 x86_64):

      libtpms-debugsource-0.8.2-150300.3.6.1
      libtpms0-0.8.2-150300.3.6.1
      libtpms0-debuginfo-0.8.2-150300.3.6.1

   - openSUSE Leap Micro 5.2 (aarch64 x86_64):

      libtpms-debugsource-0.8.2-150300.3.6.1
      libtpms0-0.8.2-150300.3.6.1
      libtpms0-debuginfo-0.8.2-150300.3.6.1

   - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

      libtpms-debugsource-0.8.2-150300.3.6.1
      libtpms-devel-0.8.2-150300.3.6.1
      libtpms0-0.8.2-150300.3.6.1
      libtpms0-debuginfo-0.8.2-150300.3.6.1

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      libtpms-debugsource-0.8.2-150300.3.6.1
      libtpms-devel-0.8.2-150300.3.6.1
      libtpms0-0.8.2-150300.3.6.1
      libtpms0-debuginfo-0.8.2-150300.3.6.1

   - SUSE Linux Enterprise Module for Server Applications 15-SP4 (aarch64 ppc64le s390x x86_64):

      libtpms-debugsource-0.8.2-150300.3.6.1
      libtpms-devel-0.8.2-150300.3.6.1
      libtpms0-0.8.2-150300.3.6.1
      libtpms0-debuginfo-0.8.2-150300.3.6.1

   - SUSE Linux Enterprise Module for Server Applications 15-SP3 (aarch64 ppc64le s390x x86_64):

      libtpms-debugsource-0.8.2-150300.3.6.1
      libtpms-devel-0.8.2-150300.3.6.1
      libtpms0-0.8.2-150300.3.6.1
      libtpms0-debuginfo-0.8.2-150300.3.6.1

   - SUSE Linux Enterprise Micro 5.3 (aarch64 s390x x86_64):

      libtpms-debugsource-0.8.2-150300.3.6.1
      libtpms0-0.8.2-150300.3.6.1
      libtpms0-debuginfo-0.8.2-150300.3.6.1

   - SUSE Linux Enterprise Micro 5.2 (aarch64 s390x x86_64):

      libtpms-debugsource-0.8.2-150300.3.6.1
      libtpms0-0.8.2-150300.3.6.1
      libtpms0-debuginfo-0.8.2-150300.3.6.1

   - SUSE Linux Enterprise Micro 5.1 (aarch64 s390x x86_64):

      libtpms-debugsource-0.8.2-150300.3.6.1
      libtpms0-0.8.2-150300.3.6.1
      libtpms0-debuginfo-0.8.2-150300.3.6.1


References:

   https://www.suse.com/security/cve/CVE-2021-3623.html
   https://bugzilla.suse.com/1187767
   https://bugzilla.suse.com/1204556

SUSE: 2022:4457-1 moderate: libtpms

December 13, 2022
An update that solves one vulnerability and has one errata is now available

Summary

This update for libtpms fixes the following issues: - CVE-2021-3623: Fixed out-of-bounds access when trying to resume the state of the vTPM (bsc#1187767) Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap Micro 5.3: zypper in -t patch openSUSE-Leap-Micro-5.3-2022-4457=1 - openSUSE Leap Micro 5.2: zypper in -t patch openSUSE-Leap-Micro-5.2-2022-4457=1 - openSUSE Leap 15.4: zypper in -t patch openSUSE-SLE-15.4-2022-4457=1 - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2022-4457=1 - SUSE Linux Enterprise Module for Server Applications 15-SP4: zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP4-2022-4457=1 - SUSE Linux Enterprise Module for Server Applications 15-SP3: zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP3-2022-4457=1 - SUSE Linux Enterprise Micro 5.3: zypper in -t patch SUSE-SLE-Micro-5.3-2022-4457=1 - SUSE Linux Enterprise Micro 5.2: zypper in -t patch SUSE-SUSE-MicroOS-5.2-2022-4457=1 - SUSE Linux Enterprise Micro 5.1: zypper in -t patch SUSE-SUSE-MicroOS-5.1-2022-4457=1 Package List: - openSUSE Leap Micro 5.3 (aarch64 x86_64): libtpms-debugsource-0.8.2-150300.3.6.1 libtpms0-0.8.2-150300.3.6.1 libtpms0-debuginfo-0.8.2-150300.3.6.1 - openSUSE Leap Micro 5.2 (aarch64 x86_64): libtpms-debugsource-0.8.2-150300.3.6.1 libtpms0-0.8.2-150300.3.6.1 libtpms0-debuginfo-0.8.2-150300.3.6.1 - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64): libtpms-debugsource-0.8.2-150300.3.6.1 libtpms-devel-0.8.2-150300.3.6.1 libtpms0-0.8.2-150300.3.6.1 libtpms0-debuginfo-0.8.2-150300.3.6.1 - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64): libtpms-debugsource-0.8.2-150300.3.6.1 libtpms-devel-0.8.2-150300.3.6.1 libtpms0-0.8.2-150300.3.6.1 libtpms0-debuginfo-0.8.2-150300.3.6.1 - SUSE Linux Enterprise Module for Server Applications 15-SP4 (aarch64 ppc64le s390x x86_64): libtpms-debugsource-0.8.2-150300.3.6.1 libtpms-devel-0.8.2-150300.3.6.1 libtpms0-0.8.2-150300.3.6.1 libtpms0-debuginfo-0.8.2-150300.3.6.1 - SUSE Linux Enterprise Module for Server Applications 15-SP3 (aarch64 ppc64le s390x x86_64): libtpms-debugsource-0.8.2-150300.3.6.1 libtpms-devel-0.8.2-150300.3.6.1 libtpms0-0.8.2-150300.3.6.1 libtpms0-debuginfo-0.8.2-150300.3.6.1 - SUSE Linux Enterprise Micro 5.3 (aarch64 s390x x86_64): libtpms-debugsource-0.8.2-150300.3.6.1 libtpms0-0.8.2-150300.3.6.1 libtpms0-debuginfo-0.8.2-150300.3.6.1 - SUSE Linux Enterprise Micro 5.2 (aarch64 s390x x86_64): libtpms-debugsource-0.8.2-150300.3.6.1 libtpms0-0.8.2-150300.3.6.1 libtpms0-debuginfo-0.8.2-150300.3.6.1 - SUSE Linux Enterprise Micro 5.1 (aarch64 s390x x86_64): libtpms-debugsource-0.8.2-150300.3.6.1 libtpms0-0.8.2-150300.3.6.1 libtpms0-debuginfo-0.8.2-150300.3.6.1

References

#1187767 #1204556

Cross- CVE-2021-3623

CVSS scores:

CVE-2021-3623 (NVD) : 6.1 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:H

CVE-2021-3623 (SUSE): 6.1 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:H

Affected Products:

SUSE Enterprise Storage 7.1

SUSE Linux Enterprise High Performance Computing 15-SP3

SUSE Linux Enterprise High Performance Computing 15-SP4

SUSE Linux Enterprise Micro 5.1

SUSE Linux Enterprise Micro 5.2

SUSE Linux Enterprise Micro 5.3

SUSE Linux Enterprise Module for Server Applications 15-SP3

SUSE Linux Enterprise Module for Server Applications 15-SP4

SUSE Linux Enterprise Server 15-SP3

SUSE Linux Enterprise Server 15-SP4

SUSE Linux Enterprise Server for SAP Applications 15-SP3

SUSE Linux Enterprise Server for SAP Applications 15-SP4

SUSE Manager Proxy 4.2

SUSE Manager Proxy 4.3

SUSE Manager Retail Branch Server 4.2

SUSE Manager Retail Branch Server 4.3

SUSE Manager Server 4.2

SUSE Manager Server 4.3

openSUSE Leap 15.3

openSUSE Leap 15.4

openSUSE Leap Micro 5.2

openSUSE Leap Micro 5.3

https://www.suse.com/security/cve/CVE-2021-3623.html

https://bugzilla.suse.com/1187767

https://bugzilla.suse.com/1204556

Severity
Announcement ID: SUSE-SU-2022:4457-1
Rating: moderate

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.