Discover Government News



# Security update for openssl-3

Announcement ID: SUSE-SU-2023:4190-1  
Rating: important  
References:

  * bsc#1213853
  * bsc#1216163

  
Cross-References:

  * CVE-2023-3817
  * CVE-2023-5363

  
CVSS scores:

  * CVE-2023-3817 ( SUSE ):  5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
  * CVE-2023-3817 ( NVD ):  5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
  * CVE-2023-5363 ( SUSE ):  7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

  
Affected Products:

  * Basesystem Module 15-SP5
  * openSUSE Leap 15.5
  * SUSE Linux Enterprise Desktop 15 SP5
  * SUSE Linux Enterprise High Performance Computing 15 SP5
  * SUSE Linux Enterprise Real Time 15 SP5
  * SUSE Linux Enterprise Server 15 SP5
  * SUSE Linux Enterprise Server for SAP Applications 15 SP5

  
  
An update that solves two vulnerabilities can now be installed.

## Description:

This update for openssl-3 fixes the following issues:

  * CVE-2023-5363: Incorrect cipher key and IV length processing. (bsc#1216163)
  * CVE-2023-3817: Add test of DH_check() with q = p + 1. (bsc#1213853)

## Patch Instructions:

To install this SUSE update use the SUSE recommended installation methods like
YaST online_update or "zypper patch".  
Alternatively you can run the command listed for your product:

  * openSUSE Leap 15.5  
    zypper in -t patch SUSE-2023-4190=1 openSUSE-SLE-15.5-2023-4190=1

  * Basesystem Module 15-SP5  
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP5-2023-4190=1

## Package List:

  * openSUSE Leap 15.5 (aarch64 ppc64le s390x x86_64 i586)
    * libopenssl3-3.0.8-150500.5.14.1
    * openssl-3-debugsource-3.0.8-150500.5.14.1
    * openssl-3-debuginfo-3.0.8-150500.5.14.1
    * openssl-3-3.0.8-150500.5.14.1
    * libopenssl-3-devel-3.0.8-150500.5.14.1
    * libopenssl3-debuginfo-3.0.8-150500.5.14.1
  * openSUSE Leap 15.5 (x86_64)
    * libopenssl3-32bit-3.0.8-150500.5.14.1
    * libopenssl-3-devel-32bit-3.0.8-150500.5.14.1
    * libopenssl3-32bit-debuginfo-3.0.8-150500.5.14.1
  * openSUSE Leap 15.5 (noarch)
    * openssl-3-doc-3.0.8-150500.5.14.1
  * openSUSE Leap 15.5 (aarch64_ilp32)
    * libopenssl3-64bit-debuginfo-3.0.8-150500.5.14.1
    * libopenssl-3-devel-64bit-3.0.8-150500.5.14.1
    * libopenssl3-64bit-3.0.8-150500.5.14.1
  * Basesystem Module 15-SP5 (aarch64 ppc64le s390x x86_64)
    * libopenssl3-3.0.8-150500.5.14.1
    * openssl-3-debugsource-3.0.8-150500.5.14.1
    * openssl-3-debuginfo-3.0.8-150500.5.14.1
    * openssl-3-3.0.8-150500.5.14.1
    * libopenssl-3-devel-3.0.8-150500.5.14.1
    * libopenssl3-debuginfo-3.0.8-150500.5.14.1

## References:

  * https://www.suse.com/security/cve/CVE-2023-3817.html
  * https://www.suse.com/security/cve/CVE-2023-5363.html
  * https://bugzilla.suse.com/show_bug.cgi?id=1213853
  * https://bugzilla.suse.com/show_bug.cgi?id=1216163

SUSE: 2023:4190-1 important: openssl-3

October 25, 2023
* bsc#1213853 * bsc#1216163 Cross-References: * CVE-2023-3817

Summary

## This update for openssl-3 fixes the following issues: * CVE-2023-5363: Incorrect cipher key and IV length processing. (bsc#1216163) * CVE-2023-3817: Add test of DH_check() with q = p + 1. (bsc#1213853) ## Patch Instructions: To install this SUSE update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: * openSUSE Leap 15.5 zypper in -t patch SUSE-2023-4190=1 openSUSE-SLE-15.5-2023-4190=1 * Basesystem Module 15-SP5 zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP5-2023-4190=1 ## Package List: * openSUSE Leap 15.5 (aarch64 ppc64le s390x x86_64 i586) * libopenssl3-3.0.8-150500.5.14.1 * openssl-3-debugsource-3.0.8-150500.5.14.1 * openssl-3-debuginfo-3.0.8-150500.5.14.1 * openssl-3-3.0.8-150500.5.14.1 * libopenssl-3-devel-3.0.8-150500.5.14.1 * libopenssl3-debuginfo-3.0.8-150500.5.14.1 * openSUSE Leap 15.5 (x86_64) * libopenssl3-32bit-3.0.8-150500.5.14.1 * libopenssl-3-devel-32bit-3.0.8-150500.5.14.1 * libopenssl3-32bit-debuginfo-3.0.8-150500.5.14.1 * openSUSE Leap 15.5 (noarch) * openssl-3-doc-3.0.8-150500.5.14.1 * openSUSE Leap 15.5 (aarch64_ilp32) * libopenssl3-64bit-debuginfo-3.0.8-150500.5.14.1 * libopenssl-3-devel-64bit-3.0.8-150500.5.14.1 * libopenssl3-64bit-3.0.8-150500.5.14.1 * Basesystem Module 15-SP5 (aarch64 ppc64le s390x x86_64) * libopenssl3-3.0.8-150500.5.14.1 * openssl-3-debugsource-3.0.8-150500.5.14.1 * openssl-3-debuginfo-3.0.8-150500.5.14.1 * openssl-3-3.0.8-150500.5.14.1 * libopenssl-3-devel-3.0.8-150500.5.14.1 * libopenssl3-debuginfo-3.0.8-150500.5.14.1

References

* bsc#1213853

* bsc#1216163

Cross-

* CVE-2023-3817

* CVE-2023-5363

CVSS scores:

* CVE-2023-3817 ( SUSE ): 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

* CVE-2023-3817 ( NVD ): 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

* CVE-2023-5363 ( SUSE ): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Affected Products:

* Basesystem Module 15-SP5

* openSUSE Leap 15.5

* SUSE Linux Enterprise Desktop 15 SP5

* SUSE Linux Enterprise High Performance Computing 15 SP5

* SUSE Linux Enterprise Real Time 15 SP5

* SUSE Linux Enterprise Server 15 SP5

* SUSE Linux Enterprise Server for SAP Applications 15 SP5

An update that solves two vulnerabilities can now be installed.

##

* https://www.suse.com/security/cve/CVE-2023-3817.html

* https://www.suse.com/security/cve/CVE-2023-5363.html

* https://bugzilla.suse.com/show_bug.cgi?id=1213853

* https://bugzilla.suse.com/show_bug.cgi?id=1216163

Severity
Announcement ID: SUSE-SU-2023:4190-1
Rating: important

Related News