# Security update for tinyxml

Announcement ID: SUSE-SU-2023:4958-1  
Rating: moderate  
References:

  * bsc#1218040

  
Cross-References:

  * CVE-2023-34194

  
CVSS scores:

  * CVE-2023-34194 ( SUSE ):  5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
  * CVE-2023-34194 ( NVD ):  7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

  
Affected Products:

  * openSUSE Leap 15.4
  * openSUSE Leap 15.5
  * SUSE Linux Enterprise Desktop 15 SP5
  * SUSE Linux Enterprise High Performance Computing 15 SP5
  * SUSE Linux Enterprise Micro 5.5
  * SUSE Linux Enterprise Real Time 15 SP5
  * SUSE Linux Enterprise Server 15 SP5
  * SUSE Linux Enterprise Server for SAP Applications 15 SP5
  * SUSE Package Hub 15 15-SP5

  
  
An update that solves one vulnerability can now be installed.

## Description:

This update for tinyxml fixes the following issues:

  * CVE-2023-34194: Fixed reachable assertion may lead to denial of service
    (bsc#1218040).

## Patch Instructions:

To install this SUSE update use the SUSE recommended installation methods like
YaST online_update or "zypper patch".  
Alternatively you can run the command listed for your product:

  * openSUSE Leap 15.5  
    zypper in -t patch openSUSE-SLE-15.5-2023-4958=1

  * SUSE Package Hub 15 15-SP5  
    zypper in -t patch SUSE-SLE-Module-Packagehub-Subpackages-15-SP5-2023-4958=1

  * openSUSE Leap 15.4  
    zypper in -t patch openSUSE-SLE-15.4-2023-4958=1

## Package List:

  * openSUSE Leap 15.5 (aarch64 ppc64le s390x x86_64)
    * libtinyxml0-2.6.2-150000.3.6.1
    * libtinyxml0-debuginfo-2.6.2-150000.3.6.1
    * tinyxml-devel-2.6.2-150000.3.6.1
    * tinyxml-debugsource-2.6.2-150000.3.6.1
    * tinyxml-docs-2.6.2-150000.3.6.1
  * SUSE Package Hub 15 15-SP5 (aarch64 ppc64le s390x x86_64)
    * libtinyxml0-2.6.2-150000.3.6.1
    * libtinyxml0-debuginfo-2.6.2-150000.3.6.1
    * tinyxml-devel-2.6.2-150000.3.6.1
    * tinyxml-debugsource-2.6.2-150000.3.6.1
    * tinyxml-docs-2.6.2-150000.3.6.1
  * openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64)
    * libtinyxml0-2.6.2-150000.3.6.1
    * libtinyxml0-debuginfo-2.6.2-150000.3.6.1
    * tinyxml-devel-2.6.2-150000.3.6.1
    * tinyxml-debugsource-2.6.2-150000.3.6.1
    * tinyxml-docs-2.6.2-150000.3.6.1

## References:

  * https://www.suse.com/security/cve/CVE-2023-34194.html
  * https://bugzilla.suse.com/show_bug.cgi?id=1218040

SUSE: 2023:4958-1 moderate: tinyxml

December 22, 2023
* bsc#1218040 Cross-References: * CVE-2023-34194

Summary

## This update for tinyxml fixes the following issues: * CVE-2023-34194: Fixed reachable assertion may lead to denial of service (bsc#1218040). ## Patch Instructions: To install this SUSE update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: * openSUSE Leap 15.5 zypper in -t patch openSUSE-SLE-15.5-2023-4958=1 * SUSE Package Hub 15 15-SP5 zypper in -t patch SUSE-SLE-Module-Packagehub-Subpackages-15-SP5-2023-4958=1 * openSUSE Leap 15.4 zypper in -t patch openSUSE-SLE-15.4-2023-4958=1 ## Package List: * openSUSE Leap 15.5 (aarch64 ppc64le s390x x86_64) * libtinyxml0-2.6.2-150000.3.6.1 * libtinyxml0-debuginfo-2.6.2-150000.3.6.1 * tinyxml-devel-2.6.2-150000.3.6.1 * tinyxml-debugsource-2.6.2-150000.3.6.1 * tinyxml-docs-2.6.2-150000.3.6.1 * SUSE Package Hub 15 15-SP5 (aarch64 ppc64le s390x x86_64) * libtinyxml0-2.6.2-150000.3.6.1 * libtinyxml0-debuginfo-2.6.2-150000.3.6.1 * tinyxml-devel-2.6.2-150000.3.6.1 * tinyxml-debugsource-2.6.2-150000.3.6.1 * tinyxml-docs-2.6.2-150000.3.6.1 * openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64) * libtinyxml0-2.6.2-150000.3.6.1 * libtinyxml0-debuginfo-2.6.2-150000.3.6.1 * tinyxml-devel-2.6.2-150000.3.6.1 * tinyxml-debugsource-2.6.2-150000.3.6.1 * tinyxml-docs-2.6.2-150000.3.6.1

References

* bsc#1218040

Cross-

* CVE-2023-34194

CVSS scores:

* CVE-2023-34194 ( SUSE ): 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

* CVE-2023-34194 ( NVD ): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Affected Products:

* openSUSE Leap 15.4

* openSUSE Leap 15.5

* SUSE Linux Enterprise Desktop 15 SP5

* SUSE Linux Enterprise High Performance Computing 15 SP5

* SUSE Linux Enterprise Micro 5.5

* SUSE Linux Enterprise Real Time 15 SP5

* SUSE Linux Enterprise Server 15 SP5

* SUSE Linux Enterprise Server for SAP Applications 15 SP5

* SUSE Package Hub 15 15-SP5

An update that solves one vulnerability can now be installed.

##

* https://www.suse.com/security/cve/CVE-2023-34194.html

* https://bugzilla.suse.com/show_bug.cgi?id=1218040

Severity
Announcement ID: SUSE-SU-2023:4958-1
Rating: moderate

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo