# Security update for gstreamer-plugins-rs

Announcement ID: SUSE-SU-2024:0090-1  
Rating: moderate  
References:

  * bsc#1208556

  
Cross-References:

  * CVE-2022-31394

  
CVSS scores:

  * CVE-2022-31394 ( SUSE ):  5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
  * CVE-2022-31394 ( NVD ):  7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

  
Affected Products:

  * Desktop Applications Module 15-SP5
  * openSUSE Leap 15.4
  * SUSE Linux Enterprise Desktop 15 SP5
  * SUSE Linux Enterprise High Performance Computing 15 SP5
  * SUSE Linux Enterprise Real Time 15 SP4
  * SUSE Linux Enterprise Real Time 15 SP5
  * SUSE Linux Enterprise Server 15 SP5
  * SUSE Linux Enterprise Server for SAP Applications 15 SP5

  
  
An update that solves one vulnerability can now be installed.

## Description:

This update for gstreamer-plugins-rs fixes the following issues:

  * CVE-2022-31394: Fixed a potential denial of service in the HTTP/2
    implementation (bsc#1208556).

## Patch Instructions:

To install this SUSE update use the SUSE recommended installation methods like
YaST online_update or "zypper patch".  
Alternatively you can run the command listed for your product:

  * openSUSE Leap 15.4  
    zypper in -t patch SUSE-2024-90=1

  * Desktop Applications Module 15-SP5  
    zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-SP5-2024-90=1

  * SUSE Linux Enterprise Real Time 15 SP4  
    zypper in -t patch SUSE-SLE-Product-RT-15-SP4-2024-90=1

## Package List:

  * openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64 i586)
    * gstreamer-plugins-rs-debuginfo-0.8.2-150400.3.3.1
    * gstreamer-plugins-rs-devel-0.8.2-150400.3.3.1
    * gstreamer-plugins-rs-debugsource-0.8.2-150400.3.3.1
    * gstreamer-plugins-rs-0.8.2-150400.3.3.1
  * Desktop Applications Module 15-SP5 (ppc64le)
    * gstreamer-plugins-rs-debuginfo-0.8.2-150400.3.3.1
    * gstreamer-plugins-rs-devel-0.8.2-150400.3.3.1
    * gstreamer-plugins-rs-debugsource-0.8.2-150400.3.3.1
    * gstreamer-plugins-rs-0.8.2-150400.3.3.1
  * SUSE Linux Enterprise Real Time 15 SP4 (x86_64)
    * gstreamer-plugins-rs-debuginfo-0.8.2-150400.3.3.1
    * gstreamer-plugins-rs-devel-0.8.2-150400.3.3.1
    * gstreamer-plugins-rs-debugsource-0.8.2-150400.3.3.1
    * gstreamer-plugins-rs-0.8.2-150400.3.3.1

## References:

  * https://www.suse.com/security/cve/CVE-2022-31394.html
  * https://bugzilla.suse.com/show_bug.cgi?id=1208556

SUSE: 2024:0090-1 moderate: gstreamer-plugins-rs

January 11, 2024
* bsc#1208556 Cross-References: * CVE-2022-31394

Summary

## This update for gstreamer-plugins-rs fixes the following issues: * CVE-2022-31394: Fixed a potential denial of service in the HTTP/2 implementation (bsc#1208556). ## Patch Instructions: To install this SUSE update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: * openSUSE Leap 15.4 zypper in -t patch SUSE-2024-90=1 * Desktop Applications Module 15-SP5 zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-SP5-2024-90=1 * SUSE Linux Enterprise Real Time 15 SP4 zypper in -t patch SUSE-SLE-Product-RT-15-SP4-2024-90=1 ## Package List: * openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64 i586) * gstreamer-plugins-rs-debuginfo-0.8.2-150400.3.3.1 * gstreamer-plugins-rs-devel-0.8.2-150400.3.3.1 * gstreamer-plugins-rs-debugsource-0.8.2-150400.3.3.1 * gstreamer-plugins-rs-0.8.2-150400.3.3.1 * Desktop Applications Module 15-SP5 (ppc64le) * gstreamer-plugins-rs-debuginfo-0.8.2-150400.3.3.1 * gstreamer-plugins-rs-devel-0.8.2-150400.3.3.1 * gstreamer-plugins-rs-debugsource-0.8.2-150400.3.3.1 * gstreamer-plugins-rs-0.8.2-150400.3.3.1 * SUSE Linux Enterprise Real Time 15 SP4 (x86_64) * gstreamer-plugins-rs-debuginfo-0.8.2-150400.3.3.1 * gstreamer-plugins-rs-devel-0.8.2-150400.3.3.1 * gstreamer-plugins-rs-debugsource-0.8.2-150400.3.3.1 * gstreamer-plugins-rs-0.8.2-150400.3.3.1

References

* bsc#1208556

Cross-

* CVE-2022-31394

CVSS scores:

* CVE-2022-31394 ( SUSE ): 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

* CVE-2022-31394 ( NVD ): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Affected Products:

* Desktop Applications Module 15-SP5

* openSUSE Leap 15.4

* SUSE Linux Enterprise Desktop 15 SP5

* SUSE Linux Enterprise High Performance Computing 15 SP5

* SUSE Linux Enterprise Real Time 15 SP4

* SUSE Linux Enterprise Real Time 15 SP5

* SUSE Linux Enterprise Server 15 SP5

* SUSE Linux Enterprise Server for SAP Applications 15 SP5

An update that solves one vulnerability can now be installed.

##

* https://www.suse.com/security/cve/CVE-2022-31394.html

* https://bugzilla.suse.com/show_bug.cgi?id=1208556

Severity
Announcement ID: SUSE-SU-2024:0090-1
Rating: moderate

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo