# Security update for bluez

Announcement ID: SUSE-SU-2024:0167-1  
Rating: important  
References:

  * bsc#1192760
  * bsc#1218300
  * bsc#1218301

  
Cross-References:

  * CVE-2021-41229
  * CVE-2023-50229
  * CVE-2023-50230

  
CVSS scores:

  * CVE-2021-41229 ( SUSE ):  4.3 CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
  * CVE-2021-41229 ( NVD ):  6.5 CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
  * CVE-2023-50229 ( SUSE ):  7.1 CVSS:3.1/AV:A/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
  * CVE-2023-50230 ( SUSE ):  7.1 CVSS:3.1/AV:A/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

  
Affected Products:

  * SUSE Linux Enterprise High Performance Computing 15 SP2
  * SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2
  * SUSE Linux Enterprise Server 15 SP2
  * SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2
  * SUSE Linux Enterprise Server for SAP Applications 15 SP2

  
  
An update that solves three vulnerabilities can now be installed.

## Description:

This update for bluez fixes the following issues:

  * CVE-2021-41229: Fix leaking buffers stored in cstates cache (bsc#1192760).
  * CVE-2023-50229: Fixed an out of bounds write in the primary version counter
    for the Phone Book Access Profile implementation (bsc#1218300).
  * CVE-2023-50230: Fixed an out of bounds write in the secondary version
    counter for the Phone Book Access Profile implementation (bsc#1218301).

## Patch Instructions:

To install this SUSE update use the SUSE recommended installation methods like
YaST online_update or "zypper patch".  
Alternatively you can run the command listed for your product:

  * SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2  
    zypper in -t patch SUSE-SLE-Product-SLES-15-SP2-LTSS-2024-167=1

  * SUSE Linux Enterprise Server for SAP Applications 15 SP2  
    zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP2-2024-167=1

  * SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2  
    zypper in -t patch SUSE-SLE-Product-HPC-15-SP2-LTSS-2024-167=1

## Package List:

  * SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2 (aarch64 ppc64le s390x
    x86_64)
    * bluez-5.48-150200.13.30.1
    * bluez-debuginfo-5.48-150200.13.30.1
    * libbluetooth3-5.48-150200.13.30.1
    * libbluetooth3-debuginfo-5.48-150200.13.30.1
    * bluez-debugsource-5.48-150200.13.30.1
    * bluez-devel-5.48-150200.13.30.1
  * SUSE Linux Enterprise Server for SAP Applications 15 SP2 (ppc64le x86_64)
    * bluez-5.48-150200.13.30.1
    * bluez-debuginfo-5.48-150200.13.30.1
    * libbluetooth3-5.48-150200.13.30.1
    * libbluetooth3-debuginfo-5.48-150200.13.30.1
    * bluez-debugsource-5.48-150200.13.30.1
    * bluez-devel-5.48-150200.13.30.1
  * SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2 (aarch64
    x86_64)
    * bluez-5.48-150200.13.30.1
    * bluez-debuginfo-5.48-150200.13.30.1
    * libbluetooth3-5.48-150200.13.30.1
    * libbluetooth3-debuginfo-5.48-150200.13.30.1
    * bluez-debugsource-5.48-150200.13.30.1
    * bluez-devel-5.48-150200.13.30.1

## References:

  * https://www.suse.com/security/cve/CVE-2021-41229.html
  * https://www.suse.com/security/cve/CVE-2023-50229.html
  * https://www.suse.com/security/cve/CVE-2023-50230.html
  * https://bugzilla.suse.com/show_bug.cgi?id=1192760
  * https://bugzilla.suse.com/show_bug.cgi?id=1218300
  * https://bugzilla.suse.com/show_bug.cgi?id=1218301

SUSE: 2024:0167-1 important: bluez

January 19, 2024
* bsc#1192760 * bsc#1218300 * bsc#1218301 Cross-References:

Summary

## This update for bluez fixes the following issues: * CVE-2021-41229: Fix leaking buffers stored in cstates cache (bsc#1192760). * CVE-2023-50229: Fixed an out of bounds write in the primary version counter for the Phone Book Access Profile implementation (bsc#1218300). * CVE-2023-50230: Fixed an out of bounds write in the secondary version counter for the Phone Book Access Profile implementation (bsc#1218301). ## Patch Instructions: To install this SUSE update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: * SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2 zypper in -t patch SUSE-SLE-Product-SLES-15-SP2-LTSS-2024-167=1 * SUSE Linux Enterprise Server for SAP Applications 15 SP2 zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP2-2024-167=1 * SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2 zypper in -t patch SUSE-SLE-Product-HPC-15-SP2-LTSS-2024-167=1 ## Package List: * SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2 (aarch64 ppc64le s390x x86_64) * bluez-5.48-150200.13.30.1 * bluez-debuginfo-5.48-150200.13.30.1 * libbluetooth3-5.48-150200.13.30.1 * libbluetooth3-debuginfo-5.48-150200.13.30.1 * bluez-debugsource-5.48-150200.13.30.1 * bluez-devel-5.48-150200.13.30.1 * SUSE Linux Enterprise Server for SAP Applications 15 SP2 (ppc64le x86_64) * bluez-5.48-150200.13.30.1 * bluez-debuginfo-5.48-150200.13.30.1 * libbluetooth3-5.48-150200.13.30.1 * libbluetooth3-debuginfo-5.48-150200.13.30.1 * bluez-debugsource-5.48-150200.13.30.1 * bluez-devel-5.48-150200.13.30.1 * SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2 (aarch64 x86_64) * bluez-5.48-150200.13.30.1 * bluez-debuginfo-5.48-150200.13.30.1 * libbluetooth3-5.48-150200.13.30.1 * libbluetooth3-debuginfo-5.48-150200.13.30.1 * bluez-debugsource-5.48-150200.13.30.1 * bluez-devel-5.48-150200.13.30.1

References

* bsc#1192760

* bsc#1218300

* bsc#1218301

Cross-

* CVE-2021-41229

* CVE-2023-50229

* CVE-2023-50230

CVSS scores:

* CVE-2021-41229 ( SUSE ): 4.3 CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

* CVE-2021-41229 ( NVD ): 6.5 CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

* CVE-2023-50229 ( SUSE ): 7.1 CVSS:3.1/AV:A/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

* CVE-2023-50230 ( SUSE ): 7.1 CVSS:3.1/AV:A/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Affected Products:

* SUSE Linux Enterprise High Performance Computing 15 SP2

* SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2

* SUSE Linux Enterprise Server 15 SP2

* SUSE Linux Enterprise Server 15 SP2 LTSS 15-SP2

* SUSE Linux Enterprise Server for SAP Applications 15 SP2

An update that solves three vulnerabilities can now be installed.

##

* https://www.suse.com/security/cve/CVE-2021-41229.html

* https://www.suse.com/security/cve/CVE-2023-50229.html

* https://www.suse.com/security/cve/CVE-2023-50230.html

* https://bugzilla.suse.com/show_bug.cgi?id=1192760

* https://bugzilla.suse.com/show_bug.cgi?id=1218300

* https://bugzilla.suse.com/show_bug.cgi?id=1218301

Severity
Announcement ID: SUSE-SU-2024:0167-1
Rating: important

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo