Discover Government News



# Security update for slurm

Announcement ID: SUSE-SU-2024:0287-1  
Rating: important  
References:

  * bsc#1216869
  * bsc#1218046
  * bsc#1218050
  * bsc#1218051
  * bsc#1218053

  
Cross-References:

  * CVE-2023-49933
  * CVE-2023-49936
  * CVE-2023-49937
  * CVE-2023-49938

  
CVSS scores:

  * CVE-2023-49933 ( SUSE ):  5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
  * CVE-2023-49933 ( NVD ):  7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
  * CVE-2023-49936 ( SUSE ):  7.8 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
  * CVE-2023-49936 ( NVD ):  7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
  * CVE-2023-49937 ( SUSE ):  7.8 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
  * CVE-2023-49937 ( NVD ):  9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
  * CVE-2023-49938 ( SUSE ):  5.1 CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
  * CVE-2023-49938 ( NVD ):  8.2 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N

  
Affected Products:

  * SUSE Linux Enterprise High Performance Computing 15 SP2
  * SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2

  
  
An update that solves four vulnerabilities and has one security fix can now be
installed.

## Description:

This update for slurm fixes the following issues:

Security fixes:

  * CVE-2023-49933: Prevent message extension attacks that could bypass the
    message hash. (bsc#1218046)
  * CVE-2023-49936: Prevent NULL pointer dereference on `size_valp` overflow.
    (bsc#1218050)
  * CVE-2023-49937: Prevent double-xfree() on error in
    `_unpack_node_reg_resp()`. (bsc#1218051)
  * CVE-2023-49938: Prevent modified `sbcast` RPCs from opening a file with the
    wrong group permissions. (bsc#1218053)

Other fixes:

  * Fix slurm upgrading to incompatible versions (bsc#1216869).

## Patch Instructions:

To install this SUSE update use the SUSE recommended installation methods like
YaST online_update or "zypper patch".  
Alternatively you can run the command listed for your product:

  * SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2  
    zypper in -t patch SUSE-SLE-Product-HPC-15-SP2-LTSS-2024-287=1

## Package List:

  * SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2 (aarch64
    x86_64)
    * perl-slurm-debuginfo-20.02.7-150200.3.20.1
    * slurm-sview-debuginfo-20.02.7-150200.3.20.1
    * slurm-doc-20.02.7-150200.3.20.1
    * slurm-node-20.02.7-150200.3.20.1
    * slurm-pam_slurm-debuginfo-20.02.7-150200.3.20.1
    * slurm-auth-none-20.02.7-150200.3.20.1
    * slurm-devel-20.02.7-150200.3.20.1
    * slurm-webdoc-20.02.7-150200.3.20.1
    * libnss_slurm2-20.02.7-150200.3.20.1
    * libslurm35-debuginfo-20.02.7-150200.3.20.1
    * slurm-munge-20.02.7-150200.3.20.1
    * slurm-torque-debuginfo-20.02.7-150200.3.20.1
    * slurm-20.02.7-150200.3.20.1
    * slurm-plugins-20.02.7-150200.3.20.1
    * slurm-plugins-debuginfo-20.02.7-150200.3.20.1
    * libnss_slurm2-debuginfo-20.02.7-150200.3.20.1
    * slurm-sql-debuginfo-20.02.7-150200.3.20.1
    * libslurm35-20.02.7-150200.3.20.1
    * perl-slurm-20.02.7-150200.3.20.1
    * slurm-torque-20.02.7-150200.3.20.1
    * slurm-auth-none-debuginfo-20.02.7-150200.3.20.1
    * libpmi0-debuginfo-20.02.7-150200.3.20.1
    * libpmi0-20.02.7-150200.3.20.1
    * slurm-debugsource-20.02.7-150200.3.20.1
    * slurm-slurmdbd-20.02.7-150200.3.20.1
    * slurm-config-man-20.02.7-150200.3.20.1
    * slurm-lua-20.02.7-150200.3.20.1
    * slurm-config-20.02.7-150200.3.20.1
    * slurm-debuginfo-20.02.7-150200.3.20.1
    * slurm-munge-debuginfo-20.02.7-150200.3.20.1
    * slurm-slurmdbd-debuginfo-20.02.7-150200.3.20.1
    * slurm-lua-debuginfo-20.02.7-150200.3.20.1
    * slurm-pam_slurm-20.02.7-150200.3.20.1
    * slurm-sql-20.02.7-150200.3.20.1
    * slurm-sview-20.02.7-150200.3.20.1
    * slurm-node-debuginfo-20.02.7-150200.3.20.1

## References:

  * https://www.suse.com/security/cve/CVE-2023-49933.html
  * https://www.suse.com/security/cve/CVE-2023-49936.html
  * https://www.suse.com/security/cve/CVE-2023-49937.html
  * https://www.suse.com/security/cve/CVE-2023-49938.html
  * https://bugzilla.suse.com/show_bug.cgi?id=1216869
  * https://bugzilla.suse.com/show_bug.cgi?id=1218046
  * https://bugzilla.suse.com/show_bug.cgi?id=1218050
  * https://bugzilla.suse.com/show_bug.cgi?id=1218051
  * https://bugzilla.suse.com/show_bug.cgi?id=1218053

SUSE: 2024:0287-1 important: slurm

January 31, 2024
* bsc#1216869 * bsc#1218046 * bsc#1218050 * bsc#1218051 * bsc#1218053

Summary

## This update for slurm fixes the following issues: Security fixes: * CVE-2023-49933: Prevent message extension attacks that could bypass the message hash. (bsc#1218046) * CVE-2023-49936: Prevent NULL pointer dereference on `size_valp` overflow. (bsc#1218050) * CVE-2023-49937: Prevent double-xfree() on error in `_unpack_node_reg_resp()`. (bsc#1218051) * CVE-2023-49938: Prevent modified `sbcast` RPCs from opening a file with the wrong group permissions. (bsc#1218053) Other fixes: * Fix slurm upgrading to incompatible versions (bsc#1216869). ## Patch Instructions: To install this SUSE update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: * SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2 zypper in -t patch SUSE-SLE-Product-HPC-15-SP2-LTSS-2024-287=1 ## Package List: * SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2 (aarch64 x86_64) * perl-slurm-debuginfo-20.02.7-150200.3.20.1 * slurm-sview-debuginfo-20.02.7-150200.3.20.1 * slurm-doc-20.02.7-150200.3.20.1 * slurm-node-20.02.7-150200.3.20.1 * slurm-pam_slurm-debuginfo-20.02.7-150200.3.20.1 * slurm-auth-none-20.02.7-150200.3.20.1 * slurm-devel-20.02.7-150200.3.20.1 * slurm-webdoc-20.02.7-150200.3.20.1 * libnss_slurm2-20.02.7-150200.3.20.1 * libslurm35-debuginfo-20.02.7-150200.3.20.1 * slurm-munge-20.02.7-150200.3.20.1 * slurm-torque-debuginfo-20.02.7-150200.3.20.1 * slurm-20.02.7-150200.3.20.1 * slurm-plugins-20.02.7-150200.3.20.1 * slurm-plugins-debuginfo-20.02.7-150200.3.20.1 * libnss_slurm2-debuginfo-20.02.7-150200.3.20.1 * slurm-sql-debuginfo-20.02.7-150200.3.20.1 * libslurm35-20.02.7-150200.3.20.1 * perl-slurm-20.02.7-150200.3.20.1 * slurm-torque-20.02.7-150200.3.20.1 * slurm-auth-none-debuginfo-20.02.7-150200.3.20.1 * libpmi0-debuginfo-20.02.7-150200.3.20.1 * libpmi0-20.02.7-150200.3.20.1 * slurm-debugsource-20.02.7-150200.3.20.1 * slurm-slurmdbd-20.02.7-150200.3.20.1 * slurm-config-man-20.02.7-150200.3.20.1 * slurm-lua-20.02.7-150200.3.20.1 * slurm-config-20.02.7-150200.3.20.1 * slurm-debuginfo-20.02.7-150200.3.20.1 * slurm-munge-debuginfo-20.02.7-150200.3.20.1 * slurm-slurmdbd-debuginfo-20.02.7-150200.3.20.1 * slurm-lua-debuginfo-20.02.7-150200.3.20.1 * slurm-pam_slurm-20.02.7-150200.3.20.1 * slurm-sql-20.02.7-150200.3.20.1 * slurm-sview-20.02.7-150200.3.20.1 * slurm-node-debuginfo-20.02.7-150200.3.20.1

References

* bsc#1216869

* bsc#1218046

* bsc#1218050

* bsc#1218051

* bsc#1218053

Cross-

* CVE-2023-49933

* CVE-2023-49936

* CVE-2023-49937

* CVE-2023-49938

CVSS scores:

* CVE-2023-49933 ( SUSE ): 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N

* CVE-2023-49933 ( NVD ): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

* CVE-2023-49936 ( SUSE ): 7.8 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H

* CVE-2023-49936 ( NVD ): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

* CVE-2023-49937 ( SUSE ): 7.8 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H

* CVE-2023-49937 ( NVD ): 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

* CVE-2023-49938 ( SUSE ): 5.1 CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

* CVE-2023-49938 ( NVD ): 8.2 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N

Affected Products:

* SUSE Linux Enterprise High Performance Computing 15 SP2

* SUSE Linux Enterprise High Performance Computing 15 SP2 LTSS 15-SP2

An update that solves four vulnerabilities and has one security fix can now be

installed.

##

* https://www.suse.com/security/cve/CVE-2023-49933.html

* https://www.suse.com/security/cve/CVE-2023-49936.html

* https://www.suse.com/security/cve/CVE-2023-49937.html

* https://www.suse.com/security/cve/CVE-2023-49938.html

* https://bugzilla.suse.com/show_bug.cgi?id=1216869

* https://bugzilla.suse.com/show_bug.cgi?id=1218046

* https://bugzilla.suse.com/show_bug.cgi?id=1218050

* https://bugzilla.suse.com/show_bug.cgi?id=1218051

* https://bugzilla.suse.com/show_bug.cgi?id=1218053

Severity
Announcement ID: SUSE-SU-2024:0287-1
Rating: important

Related News