Discover Government News



# Security update for python-pycryptodome

Announcement ID: SUSE-SU-2024:0585-1  
Rating: moderate  
References:

  * bsc#1218564

  
Cross-References:

  * CVE-2023-52323

  
CVSS scores:

  * CVE-2023-52323 ( SUSE ):  5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
  * CVE-2023-52323 ( NVD ):  5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

  
Affected Products:

  * Public Cloud Module 15-SP2
  * SUSE Linux Enterprise High Performance Computing 15 SP2
  * SUSE Linux Enterprise Server 15 SP2
  * SUSE Linux Enterprise Server for SAP Applications 15 SP2
  * SUSE Manager Proxy 4.1
  * SUSE Manager Retail Branch Server 4.1
  * SUSE Manager Server 4.1

  
  
An update that solves one vulnerability can now be installed.

## Description:

This update for python-pycryptodome fixes the following issues:

  * CVE-2023-52323: Fixed side-channel leakage in RSA decryption by using
    constant-time (faster) padding decoding for OAEP (bsc#1218564).

## Patch Instructions:

To install this SUSE update use the SUSE recommended installation methods like
YaST online_update or "zypper patch".  
Alternatively you can run the command listed for your product:

  * Public Cloud Module 15-SP2  
    zypper in -t patch SUSE-SLE-Module-Public-Cloud-15-SP2-2024-585=1

## Package List:

  * Public Cloud Module 15-SP2 (aarch64 ppc64le s390x x86_64)
    * python3-pycryptodome-debuginfo-3.9.0-150100.3.6.1
    * python3-pycryptodome-3.9.0-150100.3.6.1
    * python-pycryptodome-debugsource-3.9.0-150100.3.6.1
    * python-pycryptodome-debuginfo-3.9.0-150100.3.6.1

## References:

  * https://www.suse.com/security/cve/CVE-2023-52323.html
  * https://bugzilla.suse.com/show_bug.cgi?id=1218564

SUSE: 2024:0585-1 moderate: python-pycryptodome

February 22, 2024
* bsc#1218564 Cross-References: * CVE-2023-52323

Summary

## This update for python-pycryptodome fixes the following issues: * CVE-2023-52323: Fixed side-channel leakage in RSA decryption by using constant-time (faster) padding decoding for OAEP (bsc#1218564). ## Patch Instructions: To install this SUSE update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: * Public Cloud Module 15-SP2 zypper in -t patch SUSE-SLE-Module-Public-Cloud-15-SP2-2024-585=1 ## Package List: * Public Cloud Module 15-SP2 (aarch64 ppc64le s390x x86_64) * python3-pycryptodome-debuginfo-3.9.0-150100.3.6.1 * python3-pycryptodome-3.9.0-150100.3.6.1 * python-pycryptodome-debugsource-3.9.0-150100.3.6.1 * python-pycryptodome-debuginfo-3.9.0-150100.3.6.1

References

* bsc#1218564

Cross-

* CVE-2023-52323

CVSS scores:

* CVE-2023-52323 ( SUSE ): 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

* CVE-2023-52323 ( NVD ): 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Affected Products:

* Public Cloud Module 15-SP2

* SUSE Linux Enterprise High Performance Computing 15 SP2

* SUSE Linux Enterprise Server 15 SP2

* SUSE Linux Enterprise Server for SAP Applications 15 SP2

* SUSE Manager Proxy 4.1

* SUSE Manager Retail Branch Server 4.1

* SUSE Manager Server 4.1

An update that solves one vulnerability can now be installed.

##

* https://www.suse.com/security/cve/CVE-2023-52323.html

* https://bugzilla.suse.com/show_bug.cgi?id=1218564

Severity
Announcement ID: SUSE-SU-2024:0585-1
Rating: moderate

Related News