Discover Government News



# Security update for nodejs16

Announcement ID: SUSE-SU-2024:0728-1  
Rating: important  
References:

  * bsc#1219993
  * bsc#1219997
  * bsc#1220014
  * bsc#1220017
  * bsc#1220053

  
Cross-References:

  * CVE-2023-46809
  * CVE-2024-22019
  * CVE-2024-22025
  * CVE-2024-24758
  * CVE-2024-24806

  
CVSS scores:

  * CVE-2023-46809 ( SUSE ):  6.8 CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
  * CVE-2024-22019 ( SUSE ):  7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
  * CVE-2024-24758 ( SUSE ):  3.9 CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:L
  * CVE-2024-24806 ( SUSE ):  5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
  * CVE-2024-24806 ( NVD ):  7.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

  
Affected Products:

  * openSUSE Leap 15.4
  * SUSE Linux Enterprise High Performance Computing 15 SP4
  * SUSE Linux Enterprise High Performance Computing ESPOS 15 SP4
  * SUSE Linux Enterprise High Performance Computing LTSS 15 SP4
  * SUSE Linux Enterprise Server 15 SP4
  * SUSE Linux Enterprise Server 15 SP4 LTSS 15-SP4
  * SUSE Linux Enterprise Server for SAP Applications 15 SP4
  * SUSE Manager Server 4.3

  
  
An update that solves five vulnerabilities can now be installed.

## Description:

This update for nodejs16 fixes the following issues:

Security issues fixed:

  * CVE-2023-46809: Node.js is vulnerable to the Marvin Attack (timing variant
    of the Bleichenbacher attack against PKCS#1 v1.5 padding) (bsc#1219997).
  * CVE-2024-22019: http: Reading unprocessed HTTP request with unbounded chunk
    extension allows DoS attacks (bsc#1219993).
  * CVE-2024-22025: Denial of Service by resource exhaustion in fetch() brotli
    decoding (bsc#1220014).
  * CVE-2024-24758: ignore proxy-authorization header (bsc#1220017).
  * CVE-2024-24806: fix improper domain lookup that potentially leads to SSRF
    attacks (bsc#1219724).

## Patch Instructions:

To install this SUSE update use the SUSE recommended installation methods like
YaST online_update or "zypper patch".  
Alternatively you can run the command listed for your product:

  * openSUSE Leap 15.4  
    zypper in -t patch SUSE-2024-728=1

  * SUSE Linux Enterprise High Performance Computing ESPOS 15 SP4  
    zypper in -t patch SUSE-SLE-Product-HPC-15-SP4-ESPOS-2024-728=1

  * SUSE Linux Enterprise High Performance Computing LTSS 15 SP4  
    zypper in -t patch SUSE-SLE-Product-HPC-15-SP4-LTSS-2024-728=1

  * SUSE Linux Enterprise Server 15 SP4 LTSS 15-SP4  
    zypper in -t patch SUSE-SLE-Product-SLES-15-SP4-LTSS-2024-728=1

  * SUSE Linux Enterprise Server for SAP Applications 15 SP4  
    zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP4-2024-728=1

  * SUSE Manager Server 4.3  
    zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Server-4.3-2024-728=1

## Package List:

  * openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64 i586)
    * nodejs16-debugsource-16.20.2-150400.3.30.1
    * nodejs16-16.20.2-150400.3.30.1
    * npm16-16.20.2-150400.3.30.1
    * nodejs16-debuginfo-16.20.2-150400.3.30.1
    * nodejs16-devel-16.20.2-150400.3.30.1
    * corepack16-16.20.2-150400.3.30.1
  * openSUSE Leap 15.4 (noarch)
    * nodejs16-docs-16.20.2-150400.3.30.1
  * SUSE Linux Enterprise High Performance Computing ESPOS 15 SP4 (aarch64
    x86_64)
    * nodejs16-debugsource-16.20.2-150400.3.30.1
    * nodejs16-16.20.2-150400.3.30.1
    * npm16-16.20.2-150400.3.30.1
    * nodejs16-debuginfo-16.20.2-150400.3.30.1
    * nodejs16-devel-16.20.2-150400.3.30.1
  * SUSE Linux Enterprise High Performance Computing ESPOS 15 SP4 (noarch)
    * nodejs16-docs-16.20.2-150400.3.30.1
  * SUSE Linux Enterprise High Performance Computing LTSS 15 SP4 (aarch64
    x86_64)
    * nodejs16-debugsource-16.20.2-150400.3.30.1
    * nodejs16-16.20.2-150400.3.30.1
    * npm16-16.20.2-150400.3.30.1
    * nodejs16-debuginfo-16.20.2-150400.3.30.1
    * nodejs16-devel-16.20.2-150400.3.30.1
  * SUSE Linux Enterprise High Performance Computing LTSS 15 SP4 (noarch)
    * nodejs16-docs-16.20.2-150400.3.30.1
  * SUSE Linux Enterprise Server 15 SP4 LTSS 15-SP4 (aarch64 ppc64le s390x
    x86_64)
    * nodejs16-debugsource-16.20.2-150400.3.30.1
    * nodejs16-16.20.2-150400.3.30.1
    * npm16-16.20.2-150400.3.30.1
    * nodejs16-debuginfo-16.20.2-150400.3.30.1
    * nodejs16-devel-16.20.2-150400.3.30.1
  * SUSE Linux Enterprise Server 15 SP4 LTSS 15-SP4 (noarch)
    * nodejs16-docs-16.20.2-150400.3.30.1
  * SUSE Linux Enterprise Server for SAP Applications 15 SP4 (ppc64le x86_64)
    * nodejs16-debugsource-16.20.2-150400.3.30.1
    * nodejs16-16.20.2-150400.3.30.1
    * npm16-16.20.2-150400.3.30.1
    * nodejs16-debuginfo-16.20.2-150400.3.30.1
    * nodejs16-devel-16.20.2-150400.3.30.1
  * SUSE Linux Enterprise Server for SAP Applications 15 SP4 (noarch)
    * nodejs16-docs-16.20.2-150400.3.30.1
  * SUSE Manager Server 4.3 (ppc64le s390x x86_64)
    * nodejs16-debugsource-16.20.2-150400.3.30.1
    * nodejs16-16.20.2-150400.3.30.1
    * npm16-16.20.2-150400.3.30.1
    * nodejs16-debuginfo-16.20.2-150400.3.30.1
    * nodejs16-devel-16.20.2-150400.3.30.1
  * SUSE Manager Server 4.3 (noarch)
    * nodejs16-docs-16.20.2-150400.3.30.1

## References:

  * https://www.suse.com/security/cve/CVE-2023-46809.html
  * https://www.suse.com/security/cve/CVE-2024-22019.html
  * https://www.suse.com/security/cve/CVE-2024-22025.html
  * https://www.suse.com/security/cve/CVE-2024-24758.html
  * https://www.suse.com/security/cve/CVE-2024-24806.html
  * https://bugzilla.suse.com/show_bug.cgi?id=1219993
  * https://bugzilla.suse.com/show_bug.cgi?id=1219997
  * https://bugzilla.suse.com/show_bug.cgi?id=1220014
  * https://bugzilla.suse.com/show_bug.cgi?id=1220017
  * https://bugzilla.suse.com/show_bug.cgi?id=1220053

SUSE: 2024:0728-1 important: nodejs16

March 1, 2024
* bsc#1219993 * bsc#1219997 * bsc#1220014 * bsc#1220017 * bsc#1220053

Summary

## This update for nodejs16 fixes the following issues: Security issues fixed: * CVE-2023-46809: Node.js is vulnerable to the Marvin Attack (timing variant of the Bleichenbacher attack against PKCS#1 v1.5 padding) (bsc#1219997). * CVE-2024-22019: http: Reading unprocessed HTTP request with unbounded chunk extension allows DoS attacks (bsc#1219993). * CVE-2024-22025: Denial of Service by resource exhaustion in fetch() brotli decoding (bsc#1220014). * CVE-2024-24758: ignore proxy-authorization header (bsc#1220017). * CVE-2024-24806: fix improper domain lookup that potentially leads to SSRF attacks (bsc#1219724). ## Patch Instructions: To install this SUSE update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: * openSUSE Leap 15.4 zypper in -t patch SUSE-2024-728=1 * SUSE Linux Enterprise High Performance Computing ESPOS 15 SP4 zypper in -t patch SUSE-SLE-Product-HPC-15-SP4-ESPOS-2024-728=1 * SUSE Linux Enterprise High Performance Computing LTSS 15 SP4 zypper in -t patch SUSE-SLE-Product-HPC-15-SP4-LTSS-2024-728=1 * SUSE Linux Enterprise Server 15 SP4 LTSS 15-SP4 zypper in -t patch SUSE-SLE-Product-SLES-15-SP4-LTSS-2024-728=1 * SUSE Linux Enterprise Server for SAP Applications 15 SP4 zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP4-2024-728=1 * SUSE Manager Server 4.3 zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Server-4.3-2024-728=1 ## Package List: * openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64 i586) * nodejs16-debugsource-16.20.2-150400.3.30.1 * nodejs16-16.20.2-150400.3.30.1 * npm16-16.20.2-150400.3.30.1 * nodejs16-debuginfo-16.20.2-150400.3.30.1 * nodejs16-devel-16.20.2-150400.3.30.1 * corepack16-16.20.2-150400.3.30.1 * openSUSE Leap 15.4 (noarch) * nodejs16-docs-16.20.2-150400.3.30.1 * SUSE Linux Enterprise High Performance Computing ESPOS 15 SP4 (aarch64 x86_64) * nodejs16-debugsource-16.20.2-150400.3.30.1 * nodejs16-16.20.2-150400.3.30.1 * npm16-16.20.2-150400.3.30.1 * nodejs16-debuginfo-16.20.2-150400.3.30.1 * nodejs16-devel-16.20.2-150400.3.30.1 * SUSE Linux Enterprise High Performance Computing ESPOS 15 SP4 (noarch) * nodejs16-docs-16.20.2-150400.3.30.1 * SUSE Linux Enterprise High Performance Computing LTSS 15 SP4 (aarch64 x86_64) * nodejs16-debugsource-16.20.2-150400.3.30.1 * nodejs16-16.20.2-150400.3.30.1 * npm16-16.20.2-150400.3.30.1 * nodejs16-debuginfo-16.20.2-150400.3.30.1 * nodejs16-devel-16.20.2-150400.3.30.1 * SUSE Linux Enterprise High Performance Computing LTSS 15 SP4 (noarch) * nodejs16-docs-16.20.2-150400.3.30.1 * SUSE Linux Enterprise Server 15 SP4 LTSS 15-SP4 (aarch64 ppc64le s390x x86_64) * nodejs16-debugsource-16.20.2-150400.3.30.1 * nodejs16-16.20.2-150400.3.30.1 * npm16-16.20.2-150400.3.30.1 * nodejs16-debuginfo-16.20.2-150400.3.30.1 * nodejs16-devel-16.20.2-150400.3.30.1 * SUSE Linux Enterprise Server 15 SP4 LTSS 15-SP4 (noarch) * nodejs16-docs-16.20.2-150400.3.30.1 * SUSE Linux Enterprise Server for SAP Applications 15 SP4 (ppc64le x86_64) * nodejs16-debugsource-16.20.2-150400.3.30.1 * nodejs16-16.20.2-150400.3.30.1 * npm16-16.20.2-150400.3.30.1 * nodejs16-debuginfo-16.20.2-150400.3.30.1 * nodejs16-devel-16.20.2-150400.3.30.1 * SUSE Linux Enterprise Server for SAP Applications 15 SP4 (noarch) * nodejs16-docs-16.20.2-150400.3.30.1 * SUSE Manager Server 4.3 (ppc64le s390x x86_64) * nodejs16-debugsource-16.20.2-150400.3.30.1 * nodejs16-16.20.2-150400.3.30.1 * npm16-16.20.2-150400.3.30.1 * nodejs16-debuginfo-16.20.2-150400.3.30.1 * nodejs16-devel-16.20.2-150400.3.30.1 * SUSE Manager Server 4.3 (noarch) * nodejs16-docs-16.20.2-150400.3.30.1

References

* bsc#1219993

* bsc#1219997

* bsc#1220014

* bsc#1220017

* bsc#1220053

Cross-

* CVE-2023-46809

* CVE-2024-22019

* CVE-2024-22025

* CVE-2024-24758

* CVE-2024-24806

CVSS scores:

* CVE-2023-46809 ( SUSE ): 6.8 CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N

* CVE-2024-22019 ( SUSE ): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

* CVE-2024-24758 ( SUSE ): 3.9 CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:L

* CVE-2024-24806 ( SUSE ): 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

* CVE-2024-24806 ( NVD ): 7.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Affected Products:

* openSUSE Leap 15.4

* SUSE Linux Enterprise High Performance Computing 15 SP4

* SUSE Linux Enterprise High Performance Computing ESPOS 15 SP4

* SUSE Linux Enterprise High Performance Computing LTSS 15 SP4

* SUSE Linux Enterprise Server 15 SP4

* SUSE Linux Enterprise Server 15 SP4 LTSS 15-SP4

* SUSE Linux Enterprise Server for SAP Applications 15 SP4

* SUSE Manager Server 4.3

An update that solves five vulnerabilities can now be installed.

##

* https://www.suse.com/security/cve/CVE-2023-46809.html

* https://www.suse.com/security/cve/CVE-2024-22019.html

* https://www.suse.com/security/cve/CVE-2024-22025.html

* https://www.suse.com/security/cve/CVE-2024-24758.html

* https://www.suse.com/security/cve/CVE-2024-24806.html

* https://bugzilla.suse.com/show_bug.cgi?id=1219993

* https://bugzilla.suse.com/show_bug.cgi?id=1219997

* https://bugzilla.suse.com/show_bug.cgi?id=1220014

* https://bugzilla.suse.com/show_bug.cgi?id=1220017

* https://bugzilla.suse.com/show_bug.cgi?id=1220053

Severity
Announcement ID: SUSE-SU-2024:0728-1
Rating: important

Related News