Discover Government News



# Security update for postgresql-jdbc

Announcement ID: SUSE-SU-2024:0771-1  
Rating: critical  
References:

  * bsc#1220644

  
Cross-References:

  * CVE-2024-1597

  
CVSS scores:

  * CVE-2024-1597 ( SUSE ):  9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

  
Affected Products:

  * SUSE Linux Enterprise High Performance Computing 12 SP5
  * SUSE Linux Enterprise Server 12 SP5
  * SUSE Linux Enterprise Server for SAP Applications 12 SP5

  
  
An update that solves one vulnerability can now be installed.

## Description:

This update for postgresql-jdbc fixes the following issues:

  * CVE-2024-1597: Fixed SQL Injection via line comment generation
    (bsc#1220644).

## Patch Instructions:

To install this SUSE update use the SUSE recommended installation methods like
YaST online_update or "zypper patch".  
Alternatively you can run the command listed for your product:

  * SUSE Linux Enterprise High Performance Computing 12 SP5  
    zypper in -t patch SUSE-SLE-SERVER-12-SP5-2024-771=1

  * SUSE Linux Enterprise Server 12 SP5  
    zypper in -t patch SUSE-SLE-SERVER-12-SP5-2024-771=1

  * SUSE Linux Enterprise Server for SAP Applications 12 SP5  
    zypper in -t patch SUSE-SLE-SERVER-12-SP5-2024-771=1

## Package List:

  * SUSE Linux Enterprise High Performance Computing 12 SP5 (noarch)
    * postgresql-jdbc-9.4-3.12.1
  * SUSE Linux Enterprise Server 12 SP5 (noarch)
    * postgresql-jdbc-9.4-3.12.1
  * SUSE Linux Enterprise Server for SAP Applications 12 SP5 (noarch)
    * postgresql-jdbc-9.4-3.12.1

## References:

  * https://www.suse.com/security/cve/CVE-2024-1597.html
  * https://bugzilla.suse.com/show_bug.cgi?id=1220644

SUSE: 2024:0771-1 critical: postgresql-jdbc

March 5, 2024
* bsc#1220644 Cross-References: * CVE-2024-1597

Summary

## This update for postgresql-jdbc fixes the following issues: * CVE-2024-1597: Fixed SQL Injection via line comment generation (bsc#1220644). ## Patch Instructions: To install this SUSE update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: * SUSE Linux Enterprise High Performance Computing 12 SP5 zypper in -t patch SUSE-SLE-SERVER-12-SP5-2024-771=1 * SUSE Linux Enterprise Server 12 SP5 zypper in -t patch SUSE-SLE-SERVER-12-SP5-2024-771=1 * SUSE Linux Enterprise Server for SAP Applications 12 SP5 zypper in -t patch SUSE-SLE-SERVER-12-SP5-2024-771=1 ## Package List: * SUSE Linux Enterprise High Performance Computing 12 SP5 (noarch) * postgresql-jdbc-9.4-3.12.1 * SUSE Linux Enterprise Server 12 SP5 (noarch) * postgresql-jdbc-9.4-3.12.1 * SUSE Linux Enterprise Server for SAP Applications 12 SP5 (noarch) * postgresql-jdbc-9.4-3.12.1

References

* bsc#1220644

Cross-

* CVE-2024-1597

CVSS scores:

* CVE-2024-1597 ( SUSE ): 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Affected Products:

* SUSE Linux Enterprise High Performance Computing 12 SP5

* SUSE Linux Enterprise Server 12 SP5

* SUSE Linux Enterprise Server for SAP Applications 12 SP5

An update that solves one vulnerability can now be installed.

##

* https://www.suse.com/security/cve/CVE-2024-1597.html

* https://bugzilla.suse.com/show_bug.cgi?id=1220644

Severity
Announcement ID: SUSE-SU-2024:0771-1
Rating: critical

Related News