Discover Government News



# Security update for xen

Announcement ID: SUSE-SU-2024:0935-1  
Rating: moderate  
References:

  * bsc#1219885

  
Cross-References:

  * CVE-2023-46841

  
CVSS scores:

  * CVE-2023-46841 ( SUSE ):  6.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H

  
Affected Products:

  * openSUSE Leap 15.3
  * SUSE Linux Enterprise Micro 5.1
  * SUSE Linux Enterprise Micro 5.2
  * SUSE Linux Enterprise Micro for Rancher 5.2

  
  
An update that solves one vulnerability can now be installed.

## Description:

This update for xen fixes the following issues:

  * CVE-2023-46841: Fixed shadow stack vs exceptions from emulation stubs
    (XSA-451) (bsc#1219885).

## Patch Instructions:

To install this SUSE update use the SUSE recommended installation methods like
YaST online_update or "zypper patch".  
Alternatively you can run the command listed for your product:

  * SUSE Linux Enterprise Micro 5.2  
    zypper in -t patch SUSE-SUSE-MicroOS-5.2-2024-935=1

  * SUSE Linux Enterprise Micro for Rancher 5.2  
    zypper in -t patch SUSE-SUSE-MicroOS-5.2-2024-935=1

  * openSUSE Leap 15.3  
    zypper in -t patch SUSE-2024-935=1

  * SUSE Linux Enterprise Micro 5.1  
    zypper in -t patch SUSE-SUSE-MicroOS-5.1-2024-935=1

## Package List:

  * SUSE Linux Enterprise Micro 5.2 (x86_64)
    * xen-libs-debuginfo-4.14.6_12-150300.3.66.1
    * xen-libs-4.14.6_12-150300.3.66.1
    * xen-debugsource-4.14.6_12-150300.3.66.1
  * SUSE Linux Enterprise Micro for Rancher 5.2 (x86_64)
    * xen-libs-debuginfo-4.14.6_12-150300.3.66.1
    * xen-libs-4.14.6_12-150300.3.66.1
    * xen-debugsource-4.14.6_12-150300.3.66.1
  * openSUSE Leap 15.3 (aarch64 x86_64 i586)
    * xen-tools-domU-4.14.6_12-150300.3.66.1
    * xen-devel-4.14.6_12-150300.3.66.1
    * xen-libs-debuginfo-4.14.6_12-150300.3.66.1
    * xen-libs-4.14.6_12-150300.3.66.1
    * xen-tools-domU-debuginfo-4.14.6_12-150300.3.66.1
    * xen-debugsource-4.14.6_12-150300.3.66.1
  * openSUSE Leap 15.3 (x86_64)
    * xen-libs-32bit-debuginfo-4.14.6_12-150300.3.66.1
    * xen-libs-32bit-4.14.6_12-150300.3.66.1
  * openSUSE Leap 15.3 (aarch64 x86_64)
    * xen-tools-4.14.6_12-150300.3.66.1
    * xen-tools-debuginfo-4.14.6_12-150300.3.66.1
    * xen-4.14.6_12-150300.3.66.1
    * xen-doc-html-4.14.6_12-150300.3.66.1
  * openSUSE Leap 15.3 (noarch)
    * xen-tools-xendomains-wait-disk-4.14.6_12-150300.3.66.1
  * openSUSE Leap 15.3 (aarch64_ilp32)
    * xen-libs-64bit-4.14.6_12-150300.3.66.1
    * xen-libs-64bit-debuginfo-4.14.6_12-150300.3.66.1
  * SUSE Linux Enterprise Micro 5.1 (x86_64)
    * xen-libs-debuginfo-4.14.6_12-150300.3.66.1
    * xen-libs-4.14.6_12-150300.3.66.1
    * xen-debugsource-4.14.6_12-150300.3.66.1

## References:

  * https://www.suse.com/security/cve/CVE-2023-46841.html
  * https://bugzilla.suse.com/show_bug.cgi?id=1219885

SUSE: 2024:0935-1 moderate: xen

March 22, 2024
* bsc#1219885 Cross-References: * CVE-2023-46841

Summary

## This update for xen fixes the following issues: * CVE-2023-46841: Fixed shadow stack vs exceptions from emulation stubs (XSA-451) (bsc#1219885). ## Patch Instructions: To install this SUSE update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: * SUSE Linux Enterprise Micro 5.2 zypper in -t patch SUSE-SUSE-MicroOS-5.2-2024-935=1 * SUSE Linux Enterprise Micro for Rancher 5.2 zypper in -t patch SUSE-SUSE-MicroOS-5.2-2024-935=1 * openSUSE Leap 15.3 zypper in -t patch SUSE-2024-935=1 * SUSE Linux Enterprise Micro 5.1 zypper in -t patch SUSE-SUSE-MicroOS-5.1-2024-935=1 ## Package List: * SUSE Linux Enterprise Micro 5.2 (x86_64) * xen-libs-debuginfo-4.14.6_12-150300.3.66.1 * xen-libs-4.14.6_12-150300.3.66.1 * xen-debugsource-4.14.6_12-150300.3.66.1 * SUSE Linux Enterprise Micro for Rancher 5.2 (x86_64) * xen-libs-debuginfo-4.14.6_12-150300.3.66.1 * xen-libs-4.14.6_12-150300.3.66.1 * xen-debugsource-4.14.6_12-150300.3.66.1 * openSUSE Leap 15.3 (aarch64 x86_64 i586) * xen-tools-domU-4.14.6_12-150300.3.66.1 * xen-devel-4.14.6_12-150300.3.66.1 * xen-libs-debuginfo-4.14.6_12-150300.3.66.1 * xen-libs-4.14.6_12-150300.3.66.1 * xen-tools-domU-debuginfo-4.14.6_12-150300.3.66.1 * xen-debugsource-4.14.6_12-150300.3.66.1 * openSUSE Leap 15.3 (x86_64) * xen-libs-32bit-debuginfo-4.14.6_12-150300.3.66.1 * xen-libs-32bit-4.14.6_12-150300.3.66.1 * openSUSE Leap 15.3 (aarch64 x86_64) * xen-tools-4.14.6_12-150300.3.66.1 * xen-tools-debuginfo-4.14.6_12-150300.3.66.1 * xen-4.14.6_12-150300.3.66.1 * xen-doc-html-4.14.6_12-150300.3.66.1 * openSUSE Leap 15.3 (noarch) * xen-tools-xendomains-wait-disk-4.14.6_12-150300.3.66.1 * openSUSE Leap 15.3 (aarch64_ilp32) * xen-libs-64bit-4.14.6_12-150300.3.66.1 * xen-libs-64bit-debuginfo-4.14.6_12-150300.3.66.1 * SUSE Linux Enterprise Micro 5.1 (x86_64) * xen-libs-debuginfo-4.14.6_12-150300.3.66.1 * xen-libs-4.14.6_12-150300.3.66.1 * xen-debugsource-4.14.6_12-150300.3.66.1

References

* bsc#1219885

Cross-

* CVE-2023-46841

CVSS scores:

* CVE-2023-46841 ( SUSE ): 6.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H

Affected Products:

* openSUSE Leap 15.3

* SUSE Linux Enterprise Micro 5.1

* SUSE Linux Enterprise Micro 5.2

* SUSE Linux Enterprise Micro for Rancher 5.2

An update that solves one vulnerability can now be installed.

##

* https://www.suse.com/security/cve/CVE-2023-46841.html

* https://bugzilla.suse.com/show_bug.cgi?id=1219885

Severity
Announcement ID: SUSE-SU-2024:0935-1
Rating: moderate

Related News