Discover Government News



# Security update for dav1d

Announcement ID: SUSE-SU-2024:0963-1  
Rating: moderate  
References:

  * bsc#1220100

  
Cross-References:

  * CVE-2024-1580

  
CVSS scores:

  * CVE-2024-1580 ( SUSE ):  6.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L

  
Affected Products:

  * Basesystem Module 15-SP5
  * openSUSE Leap 15.4
  * SUSE Linux Enterprise Desktop 15 SP5
  * SUSE Linux Enterprise High Performance Computing 15 SP5
  * SUSE Linux Enterprise Real Time 15 SP5
  * SUSE Linux Enterprise Server 15 SP5
  * SUSE Linux Enterprise Server for SAP Applications 15 SP5

  
  
An update that solves one vulnerability can now be installed.

## Description:

This update for dav1d fixes the following issues:

  * CVE-2024-1580: Fixed tile_start_off calculations for extremely large frame
    sizes (bsc#1220100).

## Patch Instructions:

To install this SUSE update use the SUSE recommended installation methods like
YaST online_update or "zypper patch".  
Alternatively you can run the command listed for your product:

  * openSUSE Leap 15.4  
    zypper in -t patch SUSE-2024-963=1

  * Basesystem Module 15-SP5  
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP5-2024-963=1

## Package List:

  * openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64 i586)
    * dav1d-debugsource-0.9.2-150400.3.3.1
    * dav1d-debuginfo-0.9.2-150400.3.3.1
    * libdav1d5-0.9.2-150400.3.3.1
    * dav1d-0.9.2-150400.3.3.1
    * dav1d-devel-0.9.2-150400.3.3.1
    * libdav1d5-debuginfo-0.9.2-150400.3.3.1
  * openSUSE Leap 15.4 (x86_64)
    * libdav1d5-32bit-debuginfo-0.9.2-150400.3.3.1
    * libdav1d5-32bit-0.9.2-150400.3.3.1
  * openSUSE Leap 15.4 (aarch64_ilp32)
    * libdav1d5-64bit-0.9.2-150400.3.3.1
    * libdav1d5-64bit-debuginfo-0.9.2-150400.3.3.1
  * Basesystem Module 15-SP5 (aarch64 ppc64le s390x x86_64)
    * libdav1d5-0.9.2-150400.3.3.1
    * dav1d-debuginfo-0.9.2-150400.3.3.1
    * dav1d-debugsource-0.9.2-150400.3.3.1
    * libdav1d5-debuginfo-0.9.2-150400.3.3.1

## References:

  * https://www.suse.com/security/cve/CVE-2024-1580.html
  * https://bugzilla.suse.com/show_bug.cgi?id=1220100

SUSE: 2024:0963-1 moderate: dav1d

March 22, 2024
* bsc#1220100 Cross-References: * CVE-2024-1580

Summary

## This update for dav1d fixes the following issues: * CVE-2024-1580: Fixed tile_start_off calculations for extremely large frame sizes (bsc#1220100). ## Patch Instructions: To install this SUSE update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: * openSUSE Leap 15.4 zypper in -t patch SUSE-2024-963=1 * Basesystem Module 15-SP5 zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP5-2024-963=1 ## Package List: * openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64 i586) * dav1d-debugsource-0.9.2-150400.3.3.1 * dav1d-debuginfo-0.9.2-150400.3.3.1 * libdav1d5-0.9.2-150400.3.3.1 * dav1d-0.9.2-150400.3.3.1 * dav1d-devel-0.9.2-150400.3.3.1 * libdav1d5-debuginfo-0.9.2-150400.3.3.1 * openSUSE Leap 15.4 (x86_64) * libdav1d5-32bit-debuginfo-0.9.2-150400.3.3.1 * libdav1d5-32bit-0.9.2-150400.3.3.1 * openSUSE Leap 15.4 (aarch64_ilp32) * libdav1d5-64bit-0.9.2-150400.3.3.1 * libdav1d5-64bit-debuginfo-0.9.2-150400.3.3.1 * Basesystem Module 15-SP5 (aarch64 ppc64le s390x x86_64) * libdav1d5-0.9.2-150400.3.3.1 * dav1d-debuginfo-0.9.2-150400.3.3.1 * dav1d-debugsource-0.9.2-150400.3.3.1 * libdav1d5-debuginfo-0.9.2-150400.3.3.1

References

* bsc#1220100

Cross-

* CVE-2024-1580

CVSS scores:

* CVE-2024-1580 ( SUSE ): 6.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L

Affected Products:

* Basesystem Module 15-SP5

* openSUSE Leap 15.4

* SUSE Linux Enterprise Desktop 15 SP5

* SUSE Linux Enterprise High Performance Computing 15 SP5

* SUSE Linux Enterprise Real Time 15 SP5

* SUSE Linux Enterprise Server 15 SP5

* SUSE Linux Enterprise Server for SAP Applications 15 SP5

An update that solves one vulnerability can now be installed.

##

* https://www.suse.com/security/cve/CVE-2024-1580.html

* https://bugzilla.suse.com/show_bug.cgi?id=1220100

Severity
Announcement ID: SUSE-SU-2024:0963-1
Rating: moderate

Related News