SUSE Container Update Advisory: suse/git
-----------------------------------------------------------------
Container Advisory ID : SUSE-CU-2024:252-1
Container Tags        : suse/git:2.35 , suse/git:2.35-7.4 , suse/git:latest
Container Release     : 7.4
Severity              : important
Type                  : security
References            : 1211188 1211190 1218126 1218186 1218209 CVE-2023-1667 CVE-2023-2283
                        CVE-2023-48795 CVE-2023-6004 CVE-2023-6918 
-----------------------------------------------------------------

The container suse/git was updated. The following patches have been included in this update:

-----------------------------------------------------------------
Advisory ID: SUSE-SU-2024:140-1
Released:    Thu Jan 18 11:34:58 2024
Summary:     Security update for libssh
Type:        security
Severity:    important
References:  1211188,1211190,1218126,1218186,1218209,CVE-2023-1667,CVE-2023-2283,CVE-2023-48795,CVE-2023-6004,CVE-2023-6918
This update for libssh fixes the following issues:

Security fixes:

  - CVE-2023-6004: Fixed command injection using proxycommand (bsc#1218209)
  - CVE-2023-48795: Fixed potential downgrade attack using strict kex (bsc#1218126)
  - CVE-2023-6918: Fixed missing checks for return values of MD functions (bsc#1218186)
  - CVE-2023-1667: Fixed NULL dereference during rekeying with algorithm  guessing (bsc#1211188)
  - CVE-2023-2283: Fixed possible authorization bypass in pki_verify_data_signature under low-memory conditions (bsc#1211190)

Other fixes:

- Update to version 0.9.8
  - Allow @ in usernames when parsing from URI composes

- Update to version 0.9.7
  - Fix several memory leaks in GSSAPI handling code


The following package changes have been done:

- libssh-config-0.9.8-150400.3.3.1 updated
- libssh4-0.9.8-150400.3.3.1 updated
- container:micro-image-15.5.0-15.1 updated

SUSE: 2024:252-1 suse/git Security Update

January 19, 2024
The container suse/git was updated

Summary

Advisory ID: SUSE-SU-2024:140-1 Released: Thu Jan 18 11:34:58 2024 Summary: Security update for libssh Type: security Severity: important

References

References : 1211188 1211190 1218126 1218186 1218209 CVE-2023-1667 CVE-2023-2283

CVE-2023-48795 CVE-2023-6004 CVE-2023-6918

1211188,1211190,1218126,1218186,1218209,CVE-2023-1667,CVE-2023-2283,CVE-2023-48795,CVE-2023-6004,CVE-2023-6918

This update for libssh fixes the following issues:

Security fixes:

- CVE-2023-6004: Fixed command injection using proxycommand (bsc#1218209)

- CVE-2023-48795: Fixed potential downgrade attack using strict kex (bsc#1218126)

- CVE-2023-6918: Fixed missing checks for return values of MD functions (bsc#1218186)

- CVE-2023-1667: Fixed NULL dereference during rekeying with algorithm guessing (bsc#1211188)

- CVE-2023-2283: Fixed possible authorization bypass in pki_verify_data_signature under low-memory conditions (bsc#1211190)

Other fixes:

- Update to version 0.9.8

- Allow @ in usernames when parsing from URI composes

- Update to version 0.9.7

- Fix several memory leaks in GSSAPI handling code

The following package changes have been done:

- libssh-config-0.9.8-150400.3.3.1 updated

- libssh4-0.9.8-150400.3.3.1 updated

- container:micro-image-15.5.0-15.1 updated

Severity
Container Advisory ID : SUSE-CU-2024:252-1
Container Tags : suse/git:2.35 , suse/git:2.35-7.4 , suse/git:latest
Container Release : 7.4
Severity : important
Type : security

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo