Ubuntu 5407-1: Cairo vulnerabilities | LinuxSecurity.com

Advisories

==========================================================================
Ubuntu Security Notice USN-5407-1
May 10, 2022

cairo vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 16.04 ESM

Summary:

Several security issues were fixed in cairo.

Software Description:
- cairo: Cairo 2D vector graphics library performance utilities

Details:

Gustavo Grieco, Alberto Garcia, Francisco Oca, Suleman Ali, and others
discovered that Cairo incorrectly handled certain files.
An attacker could possibly use this issue to cause a denial of service.
(CVE-2016-9082, CVE-2017-9814, CVE-2019-6462)

Stephan Bergmann discovered that Cairo incorrectly handled certain files.
An attacker could possibly use this issue to cause a denial of service,
or possibly execute arbitrary code.
(CVE-2020-35492)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 16.04 ESM:
   cairo-perf-utils                1.14.6-1ubuntu0.1~esm1
   libcairo2                       1.14.6-1ubuntu0.1~esm1

In general, a standard system update will make all the necessary changes.

References:
   https://ubuntu.com/security/notices/USN-5407-1
   CVE-2016-9082, CVE-2017-9814, CVE-2019-6462, CVE-2020-35492

Ubuntu 5407-1: Cairo vulnerabilities

May 10, 2022

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 16.04 ESM Summary: Several security issues were fixed in cairo. Software Description: - cairo: Cairo 2D vector graphics library performance utilities Details: Gustavo Grieco, Alberto Garcia, Francisco Oca, Suleman Ali, and others discovered that Cairo incorrectly handled certain files. An attacker could possibly use this issue to cause a denial of service. (CVE-2016-9082, CVE-2017-9814, CVE-2019-6462) Stephan Bergmann discovered that Cairo incorrectly handled certain files. An attacker could possibly use this issue to cause a denial of service, or possibly execute arbitrary code. (CVE-2020-35492)

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 16.04 ESM: cairo-perf-utils 1.14.6-1ubuntu0.1~esm1 libcairo2 1.14.6-1ubuntu0.1~esm1 In general, a standard system update will make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-5407-1

CVE-2016-9082, CVE-2017-9814, CVE-2019-6462, CVE-2020-35492

Severity
Ubuntu Security Notice USN-5407-1

Package Information

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.