Ubuntu 5739-1: MariaDB vulnerabilities | LinuxSecurity.com
==========================================================================
Ubuntu Security Notice USN-5739-1
November 23, 2022

mariadb-10.3, mariadb-10.6 vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.10
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS

Summary:

Several security issues were fixed in MariaDB.

Software Description:
- mariadb-10.6: MariaDB database
- mariadb-10.3: MariaDB database

Details:

Several security issues were discovered in MariaDB and this update
includes new upstream MariaDB versions to fix these issues.

MariaDB has been updated to 10.3.37 in Ubuntu 20.04 LTS and to 10.6.11
in Ubuntu 22.04 LTS and Ubuntu 22.10.

In addition to security fixes, the updated packages contain bug fixes,
new features, and possibly incompatible changes.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.10:
  mariadb-server                  1:10.6.11-0ubuntu0.22.10.1

Ubuntu 22.04 LTS:
  mariadb-server                  1:10.6.11-0ubuntu0.22.04.1

Ubuntu 20.04 LTS:
  mariadb-server                  1:10.3.37-0ubuntu0.20.04.1

This update uses a new upstream release, which includes additional bug
fixes. In general, a standard system update will make all the necessary
changes.

References:
  https://ubuntu.com/security/notices/USN-5739-1
  CVE-2018-25032, CVE-2021-46669, CVE-2022-21427, CVE-2022-27376,
  CVE-2022-27377, CVE-2022-27378, CVE-2022-27379, CVE-2022-27380,
  CVE-2022-27381, CVE-2022-27382, CVE-2022-27383, CVE-2022-27384,
  CVE-2022-27386, CVE-2022-27387, CVE-2022-27444, CVE-2022-27445,
  CVE-2022-27446, CVE-2022-27447, CVE-2022-27448, CVE-2022-27449,
  CVE-2022-27451, CVE-2022-27452, CVE-2022-27455, CVE-2022-27456,
  CVE-2022-27457, CVE-2022-27458, CVE-2022-32081, CVE-2022-32082,
  CVE-2022-32083, CVE-2022-32084, CVE-2022-32085, CVE-2022-32086,
  CVE-2022-32087, CVE-2022-32088, CVE-2022-32089, CVE-2022-32091

Package Information:
  https://launchpad.net/ubuntu/+source/mariadb-10.6/1:10.6.11-0ubuntu0.22.10.1
  https://launchpad.net/ubuntu/+source/mariadb-10.6/1:10.6.11-0ubuntu0.22.04.1
  https://launchpad.net/ubuntu/+source/mariadb-10.3/1:10.3.37-0ubuntu0.20.04.1

Ubuntu 5739-1: MariaDB vulnerabilities

November 23, 2022

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 22.10 - Ubuntu 22.04 LTS - Ubuntu 20.04 LTS Summary: Several security issues were fixed in MariaDB. Software Description: - mariadb-10.6: MariaDB database - mariadb-10.3: MariaDB database Details: Several security issues were discovered in MariaDB and this update includes new upstream MariaDB versions to fix these issues. MariaDB has been updated to 10.3.37 in Ubuntu 20.04 LTS and to 10.6.11 in Ubuntu 22.04 LTS and Ubuntu 22.10. In addition to security fixes, the updated packages contain bug fixes, new features, and possibly incompatible changes.

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 22.10: mariadb-server 1:10.6.11-0ubuntu0.22.10.1 Ubuntu 22.04 LTS: mariadb-server 1:10.6.11-0ubuntu0.22.04.1 Ubuntu 20.04 LTS: mariadb-server 1:10.3.37-0ubuntu0.20.04.1 This update uses a new upstream release, which includes additional bug fixes. In general, a standard system update will make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-5739-1

CVE-2018-25032, CVE-2021-46669, CVE-2022-21427, CVE-2022-27376,

CVE-2022-27377, CVE-2022-27378, CVE-2022-27379, CVE-2022-27380,

CVE-2022-27381, CVE-2022-27382, CVE-2022-27383, CVE-2022-27384,

CVE-2022-27386, CVE-2022-27387, CVE-2022-27444, CVE-2022-27445,

CVE-2022-27446, CVE-2022-27447, CVE-2022-27448, CVE-2022-27449,

CVE-2022-27451, CVE-2022-27452, CVE-2022-27455, CVE-2022-27456,

CVE-2022-27457, CVE-2022-27458, CVE-2022-32081, CVE-2022-32082,

CVE-2022-32083, CVE-2022-32084, CVE-2022-32085, CVE-2022-32086,

CVE-2022-32087, CVE-2022-32088, CVE-2022-32089, CVE-2022-32091

Severity
Ubuntu Security Notice USN-5739-1

Package Information

https://launchpad.net/ubuntu/+source/mariadb-10.6/1:10.6.11-0ubuntu0.22.10.1 https://launchpad.net/ubuntu/+source/mariadb-10.6/1:10.6.11-0ubuntu0.22.04.1 https://launchpad.net/ubuntu/+source/mariadb-10.3/1:10.3.37-0ubuntu0.20.04.1

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.