Ubuntu 5775-1: Vim vulnerabilities | LinuxSecurity.com
==========================================================================
Ubuntu Security Notice USN-5775-1
December 12, 2022

vim vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 16.04 ESM

Summary:

Several security issues were fixed in Vim.

Software Description:
- vim: Vi IMproved - enhanced vi editor

Details:

It was discovered that Vim uses freed memory in recurisve substitution of
specially crafted patterns. An attacker could possbly use this to crash Vim
and cause denial of service. (CVE-2022-2345)

It was discovered that Vim makes illegal memory calls when patterns start
with an illegal byte. An attacker could possibly use this to crash Vim,
access or modify memory, or execute arbitrary commands. (CVE-2022-2581)

It was discovered that Vim could be made to crash when parsing invalid line
numbers. An attacker could possbly use this to crash Vim and cause denial
of service. (CVE-2022-3099)

It was discovered that Vim uses freed memory when autocmd changes a mark.
An attacker could possbly use this to crash Vim and cause denial of
service. (CVE-2022-3256)

It was discovered the Vim uses an incorrect array index when window width
is negative. A local attacker could possbly use this to crash Vim and cause
denial of service. (CVE-2022-3324)

It was discoverd that certain buffers could be sent to the wrong window. An
attacker with local access could use this to send messages to the wrong
window. (CVE-2022-3591)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 16.04 ESM:
vim 2:7.4.1689-3ubuntu1.5+esm14
vim-athena 2:7.4.1689-3ubuntu1.5+esm14
vim-athena-py2 2:7.4.1689-3ubuntu1.5+esm14
vim-gnome 2:7.4.1689-3ubuntu1.5+esm14
vim-gnome-py2 2:7.4.1689-3ubuntu1.5+esm14
vim-gtk 2:7.4.1689-3ubuntu1.5+esm14
vim-gtk-py2 2:7.4.1689-3ubuntu1.5+esm14
vim-gtk3 2:7.4.1689-3ubuntu1.5+esm14
vim-gtk3-py2 2:7.4.1689-3ubuntu1.5+esm14
vim-nox 2:7.4.1689-3ubuntu1.5+esm14
vim-nox-py2 2:7.4.1689-3ubuntu1.5+esm14
vim-tiny 2:7.4.1689-3ubuntu1.5+esm14

In general, a standard system update will make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-5775-1
CVE-2022-2345, CVE-2022-2581, CVE-2022-3099, CVE-2022-3256,
CVE-2022-3324, CVE-2022-3591

Ubuntu 5775-1: Vim vulnerabilities

December 12, 2022
Several security issues were fixed in Vim.

Summary

A security issue affects these releases of Ubuntu and its derivatives: - Ubuntu 16.04 ESM Summary: Several security issues were fixed in Vim. Software Description: - vim: Vi IMproved - enhanced vi editor Details: It was discovered that Vim uses freed memory in recurisve substitution of specially crafted patterns. An attacker could possbly use this to crash Vim and cause denial of service. (CVE-2022-2345) It was discovered that Vim makes illegal memory calls when patterns start with an illegal byte. An attacker could possibly use this to crash Vim, access or modify memory, or execute arbitrary commands. (CVE-2022-2581) It was discovered that Vim could be made to crash when parsing invalid line numbers. An attacker could possbly use this to crash Vim and cause denial of service. (CVE-2022-3099) It was discovered that Vim uses freed memory when autocmd changes a mark. An attacker could possbly use this to crash Vim and cause denial of service. (CVE-2022-3256) It was discovered the Vim uses an incorrect array index when window width is negative. A local attacker could possbly use this to crash Vim and cause denial of service. (CVE-2022-3324) It was discoverd that certain buffers could be sent to the wrong window. An attacker with local access could use this to send messages to the wrong window. (CVE-2022-3591)

Update Instructions

The problem can be corrected by updating your system to the following package versions: Ubuntu 16.04 ESM: vim 2:7.4.1689-3ubuntu1.5+esm14 vim-athena 2:7.4.1689-3ubuntu1.5+esm14 vim-athena-py2 2:7.4.1689-3ubuntu1.5+esm14 vim-gnome 2:7.4.1689-3ubuntu1.5+esm14 vim-gnome-py2 2:7.4.1689-3ubuntu1.5+esm14 vim-gtk 2:7.4.1689-3ubuntu1.5+esm14 vim-gtk-py2 2:7.4.1689-3ubuntu1.5+esm14 vim-gtk3 2:7.4.1689-3ubuntu1.5+esm14 vim-gtk3-py2 2:7.4.1689-3ubuntu1.5+esm14 vim-nox 2:7.4.1689-3ubuntu1.5+esm14 vim-nox-py2 2:7.4.1689-3ubuntu1.5+esm14 vim-tiny 2:7.4.1689-3ubuntu1.5+esm14 In general, a standard system update will make all the necessary changes.

References

https://ubuntu.com/security/notices/USN-5775-1

CVE-2022-2345, CVE-2022-2581, CVE-2022-3099, CVE-2022-3256,

CVE-2022-3324, CVE-2022-3591

Severity
Ubuntu Security Notice USN-5775-1

Package Information

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.