- -------------------------------------------------------------------------
Debian Security Advisory DSA-5071-1                   [email protected]
https://www.debian.org/security/                     Salvatore Bonaccorso
February 11, 2022                     https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package        : samba
CVE ID         : CVE-2021-44142 CVE-2022-0336
Debian Bug     : 1001068 1004693 1004694

Several vulnerabilities were discovered in Samba, a SMB/CIFS file,
print, and login server for Unix.

CVE-2021-44142

    Orange Tsai reported an out-of-bounds heap write vulnerability in
    the VFS module vfs_fruit, which could result in remote execution of
    arbitrary code as root.

CVE-2022-0336

    Kees van Vloten reported that Samba AD users with permission to
    write to an account can impersonate arbitrary services.

For the oldstable distribution (buster), these problems have been fixed
in version 2:4.9.5+dfsg-5+deb10u3. As per DSA 5015-1, CVE-2022-0336 has
not been addressed for the oldstable distribution (buster).

For the stable distribution (bullseye), these problems have been fixed
in version 2:4.13.13+dfsg-1~deb11u3. Additionally, some followup fixes
for CVE-2020-25717 are included in this update (Cf. #1001068).

We recommend that you upgrade your samba packages.

For the detailed security status of samba please refer to its security
tracker page at:
https://security-tracker.debian.org/tracker/samba

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: [email protected]