Debian: 'openssh' Unauthorized access vulnerability

    Date 08 Mar 2002
    2756
    Posted By LinuxSecurity Advisories
    Joost Pol reports that OpenSSH versions 2.0 through 3.0.2have an off-by-one bug in the channel allocation code. This vulnerabilitycan be exploited by authenticated users to gain root privilege or by amalicious server exploiting a client with this bug.
    
    ----------------------------------------------------------------------------
    Debian Security Advisory                                 This email address is being protected from spambots. You need JavaScript enabled to view it. 
    https://www.debian.org/security/                                Michael Stone
    March 7, 2002
    ----------------------------------------------------------------------------
    
    Package: openssh
    Vulnerability: local root exploit, remote client exploit
    Debian-specific: no
    
    Joost Pol <This email address is being protected from spambots. You need JavaScript enabled to view it.> reports that OpenSSH versions 2.0 through 3.0.2
    have an off-by-one bug in the channel allocation code. This vulnerability
    can be exploited by authenticated users to gain root privilege or by a
    malicious server exploiting a client with this bug.
    
    Since Debian 2.2 (potato) shipped with OpenSSH (the "ssh" package)
    version 1.2.3, it is not vulnerable to this exploit. No fix is required
    for Debian 2.2 (potato).
    
    The Debian unstable and testing archives do include a more recent OpenSSH
    (ssh) package. If you are running these pre-release distributions you
    should ensure that you are running version 3.0.2p1-8, a patched version
    which was added to the unstable archive today, or a later version.
    
    ----------------------------------------------------------------------------
    For apt-get: deb  https://security.debian.org/ stable/updates main
    For dpkg-ftp:  ftp://security.debian.org/debian-security dists/stable/updates/main
    Mailing list: This email address is being protected from spambots. You need JavaScript enabled to view it.
    
    
    
    

    LinuxSecurity Poll

    Are you considering making the switch to Purism's new Librem 14 Linux laptop to improve your security and privacy online?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/31-are-you-considering-making-the-switch-to-purism-s-new-librem-14-linux-laptop-to-improve-your-security-and-privacy-online?task=poll.vote&format=json
    31
    radio
    [{"id":"109","title":"Yes - the hardware kill switches and default ad blocking\/tracking protection sold me on it.","votes":"3","type":"x","order":"1","pct":37.5,"resources":[]},{"id":"110","title":"Not sure yet - I need to do more research.","votes":"4","type":"x","order":"2","pct":50,"resources":[]},{"id":"111","title":"No - I'm satisfied with my current laptop and have no security\/privacy concerns.","votes":"1","type":"x","order":"3","pct":12.5,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350
    bottom 200

    Advisories

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.