- -------------------------------------------------------------------------
Debian LTS Advisory DLA-2450-1                [email protected]
https://www.debian.org/lts/security/               Emilio Pozuelo Monfort
November 13, 2020                             https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package        : libproxy
Version        : 0.4.14-2+deb9u2
CVE ID         : CVE-2020-26154
Debian Bug     : 968366

Li Fei found that libproxy, a library for automatic proxy configuration
management, was vulnerable to a buffer overflow vulnerability when
receiving a large PAC file from a server without a Content-Length header
in the response.

For Debian 9 stretch, this problem has been fixed in version
0.4.14-2+deb9u2.

We recommend that you upgrade your libproxy packages.

For the detailed security status of libproxy please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/libproxy

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS