- -------------------------------------------------------------------------
Debian LTS Advisory DLA-2460-1                [email protected]
https://www.debian.org/lts/security/                    Thorsten Alteholz
November 21, 2020                             https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package        : golang-1.8
Version        : 1.8.1-1+deb9u2
CVE ID         : CVE-2020-15586 CVE-2020-16845 CVE-2020-28367


Three issues have been found in golang-1.8, a Go programming language
compiler version 1.8

CVE-2020-15586
      Using the 100-continue in HTTP headers received by a net/http/Server
      can lead to a data race involving the connection's buffered writer.

CVE-2020-16845
      Certain invalid inputs to ReadUvarint or ReadVarint could cause those
      functions to read an unlimited number of bytes from the ByteReader
      argument before returning an error.

CVE-2020-28367
      When using cgo, arbitrary code might be executed at build time.


For Debian 9 stretch, these problems have been fixed in version
1.8.1-1+deb9u2.

We recommend that you upgrade your golang-1.8 packages.

For the detailed security status of golang-1.8 please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/golang-1.8

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS