Gentoo: GLSA-200408-08: Cfengine : RSA Authentication Heap Corruption

    Date10 Aug 2004
    CategoryGentoo
    33
    Posted ByLinuxSecurity Advisories
    Cfengine is vulnerable to a remote root exploit from clients in AllowConnectionsFrom.
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Gentoo Linux Security Advisory                           GLSA 200408-08
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                                http://security.gentoo.org/
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
      Severity: High
         Title: Cfengine : RSA Authentication Heap Corruption
          Date: August 10, 2004
          Bugs: #59895
            ID: 200408-08
    
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
    Synopsis
    ========
    
    Cfengine is vulnerable to a remote root exploit from clients in
    AllowConnectionsFrom.
    
    Background
    ==========
    
    Cfengine is an agent/software robot and a high level policy language
    for building expert systems to administrate and configure large
    computer networks.
    
    Affected packages
    =================
    
        -------------------------------------------------------------------
         Package            /   Vulnerable   /                  Unaffected
        -------------------------------------------------------------------
      1  net-misc/cfengine       <= 2.1.17 >= 2.1.8
         net-misc/cfengine       >= 2.0.0                         >= 2.1.8
    
    Description
    ===========
    
    Two vulnerabilities have been found in cfservd. One is a buffer
    overflow in the AuthenticationDialogue function and the other is a
    failure to check the proper return value of the ReceiveTransaction
    function.
    
    Impact
    ======
    
    An attacker could use the buffer overflow to execute arbitrary code
    with the permissions of the user running cfservd, which is usually the
    root user. However, before such an attack could be mounted, the
    IP-based ACL would have to be bypassed. With the second vulnerability,
    an attacker could cause a denial of service attack.
    
    Workaround
    ==========
    
    There is no known workaround at this time. All users are encouraged to
    upgrade to the latest available version of Cfengine.
    
    Resolution
    ==========
    
    All Cfengine users should upgrade to the latest version:
    
        # emerge sync
    
        # emerge -pv ">=net-misc/cfengine-2.1.8"
        # emerge ">=net-misc/cfengine-2.1.8"
    
    References
    ==========
    
      [ 1 ] Corelabs Advisory
            http://www.coresecurity.com/common/showdoc.php?idx=387&idxseccion=10
    
    Availability
    ============
    
    This GLSA and any updates to it are available for viewing at
    the Gentoo Security Website:
    
        http://security.gentoo.org/glsa/glsa-200408-08.xml
    
    Concerns?
    =========
    
    Security is a primary focus of Gentoo Linux and ensuring the
    confidentiality and security of our users machines is of utmost
    importance to us. Any security concerns should be addressed to
    This email address is being protected from spambots. You need JavaScript enabled to view it. or alternatively, you may file a bug at
    http://bugs.gentoo.org.
    
    License
    =======
    
    Copyright 2004 Gentoo Foundation, Inc; referenced text
    belongs to its owner(s).
    
    The contents of this document are licensed under the
    Creative Commons - Attribution / Share Alike license.
    
    http://creativecommons.org/licenses/by-sa/1.0
    
    You are not authorised to post comments.

    Comments powered by CComment

    LinuxSecurity Poll

    What do you think of the articles on LinuxSecurity?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/24-what-do-you-think-of-the-quality-of-the-articles-on-linuxsecurity?task=poll.vote&format=json
    24
    radio
    [{"id":"87","title":"Excellent, don't change a thing!","votes":"5","type":"x","order":"1","pct":55.56,"resources":[]},{"id":"88","title":"Should be more technical","votes":"3","type":"x","order":"2","pct":33.33,"resources":[]},{"id":"89","title":"Should include more HOWTOs","votes":"1","type":"x","order":"3","pct":11.11,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    Advisories

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.