Gentoo: GLSA-202209-07: Mrxvt: Arbitrary Code Execution | LinuxSecu...
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202209-07
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: Mrxvt: Arbitrary Code Execution
     Date: September 25, 2022
     Bugs: #791004
       ID: 202209-07

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability has been discovered in Mrxvt which could allow for
arbitrary code execution

Background
==========

Mrxvt is a multi-tabbed rxvt clone with XFT, transparent background and
CJK support.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  x11-terms/mrxvt            <= 0.5.4                  Vulnerable!

Description
===========

Mrxvt mishandles certain escape sequences, some of which allow for shell
command execution.

Impact
======

An attacker with sufficient access to write arbitrary text to the Mrxvt
terminal could execute arbitrary code.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

Gentoo has discontinued support for Mrxvt. We recommend that users
remove it:

  # emerge --ask --depclean "x11-terms/mrxvt"

References
==========

[ 1 ] CVE-2021-33477
      https://nvd.nist.gov/vuln/detail/CVE-2021-33477

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202209-07

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
[email protected] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2022 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Gentoo: GLSA-202209-07: Mrxvt: Arbitrary Code Execution

Summary

Mrxvt mishandles certain escape sequences, some of which allow for shell command execution.

Resolution

Gentoo has discontinued support for Mrxvt. We recommend that users remove it:
# emerge --ask --depclean "x11-terms/mrxvt"

References

[ 1 ] CVE-2021-33477 https://nvd.nist.gov/vuln/detail/CVE-2021-33477

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/202209-07

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to [email protected] or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: Normal
Title: Mrxvt: Arbitrary Code Execution
Date: September 25, 2022
Bugs: #791004
ID: 202209-07

Synopsis

A vulnerability has been discovered in Mrxvt which could allow for arbitrary code execution

Background

Mrxvt is a multi-tabbed rxvt clone with XFT, transparent background and CJK support.

Affected Packages

------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 x11-terms/mrxvt <= 0.5.4 Vulnerable!

Impact

An attacker with sufficient access to write arbitrary text to the Mrxvt terminal could execute arbitrary code.

Workaround

There is no known workaround at this time.

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.