openSUSE: 2020:0678-1: important: gstreamer-plugins-base

    Date 22 May 2020
    177
    Posted By LinuxSecurity Advisories
    An update that fixes one vulnerability is now available.
       openSUSE Security Update: Security update for gstreamer-plugins-base
    ______________________________________________________________________________
    
    Announcement ID:    openSUSE-SU-2020:0678-1
    Rating:             important
    References:         #1133375 
    Cross-References:   CVE-2019-9928
    Affected Products:
                        openSUSE Leap 15.1
    ______________________________________________________________________________
    
       An update that fixes one vulnerability is now available.
    
    Description:
    
       This update for gstreamer-plugins-base fixes the following issue:
    
       Security issue fixed:
    
       - CVE-2019-9928: Fixed a heap-based overflow in the rtsp connection parser
         (bsc#1133375).
    
       This update was imported from the SUSE:SLE-15:Update update project.
    
    
    Patch Instructions:
    
       To install this openSUSE Security Update use the SUSE recommended installation methods
       like YaST online_update or "zypper patch".
    
       Alternatively you can run the command listed for your product:
    
       - openSUSE Leap 15.1:
    
          zypper in -t patch openSUSE-2020-678=1
    
    
    
    Package List:
    
       - openSUSE Leap 15.1 (i586 x86_64):
    
          gstreamer-plugins-base-1.12.5-lp151.3.3.1
          gstreamer-plugins-base-debuginfo-1.12.5-lp151.3.3.1
          gstreamer-plugins-base-debugsource-1.12.5-lp151.3.3.1
          gstreamer-plugins-base-devel-1.12.5-lp151.3.3.1
          gstreamer-plugins-base-doc-1.12.5-lp151.3.3.1
          libgstallocators-1_0-0-1.12.5-lp151.3.3.1
          libgstallocators-1_0-0-debuginfo-1.12.5-lp151.3.3.1
          libgstapp-1_0-0-1.12.5-lp151.3.3.1
          libgstapp-1_0-0-debuginfo-1.12.5-lp151.3.3.1
          libgstaudio-1_0-0-1.12.5-lp151.3.3.1
          libgstaudio-1_0-0-debuginfo-1.12.5-lp151.3.3.1
          libgstfft-1_0-0-1.12.5-lp151.3.3.1
          libgstfft-1_0-0-debuginfo-1.12.5-lp151.3.3.1
          libgstpbutils-1_0-0-1.12.5-lp151.3.3.1
          libgstpbutils-1_0-0-debuginfo-1.12.5-lp151.3.3.1
          libgstriff-1_0-0-1.12.5-lp151.3.3.1
          libgstriff-1_0-0-debuginfo-1.12.5-lp151.3.3.1
          libgstrtp-1_0-0-1.12.5-lp151.3.3.1
          libgstrtp-1_0-0-debuginfo-1.12.5-lp151.3.3.1
          libgstrtsp-1_0-0-1.12.5-lp151.3.3.1
          libgstrtsp-1_0-0-debuginfo-1.12.5-lp151.3.3.1
          libgstsdp-1_0-0-1.12.5-lp151.3.3.1
          libgstsdp-1_0-0-debuginfo-1.12.5-lp151.3.3.1
          libgsttag-1_0-0-1.12.5-lp151.3.3.1
          libgsttag-1_0-0-debuginfo-1.12.5-lp151.3.3.1
          libgstvideo-1_0-0-1.12.5-lp151.3.3.1
          libgstvideo-1_0-0-debuginfo-1.12.5-lp151.3.3.1
          typelib-1_0-GstAllocators-1_0-1.12.5-lp151.3.3.1
          typelib-1_0-GstApp-1_0-1.12.5-lp151.3.3.1
          typelib-1_0-GstAudio-1_0-1.12.5-lp151.3.3.1
          typelib-1_0-GstFft-1_0-1.12.5-lp151.3.3.1
          typelib-1_0-GstPbutils-1_0-1.12.5-lp151.3.3.1
          typelib-1_0-GstRtp-1_0-1.12.5-lp151.3.3.1
          typelib-1_0-GstRtsp-1_0-1.12.5-lp151.3.3.1
          typelib-1_0-GstSdp-1_0-1.12.5-lp151.3.3.1
          typelib-1_0-GstTag-1_0-1.12.5-lp151.3.3.1
          typelib-1_0-GstVideo-1_0-1.12.5-lp151.3.3.1
    
       - openSUSE Leap 15.1 (noarch):
    
          gstreamer-plugins-base-lang-1.12.5-lp151.3.3.1
    
       - openSUSE Leap 15.1 (x86_64):
    
          gstreamer-plugins-base-32bit-1.12.5-lp151.3.3.1
          gstreamer-plugins-base-32bit-debuginfo-1.12.5-lp151.3.3.1
          gstreamer-plugins-base-devel-32bit-1.12.5-lp151.3.3.1
          libgstallocators-1_0-0-32bit-1.12.5-lp151.3.3.1
          libgstallocators-1_0-0-32bit-debuginfo-1.12.5-lp151.3.3.1
          libgstapp-1_0-0-32bit-1.12.5-lp151.3.3.1
          libgstapp-1_0-0-32bit-debuginfo-1.12.5-lp151.3.3.1
          libgstaudio-1_0-0-32bit-1.12.5-lp151.3.3.1
          libgstaudio-1_0-0-32bit-debuginfo-1.12.5-lp151.3.3.1
          libgstfft-1_0-0-32bit-1.12.5-lp151.3.3.1
          libgstfft-1_0-0-32bit-debuginfo-1.12.5-lp151.3.3.1
          libgstpbutils-1_0-0-32bit-1.12.5-lp151.3.3.1
          libgstpbutils-1_0-0-32bit-debuginfo-1.12.5-lp151.3.3.1
          libgstriff-1_0-0-32bit-1.12.5-lp151.3.3.1
          libgstriff-1_0-0-32bit-debuginfo-1.12.5-lp151.3.3.1
          libgstrtp-1_0-0-32bit-1.12.5-lp151.3.3.1
          libgstrtp-1_0-0-32bit-debuginfo-1.12.5-lp151.3.3.1
          libgstrtsp-1_0-0-32bit-1.12.5-lp151.3.3.1
          libgstrtsp-1_0-0-32bit-debuginfo-1.12.5-lp151.3.3.1
          libgstsdp-1_0-0-32bit-1.12.5-lp151.3.3.1
          libgstsdp-1_0-0-32bit-debuginfo-1.12.5-lp151.3.3.1
          libgsttag-1_0-0-32bit-1.12.5-lp151.3.3.1
          libgsttag-1_0-0-32bit-debuginfo-1.12.5-lp151.3.3.1
          libgstvideo-1_0-0-32bit-1.12.5-lp151.3.3.1
          libgstvideo-1_0-0-32bit-debuginfo-1.12.5-lp151.3.3.1
    
    
    References:
    
       https://www.suse.com/security/cve/CVE-2019-9928.html
       https://bugzilla.suse.com/1133375
    
    -- 
    

    LinuxSecurity Poll

    How do you feel about the elimination of the terms 'blacklist' and 'slave' from the Linux kernel?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/32-how-do-you-feel-about-the-elimination-of-the-terms-blacklist-and-slave-from-the-linux-kernel?task=poll.vote&format=json
    32
    radio
    [{"id":"112","title":"I strongly support this change - racially charged language should not be used in the code and documentation of the kernel and other open-source projects.","votes":"7","type":"x","order":"1","pct":18.42,"resources":[]},{"id":"113","title":"I'm indifferent - this small change will not affect broader issues of racial insensitivity and white privilege.","votes":"4","type":"x","order":"2","pct":10.53,"resources":[]},{"id":"114","title":"I'm opposed to this change - there is no need to change language that has been used for years. It doesn't make sense for people to take offense to terminology used in community projects.","votes":"27","type":"x","order":"3","pct":71.05,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350
    bottom 200

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.