
<!doctype html>
<html prefix="og: https://ogp.me/ns# fb: https://ogp.me/ns/fb# linux-security: https://ogp.me/ns/fb/linux-security#" lang="en-gb" dir="ltr">

<head>

<script type="text/javascript">
    (function(c,l,a,r,i,t,y){
        c[a]=c[a]||function(){(c[a].q=c[a].q||[]).push(arguments)};
        t=l.createElement(r);t.async=1;t.src="https://www.clarity.ms/tag/"+i;
        y=l.getElementsByTagName(r)[0];y.parentNode.insertBefore(t,y);
    })(window, document, "clarity", "script", "7cfho49ilc");
</script>
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-336357-8" type="text/javascript"></script>
<script type="text/javascript">window.dataLayer=window.dataLayer||[];function gtag(){dataLayer.push(arguments);}
gtag('js',new Date());gtag('config','UA-336357-8');</script>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-NBLR8DK');</script>


<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NBLR8DK" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<style>
@font-face {
  font-family: 'Arimo';
  font-style: normal;
  font-weight: 400;
  src: url('/fonts/arimo-v17-latin-regular.eot'); /* IE9 Compat Modes */
  src: local(''),
       url('/fonts/arimo-v17-latin-regular.eot?#iefix') format('embedded-opentype'), /* IE6-IE8 */
       url('/fonts/arimo-v17-latin-regular.woff2') format('woff2'), /* Super Modern Browsers */
       url('/fonts/arimo-v17-latin-regular.woff') format('woff'), /* Modern Browsers */
       url('/fonts/arimo-v17-latin-regular.ttf') format('truetype'), /* Safari, Android, iOS */
       url('/fonts/arimo-v17-latin-regular.svg#Arimo') format('svg'); /* Legacy iOS */
}

/* arimo-700 - latin */
@font-face {
  font-family: 'Arimo';
  font-style: normal;
  font-weight: 700;
  src: url('/fonts/arimo-v17-latin-700.eot'); /* IE9 Compat Modes */
  src: local(''),
       url('/fonts/arimo-v17-latin-700.eot?#iefix') format('embedded-opentype'), /* IE6-IE8 */
       url('/fonts/arimo-v17-latin-700.woff2') format('woff2'), /* Super Modern Browsers */
       url('/fonts/arimo-v17-latin-700.woff') format('woff'), /* Modern Browsers */
       url('/fonts/arimo-v17-latin-700.ttf') format('truetype'), /* Safari, Android, iOS */
       url('/fonts/arimo-v17-latin-700.svg#Arimo') format('svg'); /* Legacy iOS */
}

/* frank-ruhl-libre-300 - latin */
@font-face {
  font-family: 'Frank Ruhl Libre';
  font-style: normal;
  font-weight: 300;
  src: url('/fonts/frank-ruhl-libre-v6-latin-300.eot'); /* IE9 Compat Modes */
  src: local(''),
       url('/fonts/frank-ruhl-libre-v6-latin-300.eot?#iefix') format('embedded-opentype'), /* IE6-IE8 */
       url('/fonts/frank-ruhl-libre-v6-latin-300.woff2') format('woff2'), /* Super Modern Browsers */
       url('/fonts/frank-ruhl-libre-v6-latin-300.woff') format('woff'), /* Modern Browsers */
       url('/fonts/frank-ruhl-libre-v6-latin-300.ttf') format('truetype'), /* Safari, Android, iOS */
       url('/fonts/frank-ruhl-libre-v6-latin-300.svg#FrankRuhlLibre') format('svg'); /* Legacy iOS */
}

/* frank-ruhl-libre-regular - latin */
@font-face {
  font-family: 'Frank Ruhl Libre';
  font-style: normal;
  font-weight: 400;
  src: url('/fonts/frank-ruhl-libre-v6-latin-regular.eot'); /* IE9 Compat Modes */
  src: local(''),
       url('/fonts/frank-ruhl-libre-v6-latin-regular.eot?#iefix') format('embedded-opentype'), /* IE6-IE8 */
       url('/fonts/frank-ruhl-libre-v6-latin-regular.woff2') format('woff2'), /* Super Modern Browsers */
       url('/fonts/frank-ruhl-libre-v6-latin-regular.woff') format('woff'), /* Modern Browsers */
       url('/fonts/frank-ruhl-libre-v6-latin-regular.ttf') format('truetype'), /* Safari, Android, iOS */
       url('/fonts/frank-ruhl-libre-v6-latin-regular.svg#FrankRuhlLibre') format('svg'); /* Legacy iOS */
}

/* frank-ruhl-libre-700 - latin */
@font-face {
  font-family: 'Frank Ruhl Libre';
  font-style: normal;
  font-weight: 700;
  src: url('../fonts/frank-ruhl-libre-v6-latin-700.eot'); /* IE9 Compat Modes */
  src: local(''),
       url('../fonts/frank-ruhl-libre-v6-latin-700.eot?#iefix') format('embedded-opentype'), /* IE6-IE8 */
       url('../fonts/frank-ruhl-libre-v6-latin-700.woff2') format('woff2'), /* Super Modern Browsers */
       url('../fonts/frank-ruhl-libre-v6-latin-700.woff') format('woff'), /* Modern Browsers */
       url('../fonts/frank-ruhl-libre-v6-latin-700.ttf') format('truetype'), /* Safari, Android, iOS */
       url('../fonts/frank-ruhl-libre-v6-latin-700.svg#FrankRuhlLibre') format('svg'); /* Legacy iOS */
}

</style>
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">
<link rel="canonical" href="https://linuxsecurity.com/features/essential-guide-to-securing-node-js-applications">
<script data-cfasync="false" src="/media/jui/js/jquery.min.js" type="text/javascript"></script>
<meta name="propeller" content="b6e67365acd11fa2b0e9354078eb2b1c">
<link rel="apple-touch-icon-precomposed" sizes="57x57" href="https://linuxsecurity.com/favicon/apple-touch-icon-57x57.png" />
<link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://linuxsecurity.com/favicon/apple-touch-icon-114x114.png" />
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://linuxsecurity.com/favicon/apple-touch-icon-72x72.png" />
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://linuxsecurity.com/favicon/apple-touch-icon-144x144.png" />
<link rel="apple-touch-icon-precomposed" sizes="60x60" href="https://linuxsecurity.com/favicon/apple-touch-icon-60x60.png" />
<link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://linuxsecurity.com/favicon/apple-touch-icon-120x120.png" />
<link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://linuxsecurity.com/favicon/apple-touch-icon-76x76.png" />
<link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://linuxsecurity.com/favicon/apple-touch-icon-152x152.png" />
<link rel="icon" type="image/png" href="https://linuxsecurity.com/favicon/favicon-196x196.png" sizes="196x196" />
<link rel="icon" type="image/png" href="https://linuxsecurity.com/favicon/favicon-96x96.png" sizes="96x96" />
<link rel="icon" type="image/png" href="https://linuxsecurity.com/favicon/favicon-32x32.png" sizes="32x32" />
<link rel="icon" type="image/png" href="https://linuxsecurity.com/favicon/favicon-16x16.png" sizes="16x16" />
<link rel="icon" type="image/png" href="https://linuxsecurity.com/favicon/favicon-128.png" sizes="128x128" />
<meta name="msapplication-TileColor" content="#FFFFFF" />
<meta name="msapplication-TileImage" content="https://linuxsecurity.com/favicon/mstile-144x144.png" />
<meta name="msapplication-square70x70logo" content="https://linuxsecurity.com/favicon/mstile-70x70.png" />
<meta name="msapplication-square150x150logo" content="https://linuxsecurity.com/favicon/mstile-150x150.png" />
<meta name="msapplication-wide310x150logo" content="https://linuxsecurity.com/favicon/mstile-310x150.png" />
<meta name="msapplication-square310x310logo" content="https://linuxsecurity.com/favicon/mstile-310x310.png" />
<meta name="msapplication-notification" content="frequency=30;polling-uri=https://notifications.buildmypinnedsite.com/?feed=https://linuxsecurity.com/news/latest?format=feed&type=rss&amp;id=1;polling-uri2=https://notifications.buildmypinnedsite.com/?feed=https://linuxsecurity.com/news/latest?format=feed&type=rss&amp;id=2;polling-uri3=https://notifications.buildmypinnedsite.com/?feed=https://linuxsecurity.com/news/latest?format=feed&type=rss&amp;id=3;polling-uri4=https://notifications.buildmypinnedsite.com/?feed=https://linuxsecurity.com/news/latest?format=feed&type=rss&amp;id=4;polling-uri5=https://notifications.buildmypinnedsite.com/?feed=https://linuxsecurity.com/news/latest?format=feed&type=rss&amp;id=5;cycle=1" />
<link href="https://linuxsecurity.com/favicon/favicon-96x96.png" rel="shortcut icon" type="image/vnd.microsoft.icon" />
<link href="/templates/newsberg/css/font-awesome.min.css" rel="stylesheet" type="text/css" />
<base href="https://linuxsecurity.com/features/essential-guide-to-securing-node-js-applications" />
<meta http-equiv="content-type" content="text/html; charset=utf-8" />
<meta name="keywords" content="ability, backend, server, applications, becoming, trendy" />
<meta name="author" content="Harikrishna Kundariya" />
<meta name="description" content="Essential Guide to Securing Node.JS Applications -   Open-source backend frameworks have long had security flaws, and every Node.js developer know" />
<meta name="generator" content="HELIX_ULTIMATE_GENERATOR_TEXT" />
<title>Essential Guide to Securing Node.JS Applications | LinuxSecurity.com</title>
<link href="//linuxsecurity.com/favicon/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" />
<link href="/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" />
<link href="/media/plg_content_jcodesyntaxhighlighter/css/default.css?5c57c2ef428338f2dd94725e3b506af6" rel="stylesheet" type="text/css" />
<link href="/media/plg_content_jcodesyntaxhighlighter/combined/linenumbers-previewers.css?5c57c2ef428338f2dd94725e3b506af6" rel="stylesheet" type="text/css" />
<link href="/media/plg_content_readingtime/css/readingprogress.css" rel="stylesheet" type="text/css" />
<link href="https://linuxsecurity.com/components/com_sppagebuilder/assets/css/sppagebuilder.css" rel="stylesheet" type="text/css" />
<link href="/plugins/system/jce/css/content.css?badb4208be409b1335b815dde676300e" rel="stylesheet" type="text/css" />
<link href="/media/com_rstbox/css/engagebox.css?5c57c2ef428338f2dd94725e3b506af6" rel="stylesheet" type="text/css" />
<link href="https://linuxsecurity.com/media/com_acym/css/module.min.css?v=793" rel="stylesheet" type="text/css" />
<link href="/media/sourcecoast/css/sc_bootstrap.css" rel="stylesheet" type="text/css" />
<link href="/media/sourcecoast/css/common.css" rel="stylesheet" type="text/css" />
<link href="//fonts.googleapis.com/css?family=Arimo:100,100i,300,300i,400,400i,500,500i,700,700i,900,900i&subset=latin-ext&display=swap" rel="stylesheet" media="none" onload="media=&quot;all&quot;" type="text/css" />
<link href="//fonts.googleapis.com/css?family=Frank Ruhl Libre:100,100i,300,300i,400,400i,500,500i,700,700i,900,900i&subset=latin-ext&display=swap" rel="stylesheet" media="none" onload="media=&quot;all&quot;" type="text/css" />
<link href="/templates/newsberg/css/bootstrap.min.css" rel="stylesheet" type="text/css" />
<link href="/plugins/system/helixultimate/assets/css/system-j3.min.css" rel="stylesheet" type="text/css" />
<link href="/templates/newsberg/css/font-awesome.min.css" rel="stylesheet" type="text/css" />
<link href="/templates/newsberg/css/custom.css" rel="stylesheet" type="text/css" />
<link href="/templates/newsberg/css/fa-v4-shims.css" rel="stylesheet" type="text/css" />
<link href="/templates/newsberg/css/template.css" rel="stylesheet" type="text/css" />
<link href="/templates/newsberg/css/presets/default.css" rel="stylesheet" type="text/css" />
<link href="/components/com_sppagebuilder/assets/css/sppagebuilder.css" rel="stylesheet" type="text/css" />
<link href="//fonts.googleapis.com/css?family=Frank+Ruhl+Libre:100,100italic,200,200italic,300,300italic,400,400italic,500,500italic,600,600italic,700,700italic,800,800italic,900,900italic&display=swap" rel="stylesheet" type="text/css" />
<link href="https://linuxsecurity.com//templates/newsberg/css/swiper.min.css" rel="stylesheet" type="text/css" />
<link href="/media/foundry/css/foundry.min.css?6e0c5d81f59bef066c2ea2fe22af723e=1" rel="stylesheet" type="text/css" />
<link href="/media/foundry/css/vendor/fontawesome/css/all.min.css?6e0c5d81f59bef066c2ea2fe22af723e=1" rel="stylesheet" type="text/css" />
<link href="/media/foundry/css/vendor/lightbox/lightbox.min.css?6e0c5d81f59bef066c2ea2fe22af723e=1" rel="stylesheet" type="text/css" />
<link href="/media/foundry/css/vendor/markitup/markitup.min.css?6e0c5d81f59bef066c2ea2fe22af723e=1" rel="stylesheet" type="text/css" />
<link href="/media/com_komento/themes/wireframe/css/style.min.css?ef4e7198f946a9361df5aff296d067d4=1" rel="stylesheet" type="text/css" />
<link href="/media/foundry/css/utilities.min.css?6e0c5d81f59bef066c2ea2fe22af723e=1" rel="stylesheet" type="text/css" />
<link href="https://linuxsecurity.com/plugins/system/fmalertcookies/assets/css/bootstrap.min.css" rel="stylesheet" type="text/css" />
<link href="https://linuxsecurity.com/plugins/system/fmalertcookies/assets/css/custom.css" rel="stylesheet" type="text/css" />
<style type="text/css">
.form-like {margin:15px 0!important;}.btn-like {background-color: transparent!important;background-image: none;border-radius: 4px;border: 1px solid #ccc;color: #999;line-height: 18px!important;height: 30px!important;padding: 6px 10px 5px 10px!important;text-shadow:none;box-sizing:border-box;}.btn-like:hover {border-color: #4098d1;}.btn-like img {margin-right: 5px;float: left;}.element-invisible {position: absolute;padding: 0;margin: 0;border: 0;height: 1px;width: 1px;overflow: hidden;}
.eb-4 {
                --animation_duration: 300ms;

            }
        div#rstbox_4 .eb-content.rstbox-content li {
    margin: 5px 0px;
    border-bottom: 1px solid;
}
#rstbox_4 ul.sp-mega-group {
    margin: 0px 0px 1rem 0px;
}
div#rstbox_4  li.menu_item img {
    width: 30px;
}
div#rstbox_4 .eb-content.rstbox-content a {
    display: flex;
    align-items: left;
    margin-bottom: 10px;
}
div#rstbox_4 .eb-content.rstbox-content {
    display: contents;
}
div#rstbox_4 .col-sm-4 {
    flex: 0 0 100.333333%;
    max-width: 100.333333%;
}
div#rstbox_4 .eb-header.rstbox-header {
    text-align: center;
    padding: 0px 35px;
    color: #000;
    font-weight: 700;
}
@media(min-width:992px){
#sp-top1 > .sp-column > .sp-module .menu-collapse-icon{
display:none;
}
}
#sp-top1 > .sp-column > .sp-module .sp-module-title{cursor:pointer;}
#rstbox_4 .eb-content.rstbox-content{
display: -ms-flexbox;
    display: flex;
    -ms-flex-wrap: wrap;
    flex-wrap: wrap;
    margin-right: -15px;
    margin-left: -15px;
}
#rstbox_4 .eb-content.rstbox-content li, #rstbox_4 .eb-content.rstbox-content img, #rstbox_4 .eb-content.rstbox-content span {
    list-style: none;
    text-align: left;
    margin-left: 10px;
    display: block;
    float: none;
}
#rstbox_4  ul.sp-mega-group {
    padding-left: 0;
}
		.eb-4 .eb-close:hover {
			color: rgba(128, 128, 128, 1) !important;
		}	
	.eb-6 {
                --animation_duration: 200ms;

            }
        .ebStickyBar .eb {
    font-size: 16px;
}
.ebStickyBar .eb-close {
    margin-top: -15px;
    right: 16px;
    top: 50%;
}
.ebStickyBar .eb-close span {
    border: solid 2px rgba(255,255,255,.3);
    border-radius: 100%;
    width: 27px;
    height: 27px;
    display: flex;
    justify-content: center;
    font-family: Arial;
}
.ebStickyBar .eb-close:hover span {
    border-color: rgba(255,255,255,1);
}
.eb .eb-btn.eb-btn-primary{
background-color: #fa8f1f;
}

		.eb-6 .eb-close:hover {
			color: rgba(255, 255, 255, 1) !important;
		}	
	.eb-7 {
                --animation_duration: 200ms;

            }
        .ebStickyBar .eb {
    font-size: 16px;
}
.ebStickyBar .eb-close {
    margin-top: -15px;
    right: 16px;
    top: 50%;
}
.ebStickyBar .eb-close span {
    border: solid 2px rgba(255,255,255,.3);
    border-radius: 100%;
    width: 27px;
    height: 27px;
    display: flex;
    justify-content: center;
    font-family: Arial;
}
.ebStickyBar .eb-close:hover span {
    border-color: rgba(255,255,255,1);
}

		.eb-7 .eb-close:hover {
			color: rgba(255, 255, 255, 1) !important;
		}	
	.eb-8 {
                --animation_duration: 300ms;

            }
        .eb-inst.eb-8 .eb-content input[type="checkbox"] {
    top: 10.5px;
    right: 5px;
}
		.eb-8 .eb-close:hover {
			color: rgba(85, 85, 85, 1) !important;
		}	
	body{font-family: 'Arimo', sans-serif;font-size: 16px;text-decoration: none;}
h1{font-family: 'Frank Ruhl Libre', sans-serif;font-size: 60px;font-weight: 400;text-decoration: none;}
h2{font-family: 'Frank Ruhl Libre', sans-serif;font-size: 34px;text-decoration: none;}
h3{font-family: 'Frank Ruhl Libre', sans-serif;font-size: 27px;text-decoration: none;}
h4{font-family: 'Frank Ruhl Libre', sans-serif;font-size: 18px;text-decoration: none;}
.logo-image {height:90px;}.logo-image-phone {height:90px;}
	</style>
<script type="application/json" class="joomla-script-options new">{"csrf.token":"6693da89c632b40b787046d4b192f330","system.paths":{"root":"","base":""},"fd.options":{"rootUrl":"https:\/\/linuxsecurity.com","environment":"production","version":"1.1.13","token":"6693da89c632b40b787046d4b192f330","scriptVersion":"6e0c5d81f59bef066c2ea2fe22af723e=1","scriptVersioning":true,"isMobile":false},"data":{"breakpoints":{"tablet":991,"mobile":480},"header":{"stickyOffset":"100"}}}</script>
<script src="/media/plg_content_jcodesyntaxhighlighter/js/prism-previewers-copy.js?5c57c2ef428338f2dd94725e3b506af6" async="async" type="text/javascript"></script>
<script src="/media/jui/js/jquery.min.js?5c57c2ef428338f2dd94725e3b506af6" type="text/javascript"></script>
<script src="/media/jui/js/jquery-noconflict.js?5c57c2ef428338f2dd94725e3b506af6" type="text/javascript"></script>
<script src="/media/jui/js/jquery-migrate.min.js?5c57c2ef428338f2dd94725e3b506af6" type="text/javascript"></script>
<script src="/media/plg_content_readingtime/js/readingprogress.js" type="text/javascript"></script>
<script src="/media/system/js/core.js?5c57c2ef428338f2dd94725e3b506af6" type="text/javascript"></script>
<script src="/media/foundry/scripts/core.min.js?6e0c5d81f59bef066c2ea2fe22af723e=1" type="text/javascript"></script>
<script src="/media/system/js/caption.js?5c57c2ef428338f2dd94725e3b506af6" type="text/javascript"></script>
<script src="/media/com_rstbox/js/vendor/velocity.js?5c57c2ef428338f2dd94725e3b506af6" type="text/javascript"></script>
<script src="/media/com_rstbox/js/vendor/velocity.ui.js?5c57c2ef428338f2dd94725e3b506af6" type="text/javascript"></script>
<script src="/media/com_rstbox/js/engagebox.js?5c57c2ef428338f2dd94725e3b506af6" type="text/javascript"></script>
<script src="/media/com_rstbox/js/animations.js?5c57c2ef428338f2dd94725e3b506af6" type="text/javascript"></script>
<script src="/media/com_rstbox/js/pageslide_mode.js?5c57c2ef428338f2dd94725e3b506af6" type="text/javascript"></script>
<script src="https://linuxsecurity.com/media/com_acym/js/module.min.js?v=793" type="text/javascript" defer="defer"></script>
<script src="/components/com_jfbconnect/includes/jfbconnect.js?v=6" type="text/javascript"></script>
<script src="/templates/newsberg/js/popper.min.js" type="text/javascript"></script>
<script src="/templates/newsberg/js/bootstrap.min.js" type="text/javascript"></script>
<script src="/templates/newsberg/js/main.js" type="text/javascript"></script>
<script src="/components/com_sppagebuilder/assets/js/jquery.parallax.js?b207d5ea705bc7af71d987f0fcb1ace1" type="text/javascript"></script>
<script src="/components/com_sppagebuilder/assets/js/sppagebuilder.js?b207d5ea705bc7af71d987f0fcb1ace1" defer="defer" type="text/javascript"></script>
<script src="/media/com_cjlib/plugins/validation/jquery.validate.min.js" type="text/javascript"></script>
<script src="https://www.gstatic.com/charts/loader.js" type="text/javascript"></script>
<script src="https://linuxsecurity.com//templates/newsberg/js/swiper.min.js" type="text/javascript"></script>
<script src="/plugins/system/antispambycleantalk/js/ct-functions.js?1662598157" type="text/javascript"></script>
<script src="/media/plg_captcha_recaptcha/js/recaptcha.min.js?5c57c2ef428338f2dd94725e3b506af6" type="text/javascript"></script>
<script src="https://www.google.com/recaptcha/api.js?onload=JoomlaInitReCaptcha2&render=explicit&hl=en-GB" type="text/javascript"></script>
<script type="text/javascript">
jQuery(function($){ initTooltips(); $("body").on("subform-row-add", initTooltips); function initTooltips (event, container) { container = container || document;$(container).find(".hasTooltip").tooltip({"html": true,"container": "body"});} });jQuery(window).on('load',  function() {
				new JCaption('img.caption');
			});
            <!-- EngageBox #6 Actions Start -->
            
        !(function() {  
                if (!EngageBox) {
                    return;
                }

                EngageBox.onReady(function() {
                    var me = EngageBox.getInstance(6);

                    if (!me) {
                        return;
                    }

                    
        !(function() { me.on("close", function() { EngageBox.getInstance(7).open(); }); })();
                });
             })();
            <!-- EngageBox #6 Actions End -->
        
        if(typeof acymModule === 'undefined'){
            var acymModule = [];
			acymModule['emailRegex'] = /^[a-z0-9!#$%&\'*+\/=?^_`{|}~-]+(?:\.[a-z0-9!#$%&\'*+\/=?^_`{|}~-]+)*\@([a-z0-9-]+\.)+[a-z0-9]{2,20}$/i;
			acymModule['NAMECAPTION'] = 'Name';
			acymModule['NAME_MISSING'] = 'Please enter your name';
			acymModule['EMAILCAPTION'] = 'Email';
			acymModule['VALID_EMAIL'] = 'Please enter a valid e-mail address';
			acymModule['VALID_EMAIL_CONFIRMATION'] = 'Email field and email confirmation field must be identical';
			acymModule['CAPTCHA_MISSING'] = 'The captcha is invalid, please try again';
			acymModule['NO_LIST_SELECTED'] = 'Please select the lists you want to subscribe to';
			acymModule['NO_LIST_SELECTED_UNSUB'] = 'Please select the lists you want to unsubscribe from';
            acymModule['ACCEPT_TERMS'] = 'Please check the Terms and Conditions / Privacy policy';
        }
		window.addEventListener("DOMContentLoaded", (event) => {
acymModule["excludeValuesformAcym54841"] = [];
acymModule["excludeValuesformAcym54841"]["1"] = "Name";
acymModule["excludeValuesformAcym54841"]["2"] = "Email";  });template="newsberg";var cjlib_loc = "/components/com_cjlib";document.addEventListener("DOMContentLoaded", function(){});window.addEventListener("DOMContentLoaded", (event) => {
acymModule["excludeValuesformAcym96262"] = [];
acymModule["excludeValuesformAcym96262"]["1"] = "Name";
acymModule["excludeValuesformAcym96262"]["2"] = "Email";  });jQuery( document ).ready(function( $ ) {
			var articleSlider = new Swiper("#sppb-addon-1575467171374 .intro-items-slider", {
				breakpoints: {
					478: {
						slidesPerView: 1,	
						spaceBetween: 0,
					},
					768: {
						slidesPerView: 2,	
						spaceBetween: 20,
					},
					1199: {
						slidesPerView: 3,	
						spaceBetween: 30,
					}
				},
				lazy: true,
				navigation: {
					nextEl: ".swiper-button-next",
					prevEl: ".swiper-button-prev",
				}
			});
		});jQuery( document ).ready(function( $ ) {
			var articleSlider = new Swiper("#sppb-addon-1575467041907 .intro-items-slider", {
				breakpoints: {
					478: {
						slidesPerView: 1,	
						spaceBetween: 0,
					},
					768: {
						slidesPerView: 2,	
						spaceBetween: 20,
					},
					1199: {
						slidesPerView: 4,	
						spaceBetween: 30,
					}
				},
				lazy: true,
				navigation: {
					nextEl: ".swiper-button-next",
					prevEl: ".swiper-button-prev",
				}
			});
		});var ct_joom25=false;ctSetCookie("ct_checkjs", "1744126999", "0");
	</script>
<!--googleoff: index-->
<script type="text/javascript">
window.kt = {
	"appearance": "light",
	"theme": "foundry",
	"ajaxUrl": "https://linuxsecurity.com/?option=com_komento&lang=&Itemid=110",
	"direction": "ltr",
	"environment": "production",
	"ios": false,
	"locale": "en-GB",
	"mobile": false,
	"rootUrl": "https://linuxsecurity.com",
	"ratings": {
		"options": {
			"starType": 'i',
			"half": true,
			"starOn": 'raty raty-star raty-star--on',
			"starOff": 'raty raty-star-o raty-star--off',
			"starHalf": 'raty raty-star-half-o',
			"hints": [
				"bad", 
				"poor",
				"regular",
				"good",
				"gorgeous"
			]
		}
	},
	"siteName": "Linux Security",
	"token": "6693da89c632b40b787046d4b192f330",
	"isHttps": true,
};
</script>
<!--googleon: index-->
<script src="/media/com_komento/scripts/site-4.0.4.min.js"></script>
<meta property="og:image" content="https://linuxsecurity.com/images/articles/900x500/2.Motherboard.webp" />
<meta property="og:image:width" content="900" />
<meta property="og:image:height" content="500" />
<meta name="twitter:image:src" content="https://linuxsecurity.com/images/articles/900x500/2.Motherboard.webp" />
<meta name="twitter:card" content="summary_large_image" />
<script type="text/javascript">jfbc.base = 'https://linuxsecurity.com/';
jfbc.return_url = 'L2ZlYXR1cmVzL2Vzc2VudGlhbC1ndWlkZS10by1zZWN1cmluZy1ub2RlLWpzLWFwcGxpY2F0aW9ucw==';
jfbc.token = '6693da89c632b40b787046d4b192f330';
jfbc.init();
</script>
<meta name="twitter:site" content="LinuxSecurity" />
<meta property="og:url" content="https://linuxsecurity.com/features/essential-guide-to-securing-node-js-applications" /> <meta property="og:title" content="Essential Guide to Securing Node.JS Applications | LinuxSecurity.com" /> <meta name="twitter:title" content="Essential Guide to Securing Node.JS Applications | LinuxSecurity.com" /> <meta property="og:description" content="Essential Guide to Securing Node.JS Applications -   Open-source backend frameworks have long had security flaws, and every Node.js developer know" /> <meta name="twitter:description" content="Essential Guide to Securing Node.JS Applications -   Open-source backend frameworks have long had security flaws, and every Node.js developer know" /> <meta property="og:type" content="website" /> <meta property="fb:app_id" content="2088007108047521" /> <meta property="og:locale" content="en" /> <meta property="og:site_name" content="Linux Security" />
<script src="/media/com_cjlib/bootstrap/js/respond.min.js" type="text/javascript"></script>
<link rel="stylesheet" href="/media/com_cjlib/plugins/fontawesome/css/font-awesome.min.css" type="text/css" />
<link rel="stylesheet" href="/media/com_cjlib/bootstrap/css/bootstrap.core.min.css" type="text/css" />
<link rel="stylesheet" href="/media/com_communitypolls/css/cj.polls.min.css" type="text/css" />
<script src="/media/com_communitypolls/js/cj.polls.min.js?t=1660149463" type="text/javascript"></script>

<script type="application/ld+json" data-type="gsd">
{
    "@context": "https://schema.org",
    "@type": "BreadcrumbList",
    "itemListElement": [
        {
            "@type": "ListItem",
            "position": 1,
            "name": "Home",
            "item": "https://linuxsecurity.com/"
        },
        {
            "@type": "ListItem",
            "position": 2,
            "name": "Features",
            "item": "https://linuxsecurity.com/features"
        },
        {
            "@type": "ListItem",
            "position": 3,
            "name": "Essential Guide to Securing Node.JS Applications",
            "item": "https://linuxsecurity.com/features/essential-guide-to-securing-node-js-applications"
        }
    ]
}
</script>
<script type="application/ld+json" data-type="gsd">
{
    "@context": "https://schema.org",
    "@type": "Article",
    "mainEntityOfPage": {
        "@type": "WebPage",
        "@id": "https://linuxsecurity.com/features/essential-guide-to-securing-node-js-applications"
    },
    "headline": "Essential Guide to Securing Node.JS Applications",
    "description": "&lt;p&gt;Due to its ability to act as the backend server for web applications, Node.js is becoming a trendy platform these days. However, it becomes crucial to take into account Node.js security policies when it comes to the world of microservices.&lt;/p&gt;",
    "image": {
        "@type": "ImageObject",
        "url": "https://linuxsecurity.com/images/articles/900x500/2.Motherboard.webp"
    },
    "publisher": {
        "@type": "Organization",
        "name": "Linux Security",
        "logo": {
            "@type": "ImageObject",
            "url": "https://linuxsecurity.com/"
        }
    },
    "datePublished": "2022-08-26T07:00:37-04:00",
    "dateCreated": "2022-08-26T07:00:42-04:00",
    "dateModified": "2022-08-26T14:40:49-04:00"
}
</script>

<link rel="stylesheet" href="/templates/newsberg/plugins/owlcarousel/assets/owl.carousel.min.css">
<link rel="stylesheet" href="/templates/newsberg/plugins/owlcarousel/assets/owl.theme.default.min.css">
<link rel="stylesheet" href="/templates/newsberg/css/listnav.css">
<script src="/templates/newsberg/plugins/owlcarousel/owl.carousel.min.js"></script>
<script src="/templates/newsberg/js/jquery-listnav.js"></script>
<style>
			body.ltr .sp-megamenu-parent > li.sp-has-child > a::after, body.ltr .sp-megamenu-parent > li.sp-has-child > span::after {
				font-family: "FontAwesome" !important;
			}
		</style>
<link rel="preload" as="script" href="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></head>
<body class="site helix-ultimate hu com-content view-article layout-blog task-none itemid-110 en-gb ltr sticky-header layout-fluid offcanvas-init offcanvs-position-left"><script type="text/javascript">
  
  window.fbAsyncInit = function() {
    FB.init({version: 'v3.3',appId: '2088007108047521', status: false, cookie: true, xfbml: true});
FB.Event.subscribe('comment.create', jfbc.social.facebook.comment.create);
FB.Event.subscribe('comment.remove', jfbc.social.facebook.comment.remove);
  };
  (function(d, s, id){
     var js, fjs = d.getElementsByTagName(s)[0];
     if (d.getElementById(id)) {return;}
     js = d.createElement(s); js.id = id;
     js.src = "//connect.facebook.net/en/sdk.js";
     fjs.parentNode.insertBefore(js, fjs);
   }(document, 'script', 'facebook-jssdk'));
</script>
<div class="body-wrapper">
<div class="body-innerwrapper">
<section id="sp-top-bar">
<div class="container">
<div class="container-inner">
<div class="row">
<div id="sp-top1" class="col-1 col-sm-1 col-md-1 col-lg-4 "><div class="sp-column "><div class="sp-module "><div class="sp-module-content">
<div class="custom">
<h3 class="sp-module-title">Advisories</h3></div>
</div></div><div class="sp-module top-search"><div class="sp-module-content">
<div class="top-search-wrapper">
<div class="icon-top-wrapper">
<i class="fa fa-search search-icon" aria-hidden="true"></i>
<div class="close-icon">
<div class="icon-close-wrap">
<div class="icon-close"></div>
</div>
</div>
</div>
<div class="row top-search-input-wrap">
<div class="col-sm-12">
<div class="searchwrapper">
<h3 class="input-title">What Are You Looking For?</h3>
<form action="/features" method="post">
<div class="searchtop-search">
<div class="top-search-wrapper"><div class="sp_search_input"><i class="fa fa-search" aria-hidden="true"></i><input name="searchword" maxlength="200" class="mod-search-searchword inputboxtop-search" type="text" size="0" value="Search ..." onblur="if (this.value=='') this.value='Search ...';" onfocus="if (this.value=='Search ...') this.value='';" /></div></div> <input type="hidden" name="task" value="search" />
<input type="hidden" name="option" value="com_search" />
<input type="hidden" name="Itemid" value="801" />
</div>
</form>
</div> 
</div> 
<div class="col-sm-12"> 
<h4 class="tags-title">Popular Tags</h4>
<div class="popular-tags-wrap">
<ul>
<li>
<a href="/component/search/?areas[0]=tags&amp;searchword=ransomware" title="ransomware">ransomware</a>
</li>
<li>
<a href="/component/search/?areas[0]=tags&amp;searchword=must-read" title="must-read">must-read</a>
</li>
</ul>
</div>
</div> 
</div> 
</div>  </div></div></div></div><div id="sp-logo" class="col-1 col-sm-1 col-md-4 col-lg-4 "><div class="sp-column "><a id="offcanvas-toggler" aria-label="Navigation" class="offcanvas-toggler-left d-block d-lg-none" href="#" title=""><span class="fa fa-bars" aria-hidden="true" title="igation"></span></a><div class="logo"><a href="/" title="Linux Security"><img class="logo-image d-none d-lg-inline-block" src="/images/linux-security.webp" alt="Linux Security" width="295" height="101"><img class="logo-image-phone d-inline-block d-lg-none" src="/images/linux-security-penguin.webp" alt="Linux Security Penguin" width="92" height="101"></a></div></div></div><div id="sp-top4" class="col-1 col-sm-1 col-md-4 col-lg-4 "><div class="sp-column "><div class="sp-module login-top"><div class="sp-module-content">
<div class="customlogin-top">
<p><div class="adloader" ad="top4ajax"><div class="sp-custom-login sp-mod-login"><span class="info-text"><a class="sppb-btn sppb-btn-link open-login" onclick="jQuery('#login').show('fast');" role="button" title="Login"><i class="fn-man-user"></i> Login</a></span></div></div></p></div>
</div></div><div class="sp-module contribute"><div class="sp-module-content"><div class="mod-sppagebuilder contribute sp-page-builder" data-module_id="219">
<div class="page-content">
<div id="section-id-1574145450184" class="sppb-section"><div class="sppb-container-inner"><div class="sppb-row"><div class="sppb-col-md-12" id="column-wrap-id-1574145450183"><div id="column-id-1574145450183" class="sppb-column"><div class="sppb-column-addons"><div id="sppb-addon-wrapper-1574226143487" class="sppb-addon-wrapper"><div id="sppb-addon-1574226143487" class="clearfix "><div class="sppb-addon sppb-addon-button-group sppb-text-right"><div class="sppb-addon-content"><a href="/register" id="btn-1574226143487" class="sppb-btn  sppb-btn-primary sppb-btn-sm sppb-btn-round sppb-btn-outline" title="Contribute">Contribute</a></div></div><style type="text/css">#sppb-addon-1574226143487 {
	box-shadow: 0 0 0 0 #ffffff;
}
#sppb-addon-1574226143487 {
}
#sppb-addon-1574226143487.sppb-element-loaded {
}
@media (min-width: 768px) and (max-width: 991px) {#sppb-addon-1574226143487 {}}@media (max-width: 767px) {#sppb-addon-1574226143487 {}}</style><style type="text/css"></style></div></div></div></div></div></div></div></div><style type="text/css">.sp-page-builder .page-content #landing-page-heading{padding-top:0px;padding-right:0px;padding-bottom:0px;padding-left:0px;margin-top:0px;margin-right:0px;margin-bottom:0px;margin-left:0px;box-shadow:0 0 0 0 #ffffff;}#column-id-1621349883047{box-shadow:0 0 0 0 #fff;}.sp-page-builder .page-content #section-id-1621349883049{padding-top:50px;padding-right:0px;padding-bottom:0px;padding-left:0px;margin-top:0px;margin-right:0px;margin-bottom:0px;margin-left:0px;box-shadow:0 0 0 0 #ffffff;}#column-id-1621349883050{box-shadow:0 0 0 0 #fff;}.sp-page-builder .page-content #section-id-1574934640685{padding-top:90px;padding-right:0px;padding-bottom:50px;padding-left:0px;margin-top:0px;margin-right:0px;margin-bottom:0px;margin-left:0px;background-color:#1d1d1d;background-image:url(/images/2021/04/29/secure-webserver-bg.webp);background-repeat:no-repeat;background-size:cover;background-attachment:scroll;background-position:50% 50%;}@media (min-width:768px) and (max-width:991px) { .sp-page-builder .page-content #section-id-1574934640685{padding-top:40px;padding-right:0px;padding-bottom:10px;padding-left:0px;} }@media (max-width:767px) { .sp-page-builder .page-content #section-id-1574934640685{padding-top:20px;padding-right:0px;padding-bottom:0px;padding-left:0px;} }.sp-page-builder .page-content #section-id-1574934640685 > .sppb-row-overlay {mix-blend-mode:normal;}.sp-page-builder .page-content #section-id-1574145450184{padding-top:0px;padding-right:0px;padding-bottom:0px;padding-left:0px;margin-top:0px;margin-right:0px;margin-bottom:0px;margin-left:0px;}#column-id-1574145450183{box-shadow:0 0 0 0 #fff;}</style> </div>
</div>
</div></div><ul class="social-icons"><li class="social-icon-facebook"><a target="_blank" href="https://www.facebook.com/lnxsec/" aria-label="facebook" title="Lnxsec"><span class="fa fa-facebook" aria-hidden="true"></span></a></li><li class="social-icon-twitter"><a target="_blank" href="https://twitter.com/lnxsec" aria-label="twitter" title="Lnxsec"><span class="fa fa-twitter" aria-hidden="true"></span></a></li><li class="social-icon-linkedin"><a target="_blank" href="https://www.linkedin.com/company/guardiandigital" aria-label="LinkedIn" title="Guardiandigital"><span class="fa fa-linkedin" aria-hidden="true"></span></a></li><li class="social-icon-custom"><a target="_blank" href="/about/linuxsecurity-rss-feeds" title="Linuxsecurity Rss Feeds"><span class="fa fa-rss" aria-hidden="true"></span></a></li></ul></div></div></div>
</div>
</div>
</section>
<header id="sp-header">
<div class="container">
<div class="container-inner">
<div class="row">
<div id="sp-menu" class="col-lg-9 "><div class="sp-column  d-flex align-items-center justify-content-end"><nav class="sp-megamenu-wrapper" role="navigation"><ul class="sp-megamenu-parent menu-animation-fade-up d-none d-lg-block"><li class="sp-menu-item sp-has-child"><a href="/news" title="News">News</a><div class="sp-dropdown sp-dropdown-main sp-dropdown-mega sp-menu-right" style="width: 600px;"><div class="sp-dropdown-inner"><div class="row"><div class="col-sm-4"><ul class="sp-mega-group"><li class="item-581 menu_item item-header"><a href="/news/cloud-security" title="Cloud Security">Cloud Security</a></li><li class="item-596 menu_item item-header"><a href="/news/cryptography" title="Cryptography">Cryptography</a></li><li class="item-679 menu_item item-header"><a href="/news/desktop-security" title="Desktop Security">Desktop Security</a></li><li class="item-595 menu_item item-header"><a href="/news/firewall" title="Firewall">Firewall</a></li><li class="item-591 menu_item item-header"><a href="/news/government" title="Government">Government</a></li></ul></div><div class="col-sm-4"><ul class="sp-mega-group"><li class="item-589 menu_item item-header"><a href="/news/hackscracks" title="Hacks/Cracks">Hacks/Cracks</a></li><li class="item-680 menu_item item-header"><a href="/news/iot-security" title="IoT Security">IoT Security</a></li><li class="item-681 menu_item item-header"><a href="/news/network-security" title="Network Security">Network Security</a></li><li class="item-682 menu_item item-header"><a href="/news/organizations-events" title="Organizations/Events">Organizations/Events</a></li><li class="item-590 menu_item item-header"><a href="/news/privacy" title="Privacy">Privacy</a></li></ul></div><div class="col-sm-4"><ul class="sp-mega-group"><li class="item-592 menu_item item-header"><a href="/news/security-projects" title="Security Projects">Security Projects</a></li><li class="item-683 menu_item item-header"><a href="/news/security-trends" title="Security Trends">Security Trends</a></li><li class="item-684 menu_item item-header"><a href="/news/security-vulnerabilities" title="Security Vulnerabilities">Security Vulnerabilities</a></li><li class="item-594 menu_item item-header"><a href="/news/server-security" title="Server Security">Server Security</a></li><li class="item-593 menu_item item-header"><a href="/news/vendors-products" title="Vendors/Products">Vendors/Products</a></li></ul></div></div></div></div></li><li class="sp-menu-item sp-has-child  advisories-menu"><a href="/advisories" title="Advisories">Advisories</a><div class="sp-dropdown sp-dropdown-main sp-dropdown-mega sp-menu-right" style="width: 600px;"><div class="sp-dropdown-inner"><div class="row"><div class="col-sm-6"><ul class="sp-mega-group"><li class="item-575 menu_item item-header"><a href="/advisories/archlinux" title=" Archlinux"><img src="/images/nav/nav_archlinux.webp" alt="Nav Archlinux" width="50" height="50" /><span class="image-title">ArchLinux</span> </a></li><li class="item-576 menu_item item-header"><a href="/advisories/centos" title=" Centos"><img src="/images/nav/nav_centos.webp" alt="Nav Centos" width="50" height="50" /><span class="image-title">CentOS</span> </a></li><li class="item-578 menu_item item-header"><a href="/advisories/debian" title=" Debian"><img src="/images/nav/nav_debian.webp" alt="Nav Debian" width="50" height="50" /><span class="image-title">Debian</span> </a></li><li class="item-577 menu_item item-header"><a href="/advisories/deblts" title=" Debian Lts"><img src="/images/nav/nav_debian_lts.webp" alt="Nav Debian Lts" width="50" height="50" /><span class="image-title">Debian LTS</span> </a></li><li class="item-579 menu_item item-header"><a href="/advisories/fedora" title=" Fedora"><img src="/images/nav/nav_fedora.webp" alt="Nav Fedora" width="50" height="50" /><span class="image-title">Fedora</span> </a></li><li class="item-580 menu_item item-header"><a href="/advisories/gentoo" title=" Gentoo"><img src="/images/nav/nav_gentoo.webp" alt="Nav Gentoo" width="50" height="50" /><span class="image-title">Gentoo</span> </a></li><li class="item-582 menu_item item-header"><a href="/advisories/mageia" title=" Mageia"><img src="/images/nav/nav_mageia.webp" alt="Nav Mageia" width="50" height="50" /><span class="image-title">Mageia</span> </a></li></ul></div><div class="col-sm-6"><ul class="sp-mega-group"><li class="item-975 menu_item item-header"><a href="/advisories/oracle" title="Oracle Large"><img src="/images/nav/oracle-large.webp" alt="Oracle Large" width="50" height="50" /><span class="image-title">Oracle</span> </a></li><li class="item-588 menu_item item-header"><a href="/advisories/opensuse" title=" Opensuse"><img src="/images/nav/nav_opensuse.webp" alt="Nav Opensuse" width="50" height="50" /><span class="image-title">openSUSE</span> </a></li><li class="item-583 menu_item item-header"><a href="/advisories/red-hat" title=" Redhat"><img src="/images/nav/nav_redhat.webp" alt="Nav Redhat" width="50" height="50" /><span class="image-title">Red Hat</span> </a></li><li class="item-584 menu_item item-header"><a href="/advisories/scilinux" title=" Scientific"><img src="/images/nav/nav_scientific.webp" alt="Nav Scientific" width="50" height="50" /><span class="image-title">Scientific Linux</span> </a></li><li class="item-585 menu_item item-header"><a href="/advisories/slackware" title=" Slackware"><img src="/images/nav/nav_slackware.webp" alt="Nav Slackware" width="50" height="50" /><span class="image-title">Slackware</span> </a></li><li class="item-586 menu_item item-header"><a href="/advisories/suse" title=" Suse"><img src="/images/nav/nav_suse.webp" alt="Nav Suse" width="50" height="50" /><span class="image-title">SuSE</span> </a></li><li class="item-587 menu_item item-header"><a href="/advisories/ubuntu" title=" Ubuntu"><img src="/images/nav/nav_ubuntu.webp" alt="Nav Ubuntu" width="50" height="50" /><span class="image-title">Ubuntu</span> </a></li></ul></div></div></div></div></li><li class="sp-menu-item sp-has-child"><a href="/howtos" title="HOWTOs">HOWTOs</a><div class="sp-dropdown sp-dropdown-main sp-dropdown-mega sp-menu-right" style="width: 600px;"><div class="sp-dropdown-inner"><div class="row"><div class="col-sm-6"><ul class="sp-mega-group"><li class="item-597 menu_item item-header"><a href="/howtos/harden-my-filesystem" title="Harden My Filesystem">Harden My Filesystem</a></li><li class="item-598 menu_item item-header"><a href="/howtos/learn-tips-and-tricks" title="Learn Tips and Tricks">Learn Tips and Tricks</a></li><li class="item-599 menu_item item-header"><a href="/howtos/secure-my-e-mail" title="Secure My E-mail">Secure My E-mail</a></li><li class="item-600 menu_item item-header"><a href="/howtos/secure-my-firewall" title="Secure My Firewall">Secure My Firewall</a></li></ul></div><div class="col-sm-6"><ul class="sp-mega-group"><li class="item-601 menu_item item-header"><a href="/howtos/secure-my-network" title="Secure My Network">Secure My Network</a></li><li class="item-602 menu_item item-header"><a href="/howtos/secure-my-webserver" title="Secure My Webserver">Secure My Webserver</a></li><li class="item-603 menu_item item-header"><a href="/howtos/strengthen-my-privacy" title="Strengthen My Privacy">Strengthen My Privacy</a></li></ul></div></div></div></div></li><li class="sp-menu-item sp-has-child current-item active"><a aria-current="page" href="/features" title="Features">Features</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 240px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item active"><a href="/features" title="Feature Articles">Feature Articles</a></li><li class="sp-menu-item"><a href="/features/must-read-articles" title="Must Read Articles">Must Read Articles</a></li><li class="sp-menu-item"></li></ul></div></div></li><li class="sp-menu-item"><a href="/newsletters" title="Newsletters">Newsletters</a></li><li class="sp-menu-item"><a href="/polls" title="Polls">Polls</a></li><li class="sp-menu-item sp-has-child"><a href="/about" title="About">About</a><div class="sp-dropdown sp-dropdown-main sp-menu-right" style="width: 240px;"><div class="sp-dropdown-inner"><ul class="sp-dropdown-items"><li class="sp-menu-item"><a href="/about/advertise" title="Advertise">Advertise</a></li><li class="sp-menu-item"><a href="/about/legal-notice" title="Legal Notice">Legal Notice</a></li><li class="sp-menu-item"><a href="/about/linuxsecurity-rss-feeds" title="RSS Feeds">RSS Feeds</a></li><li class="sp-menu-item"><a href="/contact-us" title="Contact Us">Contact Us</a></li></ul></div></div></li><li class="sp-menu-item"><a href="/security-dictionary" title="Security Dictionary">Security Dictionary</a></li></ul></nav></div></div><div id="sp-menu-right" class="col-lg-3 "><div class="sp-column  d-flex align-items-center"><div class="sp-module  acount"><div class="sp-module-content">
<div class="custom acount">
<p><i class="fa fa-bell" aria-hidden="true"></i> <a href="/advisories" title="Advisories This Week:">Advisories This Week:</a>&nbsp;325</p></div>
</div></div></div></div></div>
</div>
</div>
</header>
<section id="sp-blog-top">
<div class="row">
<div id="sp-blog-top" class="col-lg-12 "><div class="sp-column "><div class="sp-module "><div class="sp-module-content"><div class="mod-sppagebuilder  sp-page-builder" data-module_id="247">
<div class="page-content">
<div id="section-id-1574934640685" class="sppb-section business-listing-top-wrapper extend-container"><div class="sppb-container-inner"><div class="sppb-row"><div class="sppb-col-md-12" id="column-wrap-id-1574934640686"><div id="column-id-1574934640686" class="sppb-column"><div class="sppb-column-addons"><div id="sppb-addon-wrapper-1574427752436" class="sppb-addon-wrapper"><div id="sppb-addon-1574427752436" class="clearfix "><div class="sppb-addon sppb-addon-header sppb-text-center"><h1 class="sppb-addon-title">Feature Articles</h1></div><style type="text/css">#sppb-addon-wrapper-1574427752436 {
margin:0 0 0 0;}
#sppb-addon-1574427752436 {
	color: #ffffff;
	box-shadow: 0 0 0 0 #ffffff;
padding:0 0 0 0;}
#sppb-addon-1574427752436 {
}
#sppb-addon-1574427752436.sppb-element-loaded {
}
#sppb-addon-1574427752436 .sppb-addon-title {
font-size:60px;line-height:70px;font-weight: 700;}
@media (min-width: 768px) and (max-width: 991px) {#sppb-addon-1574427752436 {}}@media (max-width: 767px) {#sppb-addon-1574427752436 {}#sppb-addon-1574427752436 .sppb-addon-title {
font-size:40px;line-height:40px;line-height:50px;}
}#sppb-addon-1574427752436 .sppb-addon-title { font-family: "Frank Ruhl Libre"; }
</style><style type="text/css">#sppb-addon-1574427752436 h1.sppb-addon-title {margin: 0px 0px 10px 0px; text-transform: capitalize; padding: 0px 0px 0px 0px; }@media (min-width: 768px) and (max-width: 991px) {#sppb-addon-1574427752436 h1.sppb-addon-title {margin: 0px 0px 30px 0px; }}@media (max-width: 767px) {#sppb-addon-1574427752436 h1.sppb-addon-title {margin: 0px 0px 20px 0px; }}</style></div></div><div id="sppb-addon-wrapper-1618599957253" class="sppb-addon-wrapper"><div id="sppb-addon-1618599957253" class="clearfix "><div class="sppb-addon sppb-addon-text-block sppb-text-center "><div class="sppb-addon-content"><div class="category-desc">
<p>Need an in-depth introduction to a new security topic? Our features articles will bring up up-to-date on everything from buffer overflows to SE Linux policy development.</p>
</div></div></div><style type="text/css">#sppb-addon-wrapper-1618599957253 {
margin:0px 0px 15px 0px;}
#sppb-addon-1618599957253 {
	box-shadow: 0 0 0 0 #ffffff;
padding:0 20% 20px 20%;}
#sppb-addon-1618599957253 {
}
#sppb-addon-1618599957253.sppb-element-loaded {
}
@media (min-width: 768px) and (max-width: 991px) {#sppb-addon-1618599957253 {}}@media (max-width: 767px) {#sppb-addon-1618599957253 {}}</style><style type="text/css">#sppb-addon-1618599957253{ font-size: 20px; }@media (min-width: 768px) and (max-width: 991px) {}@media (max-width: 767px) {}</style></div></div></div></div></div><div class="sppb-col-md-9" id="column-wrap-id-1574934640700"><div id="column-id-1574934640700" class="sppb-column"><div class="sppb-column-addons"><div id="sppb-addon-wrapper-1575467171374" class="sppb-addon-wrapper"><div id="sppb-addon-1575467171374" class="clearfix "><div class="sppb-addon sppb-addon-articles-layout layout-liberica  "><div class="sppb-addon-content"><div class="sppb-row"><style>
body .sppb-addon-articles-layout.layout-bourbon .sppb-addon-article.g-ads::after {
    background-image: unset !important;
}
.sppb-addon-articles-layout.layout-bourbon .sppb-addon-article.g-ads {
    color: #000;
}
			</style><div class="leading-item  sppb-col-sm-12"><div bgimg="/images/articles/900x500/23.Tablet_Connections.webp" class="sppb-addon-article  customclass1features " style=""><div class="bg-img-wrapper" style="background-image: url(https://linuxsecurity.com/images/articles/900x500/23.Tablet_Connections-esm-h315.jpg);"></div>
<style>
				body .sppb-addon-articles-layout.layout-bourbon .sppb-addon-article.customclass1features {
					background-image: url(/images/articles/900x500/23.Tablet_Connections-esm-h465.jpg) !important;
					background-size: cover;
				}
				</style>
<div class="sppb-article-info-wrap "><h3><a href="/features/the-dangers-of-using-a-vpn-for-remote-work-zero-trust-to-replace-it" title="The Dangers of Using a VPN for Remote Work: Zero Trust to Replace It">The Dangers of Using a VPN for Remote Work: Zero Trust to Replace It</a></h3><div class="sppb-article-introtext">When it comes to the current state of our society now, we see now more than ever that employers, as well as employees, are embracing flexibility within the workspace with remote work. The norms and expectations surrounding remote working have shifted...</div><div class="sppb-article-meta"><span class="sppb-meta-date">Sep 07, 2022</span></div></div></div></div></div></div></div><style type="text/css">#sppb-addon-1575467171374 {
	box-shadow: 0 0 0 0 #ffffff;
}
#sppb-addon-1575467171374 {
}
#sppb-addon-1575467171374.sppb-element-loaded {
}
@media (min-width: 768px) and (max-width: 991px) {#sppb-addon-1575467171374 {}}@media (max-width: 767px) {#sppb-addon-1575467171374 {}#sppb-addon-wrapper-1575467171374 {margin-top: 0px;margin-right: 0px;margin-bottom: 0px;margin-left: 0px;}}</style><style type="text/css"></style></div></div><div id="sppb-addon-wrapper-1638299048499" class="sppb-addon-wrapper"><div id="sppb-addon-1638299048499" class="clearfix "><div class="sppb-addon sppb-addon-raw-html "><div class="sppb-addon-content"><div class="adloader" ad="features_ad_top"></div></div></div><style type="text/css">#sppb-addon-wrapper-1638299048499 {
margin:0px 0px 30px 0px;}
#sppb-addon-1638299048499 {
	box-shadow: 0 0 0 0 #ffffff;
}
#sppb-addon-1638299048499 {
}
#sppb-addon-1638299048499.sppb-element-loaded {
}
@media (min-width: 768px) and (max-width: 991px) {#sppb-addon-1638299048499 {}}@media (max-width: 767px) {#sppb-addon-1638299048499 {}}</style></div></div></div></div></div><div class="sppb-col-md-3" id="column-wrap-id-1574934640701"><div id="column-id-1574934640701" class="sppb-column"><div class="sppb-column-addons"><div id="sppb-addon-wrapper-1575467041907" class="sppb-addon-wrapper"><div id="sppb-addon-1575467041907" class="clearfix "><div class="sppb-addon sppb-addon-articles-layout layout-arabica  "><div class="sppb-addon-content"><div class="sppb-row"><style>
body .sppb-addon-articles-layout.layout-bourbon .sppb-addon-article.g-ads::after {
    background-image: unset !important;
}
.sppb-addon-articles-layout.layout-bourbon .sppb-addon-article.g-ads {
    color: #000;
}
			</style><div class="normal-item  sppb-col-sm-12"><div bgimg="/images/articles/900x500/2.Motherboard.webp" class="sppb-addon-article  customclass1features " style="">
<style>
				body .sppb-addon-articles-layout.layout-bourbon .sppb-addon-article.customclass1features {
					background-image: url(/images/articles/900x500/2.Motherboard-esm-h465.jpg) !important;
					background-size: cover;
				}
				</style>
<div class="sppb-article-info-wrap "><h3><a href="/features/all-you-need-to-know-about-linux-services-runlevels" title="All You Need to Know about Linux Services &amp; Runlevels"> All You Need to Know about Linux Services & Runlevels</a></h3><div class="sppb-article-info-intro-wrap d-flex align-items-center"><div><div class="sppb-article-introtext">While the Firewall may be configured to block the ports...</div><div class="sppb-article-meta"><span class="sppb-meta-date">Sep 05, 2022</span></div></div><a class="sppb-article-img-wrap" href="/features/all-you-need-to-know-about-linux-services-runlevels" title="2.Motherboard Esm H115"><img class="sppb-img-responsive" src="/images/articles/900x500/2.Motherboard-esm-h115.jpg" alt="2.Motherboard Esm H115" itemprop="thumbnailUrl"></a></div></div></div></div><div class="normal-item  sppb-col-sm-12"><div bgimg="/images/articles/900x500/20.Lock_AbstractDigital_Circular.webp" class="sppb-addon-article  customclass2features " style="">
<style>
				body .sppb-addon-articles-layout.layout-bourbon .sppb-addon-article.customclass2features {
					background-image: url(/images/articles/900x500/20.Lock_AbstractDigital_Circular-esm-h465.jpg) !important;
					background-size: cover;
				}
				</style>
<div class="sppb-article-info-wrap "><h3><a href="/features/blackhat-usa-2022-devils-are-in-the-file-descriptors" title="BlackHat USA 2022: Devils Are in the File Descriptors">BlackHat USA 2022: Devils Are in the File Descriptors</a></h3><div class="sppb-article-info-intro-wrap d-flex align-items-center"><div><div class="sppb-article-introtext">Learn about a File Descriptor vulnerability that was ex...</div><div class="sppb-article-meta"><span class="sppb-meta-date">Aug 31, 2022</span></div></div><a class="sppb-article-img-wrap" href="/features/blackhat-usa-2022-devils-are-in-the-file-descriptors" title="20.Lock AbstractDigital Circular Esm H115"><img class="sppb-img-responsive" src="/images/articles/900x500/20.Lock_AbstractDigital_Circular-esm-h115.jpg" alt="20.Lock AbstractDigital Circular Esm H115" itemprop="thumbnailUrl"></a></div></div></div></div></div></div></div><style type="text/css">#sppb-addon-wrapper-1575467041907 {
margin:0px 0px 30px 0px;}
#sppb-addon-1575467041907 {
	box-shadow: 0 0 0 0 #ffffff;
}
#sppb-addon-1575467041907 {
}
#sppb-addon-1575467041907.sppb-element-loaded {
}
@media (min-width: 768px) and (max-width: 991px) {#sppb-addon-1575467041907 {}#sppb-addon-wrapper-1575467041907 {margin-top: 0px;margin-right: 0px;margin-bottom: 20px;margin-left: 0px;}}@media (max-width: 767px) {#sppb-addon-1575467041907 {}#sppb-addon-wrapper-1575467041907 {margin-top: 0px;margin-right: 0px;margin-bottom: 10px;margin-left: 0px;}}</style><style type="text/css"></style></div></div></div></div></div></div></div></div><style type="text/css">.sp-page-builder .page-content #landing-page-heading{padding-top:0px;padding-right:0px;padding-bottom:0px;padding-left:0px;margin-top:0px;margin-right:0px;margin-bottom:0px;margin-left:0px;box-shadow:0 0 0 0 #ffffff;}#column-id-1621349883047{box-shadow:0 0 0 0 #fff;}.sp-page-builder .page-content #section-id-1621349883049{padding-top:50px;padding-right:0px;padding-bottom:0px;padding-left:0px;margin-top:0px;margin-right:0px;margin-bottom:0px;margin-left:0px;box-shadow:0 0 0 0 #ffffff;}#column-id-1621349883050{box-shadow:0 0 0 0 #fff;}.sp-page-builder .page-content #section-id-1574934640685{padding-top:90px;padding-right:0px;padding-bottom:50px;padding-left:0px;margin-top:0px;margin-right:0px;margin-bottom:0px;margin-left:0px;background-color:#1d1d1d;background-image:url(/images/2021/04/29/secure-webserver-bg.webp);background-repeat:no-repeat;background-size:cover;background-attachment:scroll;background-position:50% 50%;}@media (min-width:768px) and (max-width:991px) { .sp-page-builder .page-content #section-id-1574934640685{padding-top:40px;padding-right:0px;padding-bottom:10px;padding-left:0px;} }@media (max-width:767px) { .sp-page-builder .page-content #section-id-1574934640685{padding-top:20px;padding-right:0px;padding-bottom:0px;padding-left:0px;} }.sp-page-builder .page-content #section-id-1574934640685 > .sppb-row-overlay {mix-blend-mode:normal;}</style> </div>
</div>
</div></div></div></div></div>
</section>
<section id="sp-main-body">
<div class="container">
<div class="container-inner">
<div class="row">
<main id="sp-component" class="col-lg-8 ">
<div class="sp-column ">
<div id="system-message-container">
</div>
<div class="sp-module-content-top clearfix">
<div class="sp-module "><div class="sp-module-content"><div class="mod-sppagebuilder  sp-page-builder" data-module_id="360">
<div class="page-content">
<div id="landing-page-heading" class="sppb-section landing-page-heading container"><div class="sppb-container-inner"><div class="sppb-row"><div class="sppb-col-md-12" id="column-wrap-id-1621349883047"><div id="column-id-1621349883047" class="sppb-column"><div class="sppb-column-addons"><div id="section-id-1621349883049" class="sppb-section"><div class="sppb-container-inner"><div class="sppb-row"><div class="sppb-col-md-12" id="column-wrap-id-1621349883050"><div id="column-id-1621349883050" class="sppb-column"><div class="sppb-column-addons"><div id="sppb-addon-wrapper-1621349802156" class="sppb-addon-wrapper"><div id="sppb-addon-1621349802156" class="clearfix "><div class="sppb-addon sppb-addon-header heading-arrow sppb-text-center"><h2 class="sppb-addon-title">Discover LinuxSecurity Features</h2></div><style type="text/css">#sppb-addon-wrapper-1621349802156 {
margin:0px 0px 0px 0px;}
#sppb-addon-1621349802156 {
	box-shadow: 0 0 0 0 #ffffff;
}
#sppb-addon-1621349802156 {
}
#sppb-addon-1621349802156.sppb-element-loaded {
}
#sppb-addon-1621349802156 .sppb-addon-title {
font-size:32px;line-height:40px;}
@media (min-width: 768px) and (max-width: 991px) {#sppb-addon-1621349802156 {}}@media (max-width: 767px) {#sppb-addon-1621349802156 {}}</style><style type="text/css">#sppb-addon-1621349802156 h2.sppb-addon-title {margin: 0px 0px 30px 0px; text-transform: none; padding: 0px 0px 0px 0px; }</style></div></div></div></div></div></div></div></div><style type="text/css">.sp-page-builder .page-content #landing-page-heading{padding-top:0px;padding-right:0px;padding-bottom:0px;padding-left:0px;margin-top:0px;margin-right:0px;margin-bottom:0px;margin-left:0px;box-shadow:0 0 0 0 #ffffff;}#column-id-1621349883047{box-shadow:0 0 0 0 #fff;}.sp-page-builder .page-content #section-id-1621349883049{padding-top:50px;padding-right:0px;padding-bottom:0px;padding-left:0px;margin-top:0px;margin-right:0px;margin-bottom:0px;margin-left:0px;box-shadow:0 0 0 0 #ffffff;}#column-id-1621349883050{box-shadow:0 0 0 0 #fff;}</style></div></div></div></div></div></div><style type="text/css">.sp-page-builder .page-content #landing-page-heading{padding-top:0px;padding-right:0px;padding-bottom:0px;padding-left:0px;margin-top:0px;margin-right:0px;margin-bottom:0px;margin-left:0px;box-shadow:0 0 0 0 #ffffff;}#column-id-1621349883047{box-shadow:0 0 0 0 #fff;}.sp-page-builder .page-content #section-id-1621349883049{padding-top:50px;padding-right:0px;padding-bottom:0px;padding-left:0px;margin-top:0px;margin-right:0px;margin-bottom:0px;margin-left:0px;box-shadow:0 0 0 0 #ffffff;}#column-id-1621349883050{box-shadow:0 0 0 0 #fff;}</style> </div>
</div>
</div></div>
</div>
<script>
jQuery(window).load(function(){
jQuery('#kt').appendTo(jQuery('.article-details'));
});
</script>
<div class="article-details ">
<div class="newsberg-details-img-wrapper">
<div class="img-top-wrap">
<div class="article-header">
<h1>
Essential Guide to Securing Node.JS Applications </h1>
</div>
</div>
</div>
<div class="article-can-edit d-flex flex-wrap justify-content-between">
</div>
<div class="author-content-info">
<div class="article-author-information">
<div class="media">
<div class="mr-3">
<img title="Harikrishna Kundariya" class="img-circle img-responsive" src="/media/acfupload/ls-default.png" alt="Ls Default" width="162" height="216">
</div> 
<div class="media-body">
<h5 class="mt-0 author-info">
Harikrishna Kundariya 
</h5>
</div> 
</div> 
</div>
<div class="read-content-link">
<span class="reading-time" style="">
8 - 16 min read

</span> <span class="hits"><span class="fa fa-eye"></span>553</span>
<span class="created"><i class="sej-meta-icon fa fa-clock-o"></i>08/26/2022</span>
</div>
</div>
<div class="adloader" ad="skyscraper"></div>
<div class="articleBody">
<div class="article-full-image">
<img src="/images/articles/900x500/2.Motherboard.webp" alt="2.Motherboard" width="900" height="500">
</div>
<progress class="ert-progress" value="0"></progress>
<span id="ert-start"></span><p>Due to its ability to act as the backend server for web applications, Node.js is becoming a trendy platform these days. However, it becomes crucial to take into account Node.js security policies when it comes to the world of microservices.</p>
&nbsp;
<p>Open-source backend frameworks have long had security flaws, and every Node.js developer knows the dangers that hackers pose to apps and user data.&nbsp;&nbsp;</p>
<p>The article will concentrate on the risks and solutions developers may use to increase the security of their online applications while keeping Node.js security issues in mind.</p>
<h2>Why Is Node.js Popular in Back-End Development?</h2>
<p>JavaScript has strong frameworks and libraries and has been around for a while. Still, it has never had any backend platforms that could contend with other programming languages. Node.js can address this problem.&nbsp;&nbsp;<img src="/images/articles/features/nodejs.webp" width="337" height="238" alt="Nodejs" style="margin: 10px; float: right;" /></p>
<p>Some of the advantages of using Node.js are listed below.</p>
<ul>
<li aria-level="1"><strong>Easy to learn:</strong> JavaScript proficiency is prevalent among many developers. Node.js uses JavaScript. As a result, picking up Node.js is not difficult and can be learned in a few weeks.</li>
<li aria-level="1"><strong>Scalability:</strong> Scalable network applications are the focus of the design of Node.js.This is why it gained popularity among developers and big businesses so quickly.</li>
<li aria-level="1"><strong>Flexibility:</strong> Node.js gets big thumbs up for allowing developers to create adaptable programs that function flawlessly on any platform. Node.js helped alleviate the concern that apps wouldn't work on various operating systems.&nbsp;</li>
<li aria-level="1"><strong>Light and fast:</strong> Node.js uses a high-performance, open-source JavaScript and WebAssembly engine. In a single asynchronous thread, it responds to requests. This lessens both the CPU and memory load. Your app will become lighter as a result.</li>
</ul>
<p>The possibility that hackers will attempt to find vulnerabilities increases with the framework's popularity. As a result, Node.js security should always be taken care of.</p>
<h2>Potential Risks for Node.JS Applications</h2>
<p>Not all security concerns are serious, and here are the primary security considerations on Node.js.</p>
<h3>Code injection</h3>
<p>The primary duty of an application developer is to write secure code. However, you cannot ultimately ensure the security of your codebase while using open-source software.&nbsp;</p>
<p>Any <a href="https://guardiandigital.com/email-threat/malware" title="malware">malware</a> in which the hacker inserts code into the system and forces the application function to run is called a code injection attack. The attacker looks at the sloppy and uncertain data to learn more about your codebase.</p>
<p>A common code injection attack that most people run into while developing software is SQL injection. Here, the hackers use malicious SQL code to change the backend database to get sensitive data that is not usually visible.&nbsp;&nbsp;</p>
<h3>Cross-site request forgery attack</h3>
<p>You shouldn't ignore the frequent Node.js security vulnerability known as Cross-Site Request Forgery (CSRF). Using a CSRF attack, a web application against which a user has already been authenticated is forced to accept requests from authenticated users. It lets hackers access private information and risks web applications' security and integrity.</p>
<p>Hackers utilizing CSRF want to alter the application's state by tricking users into thinking they've received a message or <a href="https://guardiandigital.com/google-workspace-email-protection" title="email">email</a>. Attacks on admin-level users that use CSRF could put the security of the whole web application at risk.</p>
<h3>Cookies</h3>
<p>Since every user action on a web application results in cookies kept in the underlying infrastructure, cookies help websites or web apps identify a specific user. The most typical uses of cookies are in shopping carts on eCommerce websites.&nbsp;</p>
<p>Because of the cookies, the shopping cart will show you the items you previously selected on the website when you go to the checkout page.</p>
<p>However, the issue with Node.js development is when the developer chooses the standard cookie names rather than changes them to meet the needs. Since hackers know the default cookie name, they are likely to attack and quickly get access to user input.</p>
<h3>Brute-force attacks</h3>
<p>One of the most frequent threats or risks in any Node.js security checklist is brute force attacks. To gain access to sensitive data, hackers attempt to use random passwords generated at the login endpoints of web applications.&nbsp;</p>
<p>The goal of brute forcing is to try millions of different password combinations until they find the one that works for the online application. You must fortify your authentication system for Node.js applications to thwart brute-force attacks.&nbsp;</p>
<p>To deal with such unsafe scenarios, you can also restrict the number of login attempts from one IP address and use bcrypt.js to protect the passwords saved in the database.</p>
<h3>X-powered-By header</h3>
<p>Many programming languages, by default, use the non-standard HTTP response header known as X-Powered-By. This header identifies the technology used in app development.&nbsp;</p>
<p>It enables hackers to take advantage of numerous security flaws related to that specific technology. You can enable or disable this header using server configuration management approaches.&nbsp;&nbsp;</p>
<h3>Distributed Denial of Service</h3>
<p>A Distributed Denial of Service (DDoS) assault involves flooding a server, service, or network with excessive internet data. It includes malicious JavaScript code to interfere with the regular server, service, or network traffic.&nbsp;</p>
<p>Due to their ability to take advantage of the HTTP processing flaw, Node.js versions 4.0.0 and 4.1.1 have given birth to DDoS attacks.</p>
<p>Since they have the potential to destroy your servers, networks, or services, limiting these attacks is crucial to guarantee the smooth functioning of your Node.js apps.&nbsp;&nbsp;</p>
<h3>Cross-Site Scripting Attack</h3>
<p>Cross-site scripting attacks are critical risks to be aware of when developing Node.js web applications. Cross-site scripting (XSS) lets attackers change the JavaScript code in a web app using client-side scripting.&nbsp;&nbsp;</p>
<p>The end user's browsers cannot determine whether the codebase is trustworthy. Therefore, a hacker can use XSS to send them a malicious script.&nbsp;</p>
<p>As a result, they automatically execute it, allowing attackers to access any session tokens, cookies, or other private data. These scripts can also change any HTML page's content, making XSS extremely dangerous.</p>
<p>Let's break down Node.js's recommended practices to help you avoid these situations now that you're sufficiently aware of their risks.</p>
<h2>Best ways to boost Node.JS application security&nbsp;</h2>
<h3>Validation of user data</h3>
<p>The data coming from the user or another system entity must constantly be verified. The working system is endangered by poor validation, resulting in security exploits. Data validation can be carried out using a node module named validator. Let's explore Node.js's data validation capabilities.&nbsp;&nbsp;</p>
<pre class="language-js line-numbers"><code>
const validator = require('validator');

validator.isEmail(<span id="cloake50cdd1398379600a43a47a8853f53a5">This email address is being protected from spambots. You need JavaScript enabled to view it.</span><script type='text/javascript'>
				document.getElementById('cloake50cdd1398379600a43a47a8853f53a5').innerHTML = '';
				var prefix = '&#109;a' + 'i&#108;' + '&#116;o';
				var path = 'hr' + 'ef' + '=';
				var addye50cdd1398379600a43a47a8853f53a5 = '&#039;f&#111;&#111;' + '&#64;';
				addye50cdd1398379600a43a47a8853f53a5 = addye50cdd1398379600a43a47a8853f53a5 + 'b&#97;r' + '&#46;' + 'c&#111;m';
				var addy_texte50cdd1398379600a43a47a8853f53a5 = '&#039;f&#111;&#111;' + '&#64;' + 'b&#97;r' + '&#46;' + 'c&#111;m';document.getElementById('cloake50cdd1398379600a43a47a8853f53a5').innerHTML += '<a ' + path + '\'' + prefix + ':' + addye50cdd1398379600a43a47a8853f53a5 + '\'>'+addy_texte50cdd1398379600a43a47a8853f53a5+'<\/a>';
		</script>'); //=&gt; true

validator.isEmail('bar.com'); //=&gt; false
</code></pre>
<p>The data/schema validation can also be done using a module named joi.&nbsp;&nbsp;</p>
<pre class="language-js line-numbers"><code>
const joi = require('joi');

&nbsp;&nbsp;try {

&nbsp;&nbsp;&nbsp;&nbsp;const schema = joi.object().keys({

&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;name: joi.string().min(3).max(45).required(),

&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;email: joi.string().email().required(),

&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;password: joi.string().min(6).max(20).required()

&nbsp;&nbsp;&nbsp;&nbsp;});

&nbsp;&nbsp;&nbsp;&nbsp;const dataToValidate = {

&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;name: "Shahid",

&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;email: "abc.com",

&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;password: "123456",

&nbsp;&nbsp;&nbsp;&nbsp;}

&nbsp;&nbsp;&nbsp;&nbsp;const result = schema.validate(dataToValidate);

&nbsp;&nbsp;&nbsp;&nbsp;if (result.error) {

&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;throw result.error.details[0].message;

&nbsp;&nbsp;&nbsp;&nbsp;}&nbsp;&nbsp;&nbsp;&nbsp;

&nbsp;&nbsp;} catch (e) {

&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;console.log(e);

&nbsp;&nbsp;}
</code></pre>
<h3>Prevent SQL injection attacks</h3>
<p>Your database can be retrieved, added to, or modified by attackers who defeat authentication. SQL injections happen when you ask users for input, such as their id or username, and they insert a SQL statement in its place. This is a typical hacking tactic that could ruin your database.</p>
<p>See one example below.</p>
<pre class="language-js line-numbers"><code>
textuserID = getRequestString("userID");

textSQL = "SELECT * FROM Users WHERE userID = " + textuserID;
</code></pre>
<p>Let's examine some of the potential problems. The example retrieves a variable (textuserID) from user input. The user is chosen in the following line of code based on their ID.</p>
<h4>SQL injection 1=1</h4>
<p>The SQL statement appears as follows if your user provides something like 100 OR 1=1 for their userID:</p>
<pre class="language-mysql line-numbers"><code>
SELECT * FROM Users WHERE userID = 100 OR 1=1;
</code></pre>
<p>Since 1=1 is true, the statement above will return all rows from the Users table. This might be pretty risky if your table contains data like usernames and passwords.</p>
<h4>How to prevent SQL injection?</h4>
<ul>
<li aria-level="1">Parameterized statements: Regardless of the input, they enable your database to distinguish between data and code.</li>
<li aria-level="1">Input validations: Additional protection is provided via input validations. Writing your validation logic will allow you to compare input to a list of permitted possibilities.</li>
<li aria-level="1">Database with least privilege: Your app is protected from SQL injections if you use database accounts with the very minimum access. Avoid using database accounts with admin permissions in your Node.js application.</li>
<li aria-level="1">Sanitize input: You must make sure to remove any input that seems suspect. Checking fields like <a href="https://guardiandigital.com/solutions/cloud-email-security/engarde-cloud-email-security-dashboard" title="email addresses">email addresses</a>, and matching a regular expression might help you achieve that.</li>
</ul>
<h3>Data verification through typecasting</h3>
<p>Since JavaScript is dynamically typed, a value can be of any type. To ensure that only the appropriate value enters the database, you can use the typecasting technique to determine the data type. For instance, typecasting should ensure that a user ID can only be a number and can only accept numbers. As an illustration, consider the code we displayed below.</p>
<pre class="language-js line-numbers"><code>
var mysql = require('mysql');

var connection = mysql.createConnection({

&nbsp;&nbsp;host &nbsp; &nbsp; : 'localhost',

&nbsp;&nbsp;user &nbsp; &nbsp; : 'me',

&nbsp;&nbsp;password : 'secret',

&nbsp;&nbsp;database : 'my_db'

});

connection.connect();

connection.query(

&nbsp;&nbsp;&nbsp;&nbsp;'UPDATE users SET ?? = ? WHERE ?? = ?',

&nbsp;&nbsp;&nbsp;&nbsp;['first_name',req.body.first_name, ,'id',Number(req.body.ID)],

&nbsp;&nbsp;&nbsp;&nbsp;function(err, result) {

&nbsp;&nbsp;&nbsp;&nbsp;//...

});
</code></pre>
<p>In order to verify that ID is always a number, we used Number(req.body.ID).&nbsp;</p>
<h3>Authentication and authorization</h3>
<p>Passwords and other sensitive data should be maintained in systems securely to prevent misuse by malicious individuals. We will learn how to save and manage passwords in this part.&nbsp;&nbsp;</p>
<h4>Password hashing</h4>
<p>Hashing is a form of one-way encryption. Because it lacks a decryption key, it differs from encryption. Assume your password is Pa55word to see how it works. It will resemble dhkqhuhdhudhuh after being processed by a hashing method</p>
<p>You can sign in by entering your password (Pa55word), which is hashed and checked to see whether it matches dhkqhuhdhudhuh.</p>
<p>To protect passwords, the Node.js package bcryptjs takes the password and the salt, which says how many times the hashing method should run.</p>
<p>The hash and salt are generated using several function calls in the example below.</p>
<pre class="language-js line-numbers"><code>
bcrypt.genSalt(saltRounds, function(err, salt) {

&nbsp;&nbsp;&nbsp;&nbsp;bcrypt.hash(myPlaintextPassword, salt, function(err, hash) {

&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;// Store hashed password in database

&nbsp;&nbsp;&nbsp;&nbsp;});

});
</code></pre>
<h4>Storage</h4>
<p>You cannot keep a plain text copy of your passwords, whether you use a database or files to store them. You should create the hash and store it in the system.</p>
<p>In cases when a password is involved, we typically advise utilizing the varchar(255) data type. You can choose a field with an unlimited length. You can utilize the varchar(60) field using bcrypt because it creates fixed-size hashes of 60 characters.</p>
<h4>Encryption</h4>
<p>By using an encryption key, password encryption enables you to turn your passwords into an unreadable message. The recipient and you both know the mathematical value that serves as the encryption key.</p>
<p>The recipient converts the random text to a message that can be read using the encryption key. Encryption is a two-way function. Therefore, you must afterwards decrypt everything you encrypt.</p>
<h4>User authorization</h4>
<p>A system with appropriate user roles and permissions stops malicious users from acting without authorization. Each user is given the appropriate roles and rights to establish a proper authorization procedure, allowing them to perform only necessary actions. Using the well-known ACL module, you can create access control lists based on system permission in Node.js.</p>
<pre class="language-js line-numbers"><code>
const ACL = require('acl2');

const acl = new ACL(new ACL.memoryBackend());

// guest is allowed to view blogs

acl.allow('guest', 'blogs', 'view')

// check if the permission is granted

acl.isAllowed('joed', 'blogs', 'view', (err, res) =&gt; {

&nbsp;&nbsp;&nbsp;&nbsp;if(res){

&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;console.log("User joed is allowed to view blogs");

&nbsp;&nbsp;&nbsp;&nbsp;}

});
</code></pre>
<h3>Stop brute-force attacks</h3>
<p>In brute force attacks, the attackers always continue to attempt to create a random password. Attackers in this situation might think about generating millions of passwords until they come up with the ideal one.</p>
<p>Consider utilizing the bcrypt.js package, which will protect the password whenever it is saved in the database. Additionally, you can think about restricting the volume of queries from a single IP.</p>
<p>Execute the below code:</p>
<pre class="language-js line-numbers"><code>
npm install express-brute --save
</code></pre>
<p>Try this code:</p>
<pre class="language-js line-numbers"><code>
const ExpressBrute = require('express-brute');

const store = new ExpressBrute.MemoryStore();&nbsp;&nbsp;

const bruteforce = new ExpressBrute(store);

app.post('/auth',

&nbsp;&nbsp;&nbsp;&nbsp;bruteforce.prevent, // error 429 if we hit this route too often

&nbsp;&nbsp;&nbsp;&nbsp;function (req, res, next) {

&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;res.send('Success!');

&nbsp;&nbsp;&nbsp;&nbsp;}

);
</code></pre>
<h3>SSL security layer&nbsp;</h3>
<p>Browsers and search engines use digital certificates, known as SSL certificates, to verify the legitimacy of websites. SSL certificates are one of the most important things to consider when protecting your web apps. Anyone can mimic your website without an SSL certificate and steal vital user information.</p>
<p>We must take the actions listed below to generate the SSL Certificate:</p>
<ul>
<li aria-level="1">Establish a Private Key</li>
<li aria-level="1">Using the private key, generate a CSR (certificate signing request).</li>
<li aria-level="1">Create an SSL certificate using a CSR</li>
</ul>
<h3>Integrate session layers</h3>
<p>To manage sessions in Node.js, we can use express-session middleware. In the express server itself, the session is kept. MemoryStore, the standard server-side session storage, is not intended for use in a real-world setting. It does not grow beyond a single process, leaks memory frequently, and is designed for debugging and development.&nbsp;</p>
<p>We must establish a global map and add each session object to manage numerous sessions for multiple users. Global variables in Node.js consume a lot of memory and present severe security risks in applications that are intended for production environments.</p>
<p>Utilizing an external session store will help you resolve this. Each session must be saved in the store so that it only ever belongs to one user. Redis is a widely used session store.</p>
<h3>CSRF attack prevention</h3>
<p>End users are compelled to do unnecessary activities on authenticated web apps by CSRF attacks. Due to the attacker's lack of access to the falsified request response, CSRF attacks target requests for changes in the application state.</p>
<p>&nbsp;State-changing requests can be forced using CSRF. The entire online application may be compromised for administrative users if CSRF occurs.</p>
<p>Anti-Forgery Tokens are necessary for Node.js to prevent CSRF. Tokens that are anti-CSRF are used to keep track of user requests, confirm their legitimacy, stop one-click attacks, and more.</p>
<h3>Request size reduction for DDoS</h3>
<p>The first thing to think about when dealing with DOS attack defense is restricting the actual payload that users can submit to your API/app/service. You can limit the body payload by using a body parser. You can make use of ExpressJS's built-in body parser.</p>
<pre class="language-js line-numbers"><code>
const express = require('express');

const app = express();app.use(express.json({ limit: '10kb' })); // Body limit is 10
</code></pre>
<h3>Prioritize MongoDB access</h3>
<p>Information is kept in MongoDB as JSON documents. It offers assistance for all fundamental data types. However, MongoDB saves them as BSON (binary-encoded JSON documents). Because it encrypts special characters, MongoDB defends itself against conventional injection attacks like BSON documents.&nbsp;&nbsp;</p>
<h3>Appropriate error handling</h3>
<p>When addressing errors, there are a few things to think about. First, don't reveal the information to the user, i.e., don't provide the client with the entire error object. It can have data you don't want to make public, such as pathways, a different library being used, or even secrets.&nbsp;</p>
<p>Second, encapsulate routes in a catch clause to prevent Node.js from crashing when a request causes an error. By doing this, attackers are prevented from discovering malicious requests that would crash your application and repeatedly submitting them, causing your program to crash.</p>
<h3>Securing cookies</h3>
<p>A cookie stores the details of every activity you take on the website.</p>
<p>The site's session cookie keeps track of the options you've made. The new page won't be able to identify your prior actions on other pages without session cookies.</p>
<p>Utilizing default cookie names puts your application at risk because attackers can easily detect and use them against you. Use express-session or another middleware cookie session module to fix the issue.</p>
<h3>Security headers implementation</h3>
<p>There are many security headers available in HTTP that can prevent well-known attacks. To enable all security headers with a single line of code while utilizing the Express framework, use the helmet module.</p>
<pre class="language-js line-numbers"><code>npm install helmet --save</code></pre>
<p>Try this code to use this.</p>
<pre class="language-js line-numbers"><code>
const express = require("express");&nbsp;

const helmet = require("helmet");&nbsp;&nbsp;

const app = express();&nbsp;

app.use(helmet());&nbsp;&nbsp;
</code></pre>
<h2>Conclusion</h2>
<p>Security flaws and threats have cost businesses thousands of dollars over the years. While data breaches can be costly, sensitive data leaks and stolen information are valuable. We might be unable to stop every attempt an attacker might make to destroy our apps. Still, we can control how much harm our carelessness causes.</p>
<p>This article discusses security throughout the entire software development lifecycle, not only the best practices that should be followed when creating applications. You can opt to hire a <a href="https://www.esparkinfo.com/nodejs-development-company.html" title="Node.js development company">Node.js development company</a> or consultants if you want to secure your Node.js application. Or need assistance creating data-intensive apps tailored to your company's requirements.</p> </div>
<div id="fd" data-kt-structure="63193c0ccfb53">
<div id="kt" class="kt-frontend
	light si-theme-foundry		" data-kt-compact-wrapper data-component="com_content" data-cid="307167" data-type="inline">
<div data-kt-wrapper data-component="com_content" data-cid="307167" data-url="L2ZlYXR1cmVzL2Vzc2VudGlhbC1ndWlkZS10by1zZWN1cmluZy1ub2RlLWpzLWFwcGxpY2F0aW9ucw==" data-live="0" data-live-interval="180">
<div data-kt-loader class="t-hidden">
<div class="space-y-md">
<div class="o-placeholder-loader">
<div class="flex w-full">
<div class="flex-shrink-0 h-[40px] w-[40px]">
<div class="o-placeholder-box h-[40px] w-[40px] rounded-full"></div>
</div>
<div class="ml-md space-y-xs flex flex-grow flex-col">
<div class="o-placeholder-box w-11/12"></div>
<div class="o-placeholder-box w-12/12"></div>
<div class="o-placeholder-box w-9/12"></div>
<div class="o-placeholder-box w-8/12"></div>
</div>
</div>
</div>
<div class="o-placeholder-loader">
<div class="flex w-full">
<div class="flex-shrink-0 h-[40px] w-[40px]">
<div class="o-placeholder-box h-[40px] w-[40px] rounded-full"></div>
</div>
<div class="ml-md space-y-xs flex flex-grow flex-col">
<div class="o-placeholder-box w-11/12"></div>
<div class="o-placeholder-box w-12/12"></div>
<div class="o-placeholder-box w-9/12"></div>
<div class="o-placeholder-box w-8/12"></div>
</div>
</div>
</div>
<div class="o-placeholder-loader">
<div class="flex w-full">
<div class="flex-shrink-0 h-[40px] w-[40px]">
<div class="o-placeholder-box h-[40px] w-[40px] rounded-full"></div>
</div>
<div class="ml-md space-y-xs flex flex-grow flex-col">
<div class="o-placeholder-box w-11/12"></div>
<div class="o-placeholder-box w-12/12"></div>
<div class="o-placeholder-box w-9/12"></div>
<div class="o-placeholder-box w-8/12"></div>
</div>
</div>
</div>
<div class="o-placeholder-loader">
<div class="flex w-full">
<div class="flex-shrink-0 h-[40px] w-[40px]">
<div class="o-placeholder-box h-[40px] w-[40px] rounded-full"></div>
</div>
<div class="ml-md space-y-xs flex flex-grow flex-col">
<div class="o-placeholder-box w-11/12"></div>
<div class="o-placeholder-box w-12/12"></div>
<div class="o-placeholder-box w-9/12"></div>
<div class="o-placeholder-box w-8/12"></div>
</div>
</div>
</div>
<div class="o-placeholder-loader">
<div class="flex w-full">
<div class="flex-shrink-0 h-[40px] w-[40px]">
<div class="o-placeholder-box h-[40px] w-[40px] rounded-full"></div>
</div>
<div class="ml-md space-y-xs flex flex-grow flex-col">
<div class="o-placeholder-box w-11/12"></div>
<div class="o-placeholder-box w-12/12"></div>
<div class="o-placeholder-box w-9/12"></div>
<div class="o-placeholder-box w-8/12"></div>
 </div>
</div>
</div>
<div class="o-placeholder-loader">
<div class="flex w-full">
<div class="flex-shrink-0 h-[40px] w-[40px]">
<div class="o-placeholder-box h-[40px] w-[40px] rounded-full"></div>
</div>
<div class="ml-md space-y-xs flex flex-grow flex-col">
<div class="o-placeholder-box w-11/12"></div>
<div class="o-placeholder-box w-12/12"></div>
<div class="o-placeholder-box w-9/12"></div>
<div class="o-placeholder-box w-8/12"></div>
</div>
</div>
</div>
<div class="o-placeholder-loader">
<div class="flex w-full">
<div class="flex-shrink-0 h-[40px] w-[40px]">
<div class="o-placeholder-box h-[40px] w-[40px] rounded-full"></div>
</div>
<div class="ml-md space-y-xs flex flex-grow flex-col">
<div class="o-placeholder-box w-11/12"></div>
<div class="o-placeholder-box w-12/12"></div>
<div class="o-placeholder-box w-9/12"></div>
<div class="o-placeholder-box w-8/12"></div>
</div>
</div>
</div>
<div class="o-placeholder-loader">
<div class="flex w-full">
<div class="flex-shrink-0 h-[40px] w-[40px]">
<div class="o-placeholder-box h-[40px] w-[40px] rounded-full"></div>
</div>
<div class="ml-md space-y-xs flex flex-grow flex-col">
<div class="o-placeholder-box w-11/12"></div>
<div class="o-placeholder-box w-12/12"></div>
<div class="o-placeholder-box w-9/12"></div>
<div class="o-placeholder-box w-8/12"></div>
</div>
</div>
</div>
<div class="o-placeholder-loader">
<div class="flex w-full">
<div class="flex-shrink-0 h-[40px] w-[40px]">
<div class="o-placeholder-box h-[40px] w-[40px] rounded-full"></div>
</div>
<div class="ml-md space-y-xs flex flex-grow flex-col">
<div class="o-placeholder-box w-11/12"></div>
<div class="o-placeholder-box w-12/12"></div>
<div class="o-placeholder-box w-9/12"></div>
<div class="o-placeholder-box w-8/12"></div>
</div>
</div>
</div>
<div class="o-placeholder-loader">
<div class="flex w-full">
<div class="flex-shrink-0 h-[40px] w-[40px]">
<div class="o-placeholder-box h-[40px] w-[40px] rounded-full"></div>
</div>
<div class="ml-md space-y-xs flex flex-grow flex-col">
<div class="o-placeholder-box w-11/12"></div>
<div class="o-placeholder-box w-12/12"></div>
<div class="o-placeholder-box w-9/12"></div>
<div class="o-placeholder-box w-8/12"></div>
</div>
</div>
</div>
</div> </div>
<div class="space-y-md" data-kt-container-content></div>
</div>
</div>


<div class="t-hidden" data-fd-tooltip-wrapper>
<div id="fd" data-fd-tooltip-block data-appearance="light">
<div class="light si-theme-foundry">
<div class="o-tooltip" data-fd-tooltip-message></div>
</div>
</div>
</div></div><script type="text/javascript">


Komento.ready(function($){
	if (!Komento.editorInitialized) {
		Komento.theme = 'light'
		Komento.bbcode = false;

		
		Komento.editorInitialized = true;
	}
});

Komento.require()
.script('site/structure/structure')
.done(function($) {

	var options = {
		"cid": "307167",
		"component": "com_content",
		"type": "inline",
		"commentOptions": JSON.stringify({"trigger":"onContentAfterDisplay","context":"com_content.article","params":{"article_layout":"_:default","show_title":1,"link_titles":1,"show_intro":1,"info_block_position":0,"info_block_show_title":1,"show_category":0,"link_category":1,"show_parent_category":0,"link_parent_category":0,"show_associations":0,"flags":1,"show_author":1,"link_author":0,"show_create_date":0,"show_modify_date":0,"show_publish_date":1,"show_item_navigation":1,"show_vote":0,"show_readmore":1,"show_readmore_title":1,"readmore_limit":100,"show_tags":1,"show_icons":1,"show_print_icon":0,"show_email_icon":0,"show_hits":1,"record_hits":1,"show_noauth":0,"urls_position":0,"captcha":"","show_publishing_options":1,"show_article_options":1,"save_history":1,"history_limit":10,"show_urls_images_frontend":0,"show_urls_images_backend":1,"targeta":0,"targetb":0,"targetc":0,"float_intro":"left","float_fulltext":"left","category_layout":"_:blog","show_category_heading_title_text":1,"show_category_title":0,"show_description":0,"show_description_image":0,"maxLevel":0,"show_empty_categories":0,"show_no_articles":0,"show_subcat_desc":0,"show_cat_num_articles":0,"show_cat_tags":1,"show_base_description":1,"maxLevelcat":-1,"show_empty_categories_cat":0,"show_subcat_desc_cat":1,"show_cat_num_articles_cat":1,"num_leading_articles":0,"num_intro_articles":16,"num_columns":1,"num_links":0,"multi_column_order":1,"show_subcategory_content":-1,"show_pagination_limit":1,"filter_field":"hide","show_headings":1,"list_show_date":0,"date_format":"","list_show_hits":0,"list_show_author":0,"orderby_pri":"none","orderby_sec":"rdate","order_date":"published","show_pagination":1,"show_pagination_results":0,"show_featured":"show","show_feed_link":1,"feed_summary":0,"feed_show_readmore":0,"sef_advanced":1,"sef_ids":1,"custom_fields_enable":1,"show_page_heading":0,"layout_type":"blog","menu_text":1,"menu_show":1,"page_title":"Our Feature Articles Provide Information & Insights from LinuxSecurity Experts","secure":0,"helixultimatemenulayout":"{\"width\":600,\"menualign\":\"right\",\"megamenu\":0,\"showtitle\":1,\"faicon\":\"\",\"customclass\":\"\",\"dropdown\":\"right\",\"badge\":\"\",\"badge_position\":\"\",\"badge_bg_color\":\"\",\"badge_text_color\":\"\",\"layout\":[]}","helixultimate_enable_page_title":0,"helixultimate_page_title_heading":"h2","page_description":"LinuxSecurity.com is the community's central source for information on Linux and open source security. We follow the open source trends as they affect the community. We produce content that appeals to administrators, developers, home users, and security professionals.","page_rights":null,"robots":null,"helix_ultimate_image":"images\/articles\/900x500\/2.Motherboard.jpg","helix_ultimate_article_format":"standard","access-view":true},"page":null,"enable":false,"disable":false,"lock":false,"parentid":0,"threaded":1,"loadreplies":true,"showRepliesCount":true,"sticked":0,"sort":"latest","limit":10}),
		"initialLoad": true,
		"returnUrl": "aHR0cHM6Ly9saW51eHNlY3VyaXR5LmNvbS9mZWF0dXJlcy9lc3NlbnRpYWwtZ3VpZGUtdG8tc2VjdXJpbmctbm9kZS1qcy1hcHBsaWNhdGlvbnMjY29tbWVudGZvcm0="
	};

	$('[data-kt-structure="63193c0ccfb53"]').implement(Komento.Controller.Structure, options);
});


</script>
</div> 
<ul class="pager pagenav">
<li class="previous">
<a class="hasTooltip" title="Password Guessing as an Attack Vector" aria-label="Previous article: Password Guessing as an Attack Vector" href="/features/password-guessing-as-an-attack-vector" rel="prev">
<span class="icon-chevron-left" aria-hidden="true"></span> <span aria-hidden="true">Prev</span> </a>
</li>
<li class="next">
<a class="hasTooltip" title="How RavenDB Has Earned the Trust of Hundreds of Companies" aria-label="Next article: How RavenDB Has Earned the Trust of Hundreds of Companies" href="/features/how-ravendb-has-earned-the-trust-of-hundreds-of-companies" rel="next">
<span aria-hidden="true">Next</span> <span class="icon-chevron-right" aria-hidden="true"></span> </a>
</li>
</ul>
</div>
<script type="text/javascript">
	jQuery(document).ready(function($){
		//if($('.newsletter-article-form-wrapper .eb-close').length>0){
	        //$('.newsletter-article-form-wrapper .eb-close').click(function(){
	        $(document).on("click", '.newsletter-article-form-wrapper .eb-close', function(){
	        	$.ajax({
				    type: 'POST',
				    url: '/includes/ajax-call.php',
				    data: {action: 'hide-newsletter-form'},
				    statusCode: {
	    				200: function() {
							$('.newsletter-article-form-wrapper').remove();
	    				}
	    			}
				});
	        });
	    //}
	    $(window).load(function() {
			$.ajax({
			    type: 'POST',
			    url: '/includes/ajax-call.php',
			    data: {action: 'load-newsletter-module'},
			    dataType: "json",
			    success: function(response) {
			    	//console.log(response);
			    	if(response.status==true){
									    		$('body.layout-blog .article-details .articleBody p:first').after(response.response);
						console.log('Done');
			    	}else{
			    		console.log(response.message);
			    	}
			    }
			});
		});
    });
</script>
<script>

  
  
  
  $(function(){
	  $('.view-article .articleBody p:nth(17 )').after($("#hidden_mod").html());
  })


</script>
<div id="hidden_mod" style="display:none;">
<div class="moduletable">
<div class="authors-posts-wrap1 inside-articles">
<h3 class="title-related">Related Articles</h3>
<div class="sppb-addon sppb-addon-articles-layout layout-arabica">
<div class="sppb-addon-content">
<div class="sppb-row">
<div class="sppb-col-sm-6 sppb-col-md-4">
<div bgimg1="images/articles/900x500/8.Locks_HexConnections_CodeGlobe-esm-w300.jpg" class="sppb-addon-article inside-articles1 " style="">
<div class="bg-img-wrapper article-bg-ls" style="background-image: url('/images/articles/900x500/8.Locks_HexConnections_CodeGlobe-esm-w300.jpg ');"></div>
<div class="sppb-article-info-wrap inside-article-info ">
<h3>
<a href="/features/complete-guide-to-vulnerability-basics" title="Complete Guide to Vulnerability Basics">
Complete Guide to Vulnerability Basics </a>
</h3>
<div class="sppb-article-meta"><span class="sppb-meta-date"></span></div>
</div>

</div>
</div>
<div class="sppb-col-sm-6 sppb-col-md-4">
<div bgimg1="images/articles/900x500/10.FingerPrint_Locks-esm-w300.jpg" class="sppb-addon-article inside-articles1 " style="">
<div class="bg-img-wrapper article-bg-ls" style="background-image: url('/images/articles/900x500/10.FingerPrint_Locks-esm-w300.jpg ');"></div>
<div class="sppb-article-info-wrap inside-article-info ">
<h3>
<a href="/features/guide-to-web-application-penetration-testing" title="Guide to Web Application Penetration Testing">
Guide to Web Application Penetration Testing </a>
</h3>
<div class="sppb-article-meta"><span class="sppb-meta-date"></span></div>
</div>

</div>
</div>
<div class="sppb-col-sm-6 sppb-col-md-4">
<div bgimg1="images/articles/900x500/33.EmailsTraveling-esm-w300.jpg" class="sppb-addon-article inside-articles1 " style="">
<div class="bg-img-wrapper article-bg-ls" style="background-image: url('/images/articles/900x500/33.EmailsTraveling-esm-w300.jpg ');"></div>
<div class="sppb-article-info-wrap inside-article-info ">
<h3>
<a href="/features/email-security-faqs-answered-by-guardian-digital" title="Email Security FAQs Answered by Guardian Digital">
 Email Security FAQs Answered by Guardian Digital </a>
</h3>
<div class="sppb-article-meta"><span class="sppb-meta-date"></span></div>
</div>

</div>
</div>
</ul>
</div>
</div>
</div>
</div>
<style>
 
.inside-articles .title-related:after {
    content: "";
    width: 55px;
    height: 2px;
    transition: 0.3s;
    margin-left: 15px;
    margin-top: 10px;
    border-radius: 1px;
    background-color: #1d55c1;
}

 .inside-articles .title-related  {
font-size: 27px;
    line-height: 1.41;
    color: #231f20;
    padding: 30px 20px 0px 0px;
    font-size: 27px;
    line-height: 38px;
    position: relative;
    display: flex;
    align-items: center;
    color: #231f20;
	}
	
	
 @media(min-width:768px){
.inside-articles .sppb-col-md-4 {
    flex: 0 0 30.333333%;
    max-width: 30.333333%;
 }}
  .article-bg-ls {background-size: cover;
    background-repeat: no-repeat;
    background-position: center;
    position: absolute;
    top: 0;
    left: 0;
    right: 0;
    bottom: 0;}

.inside-article-info {    padding: 0px;
  margin: 0px;
    position: relative;
    z-index: 10;}

.inside-article-info :hover {
    padding: 0px;
}
.inside-article-info h3 {
    overflow: visible!important;
    text-overflow: ellipsis!important;
    display: -webkit-box!important;
    line-height: 1.41 !important;
    max-height: 100px !important;
    -webkit-line-clamp: initial!important;
    line-clamp: initial !important;
    -webkit-box-orient: vertical!important;
    font-size: 18px;
    font-weight: 500;
}

.inside-article-info  h3 a {   color: #fff;}

.inside-articles1{    position: relative;
    margin-bottom: 35px;
    min-height: 250px;
    min-width: 252px;
    padding: 25px;
    overflow: hidden;
    border-radius: 6px;
    color: #fff;
    position: relative;
    display: inline-block;
    z-index: 2;
    display: flex;
    align-items: flex-end;
    padding: 0px;
  }

  .article-bg-ls:before {
    background: linear-gradient(to bottom,rgb(12 11 11 / 5%) 0%,rgb(0 0 0 / 100%) 100%);
 position: absolute;
    content: "";
    height: 100%;
    width: 100%;
    top: 0;
    left: 0;
    z-index: 9;
  }

  .inside-articles .sppb-article-info-wrap.inside-article-info{
 padding: 20px 20px 20px 20px;
 min-width: 250px;
  }
  .sppb-article-info-wrap.inside-article-info:hover {
    background: #152f68b5;
}

.insde-articles h3 {
    line-height: 120%;
    max-width: 100%;
    font-size: 16px;
    font-weight: 500;
    text-overflow: initial!important;
    -webkit-box-orient: initial!important;
}

 </style> </div>
<div>
</div>
</main>
<aside id="sp-right" class="col-lg-4 "><div class="sp-column "><div class="sp-module "><div class="sp-module-content"><div class="mod-sppagebuilder  sp-page-builder" data-module_id="473">
<div class="page-content">
<div id="section-id-1616687675678" class="sppb-section sppb-section-content-center"><div class="sppb-container-inner"><div class="sppb-row sppb-align-center"><div class="sppb-col-md-12" id="column-wrap-id-1616687675675"><div id="column-id-1616687675675" class="sppb-column"><div class="sppb-column-addons"><div id="sppb-addon-wrapper-1638292627105" class="sppb-addon-wrapper"><div id="sppb-addon-1638292627105" class="clearfix "><div class="sppb-addon sppb-addon-raw-html "><div class="sppb-addon-content"><div class="adloader" ad="large_square"></div></div></div><style type="text/css">#sppb-addon-wrapper-1638292627105 {
margin:20px 0px 30px 0px;}
#sppb-addon-1638292627105 {
	box-shadow: 0 0 0 0 #ffffff;
}
#sppb-addon-1638292627105 {
}
#sppb-addon-1638292627105.sppb-element-loaded {
}
@media (min-width: 768px) and (max-width: 991px) {#sppb-addon-1638292627105 {}}@media (max-width: 767px) {#sppb-addon-1638292627105 {}#sppb-addon-wrapper-1638292627105 {margin-bottom: 10px;}}#sppb-addon-1638292627105 .sa_mod_366.modsa img{margin:0px auto;}</style></div></div><div id="section-id-1619717457558" class="sppb-section newsberg-card-section"><div class="sppb-container-inner"><div class="sppb-row"><div class="sppb-col-md-12" id="column-wrap-id-1619717457559"><div id="column-id-1619717457559" class="sppb-column"><div class="sppb-column-addons"><div id="sppb-addon-wrapper-1619121265094" class="sppb-addon-wrapper"><div id="sppb-addon-1619121265094" class="clearfix "><div class="sppb-addon sppb-addon-header heading-arrow sppb-text-center"><h2 class="sppb-addon-title">LinuxSecurity Poll</h2></div><style type="text/css">#sppb-addon-wrapper-1619121265094 {
margin:0px 0px 0px 0px;}
#sppb-addon-1619121265094 {
	box-shadow: 0 0 0 0 #ffffff;
}
#sppb-addon-1619121265094 {
}
#sppb-addon-1619121265094.sppb-element-loaded {
}
#sppb-addon-1619121265094 .sppb-addon-title {
font-size:27px;line-height:38px;}
@media (min-width: 768px) and (max-width: 991px) {#sppb-addon-1619121265094 {}}@media (max-width: 767px) {#sppb-addon-1619121265094 {}}</style><style type="text/css">#sppb-addon-1619121265094 h2.sppb-addon-title {margin: 0px 0px 5px 0px; text-transform: none; padding: 0px 0px 0px 0px; }</style></div></div><div id="sppb-addon-wrapper-1616687675687" class="sppb-addon-wrapper"><div id="sppb-addon-1616687675687" class="clearfix "><div class="sppb-addon sppb-addon-module "><div class="sppb-addon-content"><div id="cj-wrapper" class="cjpoll-wrapper rp-1197861201">
<h4 class="page-title">Are you relying on a VPN alone to protect your privacy and security online while remote working?</h4>
<div class="panel panel-success poll-messages" style="display: none">
<div class="panel-heading">Message!</div>
<div class="panel-body">
<div class="poll-end-message"></div>
</div>
</div>
<form class="voting-form clearfix" name="voting-form" action="/main-polls/90-are-you-relying-on-a-vpn-alone-to-protect-your-privacy-and-security-online-while-remote-working">
<ul class="list-unstyled no-margin-left">
<li>
<label class="radio">
<input name="answer" type="radio" value="281" class="required" />
Yes </label>
</li>
<li>
<label class="radio">
<input name="answer" type="radio" value="282" class="required" />
No </label>
</li>
</ul>
</form>
<div id="cp-error-message-wrapper" class="cp-error-message-wrapper" style="display: none;">
<div class="alert alert-error"><i class="fa fa-warning"></i> <span id="cp-error-message" class="cp-error-message"></span></div>
</div>
<div style="display: none;">
<div id="error_no_selection" class="error_no_selection">No answer selected. Please try again.</div>
<div id="error_select_one_answer" class="error_select_one_answer">Please select either existing option or enter your own, however not both.</div>
<div id="msg_validation_min_answers_required">Please select minimum {0} answer(s).</div>
<div id="msg_validation_max_answers_required">Please select maximum {0} answer(s).</div>
<div id="url_vote" class="url_vote">/main-polls/90-are-you-relying-on-a-vpn-alone-to-protect-your-privacy-and-security-online-while-remote-working?task=poll.vote&amp;format=json</div>
<div id="poll_id" class="poll_id">90</div>
<div id="poll_secret" class="poll_secret"></div>
<div id="poll_type" class="poll_type">radio</div>
<div id="use_animations">0</div>
</div><div class="poll-results" style="display: none;">
<div class="">
<div class="answer-281">
<label>
<i class="fa fa-asterisk"></i> Yes (<span class="votecount">0</span> votes / <span class="votepct">0%</span>) </label>
<div class="progress progress-striped">
<div class="bar progress-bar" role="progressbar" aria-valuenow="0" aria-valuemin="0" aria-valuemax="100" style="width: 0%; background-color: #ff5b00">
<span class="sr-only"><span class='votecount'>0%</span> votes</span>
</div>
</div>
</div>
<div class="answer-282">
<label>
<i class="fa fa-asterisk"></i> No (<span class="votecount">1</span> vote / <span class="votepct">100%</span>) </label>
<div class="progress progress-striped">
<div class="bar progress-bar" role="progressbar" aria-valuenow="100" aria-valuemin="0" aria-valuemax="100" style="width: 100%; background-color: #4ac0f2">
<span class="sr-only"><span class='votecount'>100%</span> votes</span>
</div>
</div>
</div>
</div>
</div>
<div style="display: none;">
<span id="poll_answers" class="poll_answers">[{"id":"281","title":"Yes","votes":"0","type":"x","order":"1","pct":0,"resources":[]},{"id":"282","title":"No","votes":"1","type":"x","order":"2","pct":100,"resources":[]}]</span>
<span id="color_pallete" class="color_pallete">["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]</span>
<span id="rgb_color_pallete" class="rgb_color_pallete">["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]</span>
<span id="chart_height" class="chart_height">350</span>
</div>
<div class="poll-action-buttons text-inline">
<div class="alert alert-warning" style="display: none;"><i class="fa fa-exclamation-triangle"></i> <span class="error-message"></span></div>

<a href="/main-polls/90-are-you-relying-on-a-vpn-alone-to-protect-your-privacy-and-security-online-while-remote-working" class="nojs btn btn-default see-results" title="Result">
<i class="fa fa-bar-chart-o"></i> Result </a>
<a href="/main-polls/90-are-you-relying-on-a-vpn-alone-to-protect-your-privacy-and-security-online-while-remote-working" class="nojs btn btn-default " style="display: none" title="Vote Form">
<i class="fa fa-th-list"></i> Vote Form </a>

<a href="/main-polls/90-are-you-relying-on-a-vpn-alone-to-protect-your-privacy-and-security-online-while-remote-working" class="nojs btn btn-primary btn-vote-new" title="Vote">
<i class="fa fa-hand-o-up"></i> Vote </a>
<script>
	jQuery(document).ready(function(){
		
		jQuery(".see-results").on("click", function(event){
					});
	jQuery(".btn-vote-new").on("click", function(event){
		event.preventDefault();
		var selected=jQuery('input[name=answer]:checked', '.voting-form').val();
		window.location.href=jQuery(this).attr('href')+'?selected='+selected;
		});
		

	});
	</script>
</div>
<div class="rp-footer margin-top-20">
</div>
<div style="display: none;">
<span id="legend_position" class="legend_position">bottom</span>
<span id="chart_height" class="chart_height">200</span>
</div>
</div></div></div><style type="text/css">#sppb-addon-wrapper-1616687675687 {
margin:0px 15px 0px 0px;}
#sppb-addon-1616687675687 {
	box-shadow: 0 0 0 0 #ffffff;
}
#sppb-addon-1616687675687 {
}
#sppb-addon-1616687675687.sppb-element-loaded {
}
@media (min-width: 768px) and (max-width: 991px) {#sppb-addon-1616687675687 {}}@media (max-width: 767px) {#sppb-addon-1616687675687 {}}</style></div></div></div></div></div></div></div></div><style type="text/css">.sp-page-builder .page-content #section-id-1616687675678{padding-top:20px;padding-right:0px;padding-bottom:10px;padding-left:0px;margin-top:0px;margin-right:0px;margin-bottom:0px;margin-left:0px;box-shadow:0 0 0 0 #ffffff;}#column-id-1616687675675{box-shadow:0 0 0 0 #fff;}.sp-page-builder .page-content #section-id-1619717457558{padding-top:20px;padding-right:20px;padding-bottom:20px;padding-left:20px;margin-top:0px;margin-right:0px;margin-bottom:0px;margin-left:0px;box-shadow:0 0 0 0 #ffffff;}#column-id-1619717457559{padding-right:15px;box-shadow:0 0 0 0 #fff;}#column-wrap-id-1619717457559{margin-left:15px;}</style><div id="sppb-addon-wrapper-1656083605371" class="sppb-addon-wrapper"><div id="sppb-addon-1656083605371" class="clearfix "><div class="sppb-addon sppb-addon-raw-html "><div class="sppb-addon-content"><div class="adloader" ad="large_square_gd"></div></div></div><style type="text/css">#sppb-addon-wrapper-1656083605371 {
margin:20px 0px 30px 0px;}
#sppb-addon-1656083605371 {
	box-shadow: 0 0 0 0 #ffffff;
}
#sppb-addon-1656083605371 {
}
#sppb-addon-1656083605371.sppb-element-loaded {
}
@media (min-width: 768px) and (max-width: 991px) {#sppb-addon-1656083605371 {}}@media (max-width: 767px) {#sppb-addon-1656083605371 {}#sppb-addon-wrapper-1656083605371 {margin-bottom: 10px;}}#sppb-addon-1656083605371 .sa_mod_366.modsa img{margin:0px auto;}</style></div></div></div></div></div></div></div></div><style type="text/css">.sp-page-builder .page-content #section-id-1616687675678{padding-top:20px;padding-right:0px;padding-bottom:10px;padding-left:0px;margin-top:0px;margin-right:0px;margin-bottom:0px;margin-left:0px;box-shadow:0 0 0 0 #ffffff;}#column-id-1616687675675{box-shadow:0 0 0 0 #fff;}.sp-page-builder .page-content #section-id-1619717457558{padding-top:20px;padding-right:20px;padding-bottom:20px;padding-left:20px;margin-top:0px;margin-right:0px;margin-bottom:0px;margin-left:0px;box-shadow:0 0 0 0 #ffffff;}#column-id-1619717457559{padding-right:15px;box-shadow:0 0 0 0 #fff;}#column-wrap-id-1619717457559{margin-left:15px;}</style> </div>
</div>
</div></div><div class="sp-module   sidebar-related"><div class="sp-module-content">
<div class="authors-posts-wrapq">
<h3 class="title-related">Related Articles</h3>
<div class="sppb-addon sppb-addon-articles-layout layout-arabica">
<div class="sppb-addon-content">
<div class="sppb-row">
<div class="normal-item  sppb-col-sm-12 sppb-col-md-12">
<div bgimg1="images/articles/900x500/20.Lock_AbstractDigital_Circular-esm-w300.jpg" class="sppb-addon-article  customclass1features " style="">
<div class="sppb-article-info-wrap ">
<h3>
<a href="/features/blackhat-usa-2022-devils-are-in-the-file-descriptors" title="BlackHat USA 2022: Devils Are in the File Descriptors">
BlackHat USA 2022: Devils Are in the File Descriptors </a>
</h3>
<div class="sppb-article-meta"><span class="sppb-meta-date">Aug 31, 2022</span></div>
</div>
<a class="sppb-article-img-wrap" href="/features/blackhat-usa-2022-devils-are-in-the-file-descriptors" title="BlackHat USA 2022: Devils Are in the File Descriptors">
<img class="sppb-img-responsive" src="/images/articles/900x500/20.Lock_AbstractDigital_Circular-esm-w300.jpg" alt="20.Lock AbstractDigital Circular Esm W300">
</a>

</div>
</div>
<div class="normal-item  sppb-col-sm-12 sppb-col-md-12">
<div bgimg1="images/articles/900x500/18.WifiCutout_Landscape-esm-w300.jpg" class="sppb-addon-article  customclass1features " style="">
<div class="sppb-article-info-wrap ">
<h3>
<a href="/features/benefits-drawbacks-of-using-a-vpn-on-linux" title="Benefits &amp; Drawbacks of Using a VPN on Linux">
Benefits & Drawbacks of Using a VPN on Linux </a>
</h3>
<div class="sppb-article-meta"><span class="sppb-meta-date">Aug 8, 2022</span></div>
</div>
<a class="sppb-article-img-wrap" href="/features/benefits-drawbacks-of-using-a-vpn-on-linux" title="Benefits & Drawbacks of Using a VPN on Linux">
<img class="sppb-img-responsive" src="/images/articles/900x500/18.WifiCutout_Landscape-esm-w300.jpg" alt="18.WifiCutout Landscape Esm W300">
</a>

</div>
</div>
<div class="normal-item  sppb-col-sm-12 sppb-col-md-12">
<div bgimg1="images/articles/900x500/4.Lock_AbstractDigital-esm-w300.jpg" class="sppb-addon-article  customclass1features " style="">
<div class="sppb-article-info-wrap ">
<h3>
<a href="/features/how-a-waf-could-improve-the-security-of-your-linux-web-applications" title="How a WAF Could Improve the Security of Your Linux Web Applications">
How a WAF Could Improve the Security of Your Linux Web Applications </a>
</h3>
<div class="sppb-article-meta"><span class="sppb-meta-date">Aug 3, 2022</span></div>
</div>
<a class="sppb-article-img-wrap" href="/features/how-a-waf-could-improve-the-security-of-your-linux-web-applications" title="How a WAF Could Improve the Security of Your Linux Web Applications">
<img class="sppb-img-responsive" src="/images/articles/900x500/4.Lock_AbstractDigital-esm-w300.jpg" alt="4.Lock AbstractDigital Esm W300">
</a>

</div>
</div>
</ul>
</div>
</div>
</div>
</div>
<style>

.sidebar-related .sppb-article-info-wrap h3 {overflow: visible!important;padding-bottom:10px;display: block!important; }
    .sidebar-related .title-related:after {
    content: "";
    width: 55px;
    height: 2px;
    transition: 0.3s;
    margin-left: 15px;
    margin-top: 10px;
    border-radius: 1px;
    background-color: #1d55c1;
}
    .sidebar-related .title-related {
    font-size: 27px;
    line-height: 1.41;
    color: #231f20;
    padding: 30px 20px 0px 20px;
    font-size: 27px;
    line-height: 38px;
    position: relative;
    display: flex;
    align-items: center;
    color: #231f20;
	}

.sidebar-related .sppb-article-meta {
    display: grid !important;
    justify-content: space-between;
    align-items: flex-start !important;
    margin: 10px 0 0;
    font-size: 12px;
}

    .sidebar-related img.sppb-img-responsive {
        border-radius: 6px;
        height: 115px;
        object-fit: cover;
        object-position: left;
    }

    .sidebar-related .article-info-wrap {
        order: 2;
        width: 60%;
    margin-left: 0;
    }

   .sidebar-related .sppb-addon-article {
    display: flex;
    padding: 0px 20px 15px 0!important;
    box-shadow: none!important;
}


body .sidebar-related .sppb-article-info-wrap {
    order: 2;
    width: 63%;
    margin-left: 0;
}
.sidebar-related .sppb-article-img-wrap, .sidebar-related .sppb-article-img-wrap img {
    flex: 0 0 33%!important;
}
.sidebar-related .normal-item {
    margin-bottom: 15px!important;
}
.sppb-addon-articles-layout:not(.layout-robusta) .sppb-addon-article .sppb-article-img-wrap > img {
    width: 120px;
  object-position: center;
}


</style></div></div><div class="sp-module "><div class="sp-module-content"> <div class="acym_module newsletter-subscribe-module" id="acym_module_formAcym96262">
<div class="acym_fulldiv" id="acym_fulldiv_formAcym96262">
<form enctype="multipart/form-data" id="formAcym96262" name="formAcym96262" method="POST" action="/component/acym/frontusers?tmpl=component" onsubmit="return submitAcymForm('subscribe','formAcym96262', 'acymSubmitSubForm')">
<div class="acym_module_form">
<div class="acym_introtext"><h3>Get the Latest News & Insights</h3>
<p>Sign up to get the latest security news affecting Linux and open source delivered straight to your inbox</p></div>
<table class="acym_form">
<tr>
<td class="onefield acyfield_1 acyfield_text"><input name="user[name]" placeholder="Name" value="" data-authorized-content="{&quot;0&quot;:&quot;all&quot;,&quot;regex&quot;:&quot;&quot;,&quot;message&quot;:&quot;Incorrect value for the field Name&quot;}" type="text" class="cell  "><div class="acym__field__error__block" data-acym-field-id="1"></div></td></tr><tr><td class="onefield acyfield_2 acyfield_text"><input id="email_field_381" name="user[email]" placeholder="Email" value="" data-authorized-content="{&quot;0&quot;:&quot;all&quot;,&quot;regex&quot;:&quot;&quot;,&quot;message&quot;:&quot;Incorrect value for the field Email&quot;}" required type="email" class="cell acym__user__edit__email  "><div class="acym__field__error__block" data-acym-field-id="2"></div></td></tr><tr><td><table class="acym_lists">
<tr>
<td>
<input type="checkbox" class="acym_checkbox" name="subscription[]" id="acylist_1_formAcym96262" checked="checked" value="1" />
<label for="acylist_1_formAcym96262">Linux Advisory Watch</label>
</td>
</tr>
<tr>
<td>
<input type="checkbox" class="acym_checkbox" name="subscription[]" id="acylist_2_formAcym96262" checked="checked" value="2" />
<label for="acylist_2_formAcym96262">Linux Security Week</label>
</td>
</tr></table></td></tr><tr>
<td class="acysubbuttons">
<noscript>
                Please enable the javascript to submit this form			</noscript>
<input type="button" class="btn btn-primary button subbutton" value="Subscribe" name="Submit" onclick="try{ return submitAcymForm('subscribe','formAcym96262', 'acymSubmitSubForm'); }catch(err){alert('The form could not be submitted '+err);return false;}" />
</td>
</tr>
</table>
</div>
<input type="hidden" name="ctrl" value="frontusers" />
<input type="hidden" name="task" value="notask" />
<input type="hidden" name="option" value="com_acym" />
<input type="hidden" name="ajax" value="1" />
<input type="hidden" name="successmode" value="replace" />
<input type="hidden" name="acy_source" value="Module n°474" />
<input type="hidden" name="hiddenlists" value="" />
<input type="hidden" name="fields" value="name,email" />
<input type="hidden" name="acyformname" value="formAcym96262" />
<input type="hidden" name="acysubmode" value="mod_acym" />
<input type="hidden" name="confirmation_message" value="" />
</form>
</div>
</div>
</div></div></div></aside></div>
</div>
</div>
</section>
<section id="sp-bottom">
<div class="container">
<div class="container-inner">
<div class="row">
<div id="sp-bottom1" class="col-sm-col-sm-6 col-lg-2 "><div class="sp-column "><div class="sp-module "><h3 class="sp-module-title">News</h3><div class="sp-module-content"><ul class="menu">
<li class="item-581"><a href="/news/cloud-security" title="Cloud Security">Cloud Security</a></li><li class="item-596"><a href="/news/cryptography" title="Cryptography">Cryptography</a></li><li class="item-679"><a href="/news/desktop-security" title="Desktop Security">Desktop Security</a></li><li class="item-595"><a href="/news/firewall" title="Firewall">Firewall</a></li><li class="item-591"><a href="/news/government" title="Government">Government</a></li><li class="item-589"><a href="/news/hackscracks" title="Hacks/Cracks">Hacks/Cracks</a></li><li class="item-680"><a href="/news/iot-security" title="IoT Security">IoT Security</a></li><li class="item-681"><a href="/news/network-security" title="Network Security">Network Security</a></li><li class="item-884"><a href="/news/mobile-security" title="Mobile Security">Mobile Security</a></li><li class="item-682"><a href="/news/organizations-events" title="Organizations/Events">Organizations/Events</a></li><li class="item-590"><a href="/news/privacy" title="Privacy">Privacy</a></li><li class="item-592"><a href="/news/security-projects" title="Security Projects">Security Projects</a></li><li class="item-683"><a href="/news/security-trends" title="Security Trends">Security Trends</a></li><li class="item-684"><a href="/news/security-vulnerabilities" title="Security Vulnerabilities">Security Vulnerabilities</a></li><li class="item-594"><a href="/news/server-security" title="Server Security">Server Security</a></li><li class="item-593"><a href="/news/vendors-products" title="Vendors/Products">Vendors/Products</a></li></ul>
</div></div></div></div><div id="sp-bottom2" class="col-sm-col-sm-6 col-lg-2 "><div class="sp-column "><div class="sp-module "><h3 class="sp-module-title">Advisories</h3><div class="sp-module-content"><ul class="menu">
<li class="item-575"><a href="/advisories/archlinux" title=" Archlinux"><img src="/images/nav/nav_archlinux.webp" alt="Nav Archlinux" class="imgleft" width="50" height="50" /><span class="image-title">ArchLinux</span></a></li><li class="item-576"><a href="/advisories/centos" title=" Centos"><img src="/images/nav/nav_centos.webp" alt="Nav Centos" width="50" height="50" /><span class="image-title">CentOS</span></a></li><li class="item-578"><a href="/advisories/debian" title=" Debian"><img src="/images/nav/nav_debian.webp" alt="Nav Debian" width="50" height="50" /><span class="image-title">Debian</span></a></li><li class="item-577"><a href="/advisories/deblts" title=" Debian Lts"><img src="/images/nav/nav_debian_lts.webp" alt="Nav Debian Lts" width="50" height="50" /><span class="image-title">Debian LTS</span></a></li><li class="item-579"><a href="/advisories/fedora" title=" Fedora"><img src="/images/nav/nav_fedora.webp" alt="Nav Fedora" width="50" height="50" /><span class="image-title">Fedora</span></a></li><li class="item-580"><a href="/advisories/gentoo" title=" Gentoo"><img src="/images/nav/nav_gentoo.webp" alt="Nav Gentoo" width="50" height="50" /><span class="image-title">Gentoo</span></a></li><li class="item-582"><a href="/advisories/mageia" title=" Mageia"><img src="/images/nav/nav_mageia.webp" alt="Nav Mageia" width="50" height="50" /><span class="image-title">Mageia</span></a></li><li class="item-588"><a href="/advisories/opensuse" title=" Opensuse"><img src="/images/nav/nav_opensuse.webp" alt="Nav Opensuse" width="50" height="50" /><span class="image-title">openSUSE</span></a></li><li class="item-583"><a href="/advisories/red-hat" title=" Redhat"><img src="/images/nav/nav_redhat.webp" alt="Nav Redhat" width="50" height="50" /><span class="image-title">Red Hat</span></a></li><li class="item-584"><a href="/advisories/scilinux" title=" Scientific"><img src="/images/nav/nav_scientific.webp" alt="Nav Scientific" width="50" height="50" /><span class="image-title">Scientific Linux</span></a></li><li class="item-585"><a href="/advisories/slackware" title=" Slackware"><img src="/images/nav/nav_slackware.webp" alt="Nav Slackware" width="50" height="50" /><span class="image-title">Slackware</span></a></li><li class="item-586"><a href="/advisories/suse" title=" Suse"><img src="/images/nav/nav_suse.webp" alt="Nav Suse" width="50" height="50" /><span class="image-title">SuSE</span></a></li><li class="item-587"><a href="/advisories/ubuntu" title=" Ubuntu"><img src="/images/nav/nav_ubuntu.webp" alt="Nav Ubuntu" width="50" height="50" /><span class="image-title">Ubuntu</span></a></li><li class="item-975"><a href="/advisories/oracle" title="Oracle Large"><img src="/images/nav/oracle-large.webp" alt="Oracle Large" width="50" height="50" /><span class="image-title">Oracle</span></a></li></ul>
</div></div></div></div><div id="sp-bottom3" class="col-lg-2 "><div class="sp-column "><div class="sp-module "><h3 class="sp-module-title">HOWTOs</h3><div class="sp-module-content"><ul class="menu">
<li class="item-597"><a href="/howtos/harden-my-filesystem" title="Harden My Filesystem">Harden My Filesystem</a></li><li class="item-598"><a href="/howtos/learn-tips-and-tricks" title="Learn Tips and Tricks">Learn Tips and Tricks</a></li><li class="item-599"><a href="/howtos/secure-my-e-mail" title="Secure My E-mail">Secure My E-mail</a></li><li class="item-600"><a href="/howtos/secure-my-firewall" title="Secure My Firewall">Secure My Firewall</a></li><li class="item-601"><a href="/howtos/secure-my-network" title="Secure My Network">Secure My Network</a></li><li class="item-602"><a href="/howtos/secure-my-webserver" title="Secure My Webserver">Secure My Webserver</a></li><li class="item-603"><a href="/howtos/strengthen-my-privacy" title="Strengthen My Privacy">Strengthen My Privacy</a></li></ul>
</div></div></div></div><div id="sp-bottom4" class="col-lg-2 "><div class="sp-column "><div class="sp-module "><h3 class="sp-module-title">Features</h3><div class="sp-module-content"><div class="newsflash">
<h5 class="newsflash-title">
<a href="/features/the-dangers-of-using-a-vpn-for-remote-work-zero-trust-to-replace-it" title="The Dangers of Using a VPN for Remote Work: Zero Trust to Replace It">
The Dangers of Using a VPN for Remote Work: Zero Trust to Replace It </a>
</h5>
<h5 class="newsflash-title">
<a href="/features/all-you-need-to-know-about-linux-services-runlevels" title="All You Need to Know about Linux Services &amp; Runlevels">
All You Need to Know about Linux Services & Runlevels </a>
</h5>
<h5 class="newsflash-title">
<a href="/features/blackhat-usa-2022-devils-are-in-the-file-descriptors" title="BlackHat USA 2022: Devils Are in the File Descriptors">
BlackHat USA 2022: Devils Are in the File Descriptors </a>
</h5>
<h5 class="newsflash-title">
<a href="/features/blackhat-usa-2022-return-to-sender-detecting-kernel-exploits-with-ebpf" title="BlackHat USA 2022: Return to Sender - Detecting Kernel Exploits with eBPF">
BlackHat USA 2022: Return to Sender - Detecting Kernel Exploits with eBPF </a>
</h5>
<h5 class="newsflash-title">
<a href="/features/password-guessing-as-an-attack-vector" title="Password Guessing as an Attack Vector">
Password Guessing as an Attack Vector </a>
</h5>
</div>
</div></div></div></div><div id="sp-bottom5" class="col-lg-2 "><div class="sp-column "><div class="sp-module "><h3 class="sp-module-title">About Us</h3><div class="sp-module-content"><ul class="menu">
<li class="item-234"><a href="/about/advertise" title="Advertise">Advertise</a></li><li class="item-235"><a href="/about/legal-notice" title="Legal Notice">Legal Notice</a></li><li class="item-240"><a href="/about/linuxsecurity-rss-feeds" title="RSS Feeds">RSS Feeds</a></li><li class="item-685"><a href="/contact-us" title="Contact Us">Contact Us</a></li></ul>
</div></div></div></div><div id="sp-bottom6" class="col-lg-2 "><div class="sp-column "><div class="sp-module "><h3 class="sp-module-title">Powered By</h3><div class="sp-module-content">
<div class="custom">
<p><img src="/images/footer-logo.webp" alt="Footer Logo" class="img-responsive" style="float: left;" width="304" height="112" /></p></div>
</div></div></div></div></div>
</div>
</div>
</section>
<footer id="sp-footer">
<div class="container">
<div class="container-inner">
<div class="row">
<div id="sp-footer1" class="col-lg-6 "><div class="sp-column "><span class="sp-copyright">© 2022 Guardian Digital, Inc All Rights Reserved</span></div></div><div id="sp-footer2" class="col-lg-6 "><div class="sp-column "><div class="sp-module "><div class="sp-module-content">
<div class="custom">
<ul class="social-icons"><li class="social-icon-facebook"><a target="_blank" href="https://www.facebook.com/lnxsec/" aria-label="facebook" title="Lnxsec"><span class="fa fa-facebook" aria-hidden="true"></span></a></li><li class="social-icon-twitter"><a target="_blank" href="https://twitter.com/lnxsec" aria-label="twitter" title="Lnxsec"><span class="fa fa-twitter" aria-hidden="true"></span></a></li><li class="social-icon-linkedin"><a target="_blank" href="https://www.linkedin.com/authwall" aria-label="LinkedIn" title="Authwall"><span class="fa fa-linkedin" aria-hidden="true"></span></a></li></ul></div>
</div></div></div></div></div>
</div>
</div>
</footer> </div>
</div>

<div class="offcanvas-overlay"></div>
<div class="offcanvas-menu">
<a href="#" class="close-offcanvas" title=""><span class="fa fa-remove"></span></a>
<div class="offcanvas-inner">
<div class="sp-module "><div class="sp-module-content"><ul class="menu">
<li class="item-107 menu-deeper menu-parent"><a href="/news" title="News">News<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-581"><a href="/news/cloud-security" title="Cloud Security">Cloud Security</a></li><li class="item-596"><a href="/news/cryptography" title="Cryptography">Cryptography</a></li><li class="item-679"><a href="/news/desktop-security" title="Desktop Security">Desktop Security</a></li><li class="item-595"><a href="/news/firewall" title="Firewall">Firewall</a></li><li class="item-591"><a href="/news/government" title="Government">Government</a></li><li class="item-589"><a href="/news/hackscracks" title="Hacks/Cracks">Hacks/Cracks</a></li><li class="item-680"><a href="/news/iot-security" title="IoT Security">IoT Security</a></li><li class="item-681"><a href="/news/network-security" title="Network Security">Network Security</a></li><li class="item-884"><a href="/news/mobile-security" title="Mobile Security">Mobile Security</a></li><li class="item-682"><a href="/news/organizations-events" title="Organizations/Events">Organizations/Events</a></li><li class="item-590"><a href="/news/privacy" title="Privacy">Privacy</a></li><li class="item-592"><a href="/news/security-projects" title="Security Projects">Security Projects</a></li><li class="item-683"><a href="/news/security-trends" title="Security Trends">Security Trends</a></li><li class="item-684"><a href="/news/security-vulnerabilities" title="Security Vulnerabilities">Security Vulnerabilities</a></li><li class="item-594"><a href="/news/server-security" title="Server Security">Server Security</a></li><li class="item-593"><a href="/news/vendors-products" title="Vendors/Products">Vendors/Products</a></li></ul></li><li class="item-108 menu-deeper menu-parent"><a href="/advisories" title="Advisories">Advisories<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-575"><a href="/advisories/archlinux" title=" Archlinux"><img src="/images/nav/nav_archlinux.webp" alt="Nav Archlinux" class="imgleft" width="50" height="50" /><span class="image-title">ArchLinux</span></a></li><li class="item-576"><a href="/advisories/centos" title=" Centos"><img src="/images/nav/nav_centos.webp" alt="Nav Centos" width="50" height="50" /><span class="image-title">CentOS</span></a></li><li class="item-578"><a href="/advisories/debian" title=" Debian"><img src="/images/nav/nav_debian.webp" alt="Nav Debian" width="50" height="50" /><span class="image-title">Debian</span></a></li><li class="item-577"><a href="/advisories/deblts" title=" Debian Lts"><img src="/images/nav/nav_debian_lts.webp" alt="Nav Debian Lts" width="50" height="50" /><span class="image-title">Debian LTS</span></a></li><li class="item-579"><a href="/advisories/fedora" title=" Fedora"><img src="/images/nav/nav_fedora.webp" alt="Nav Fedora" width="50" height="50" /><span class="image-title">Fedora</span></a></li><li class="item-580"><a href="/advisories/gentoo" title=" Gentoo"><img src="/images/nav/nav_gentoo.webp" alt="Nav Gentoo" width="50" height="50" /><span class="image-title">Gentoo</span></a></li><li class="item-582"><a href="/advisories/mageia" title=" Mageia"><img src="/images/nav/nav_mageia.webp" alt="Nav Mageia" width="50" height="50" /><span class="image-title">Mageia</span></a></li><li class="item-588"><a href="/advisories/opensuse" title=" Opensuse"><img src="/images/nav/nav_opensuse.webp" alt="Nav Opensuse" width="50" height="50" /><span class="image-title">openSUSE</span></a></li><li class="item-583"><a href="/advisories/red-hat" title=" Redhat"><img src="/images/nav/nav_redhat.webp" alt="Nav Redhat" width="50" height="50" /><span class="image-title">Red Hat</span></a></li><li class="item-584"><a href="/advisories/scilinux" title=" Scientific"><img src="/images/nav/nav_scientific.webp" alt="Nav Scientific" width="50" height="50" /><span class="image-title">Scientific Linux</span></a></li><li class="item-585"><a href="/advisories/slackware" title=" Slackware"><img src="/images/nav/nav_slackware.webp" alt="Nav Slackware" width="50" height="50" /><span class="image-title">Slackware</span></a></li><li class="item-586"><a href="/advisories/suse" title=" Suse"><img src="/images/nav/nav_suse.webp" alt="Nav Suse" width="50" height="50" /><span class="image-title">SuSE</span></a></li><li class="item-587"><a href="/advisories/ubuntu" title=" Ubuntu"><img src="/images/nav/nav_ubuntu.webp" alt="Nav Ubuntu" width="50" height="50" /><span class="image-title">Ubuntu</span></a></li><li class="item-975"><a href="/advisories/oracle" title="Oracle Large"><img src="/images/nav/oracle-large.webp" alt="Oracle Large" width="50" height="50" /><span class="image-title">Oracle</span></a></li></ul></li><li class="item-109 menu-deeper menu-parent"><a href="/howtos" title="HOWTOs">HOWTOs<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-597"><a href="/howtos/harden-my-filesystem" title="Harden My Filesystem">Harden My Filesystem</a></li><li class="item-598"><a href="/howtos/learn-tips-and-tricks" title="Learn Tips and Tricks">Learn Tips and Tricks</a></li><li class="item-599"><a href="/howtos/secure-my-e-mail" title="Secure My E-mail">Secure My E-mail</a></li><li class="item-600"><a href="/howtos/secure-my-firewall" title="Secure My Firewall">Secure My Firewall</a></li><li class="item-601"><a href="/howtos/secure-my-network" title="Secure My Network">Secure My Network</a></li><li class="item-602"><a href="/howtos/secure-my-webserver" title="Secure My Webserver">Secure My Webserver</a></li><li class="item-603"><a href="/howtos/strengthen-my-privacy" title="Strengthen My Privacy">Strengthen My Privacy</a></li></ul></li><li class="item-110 current active menu-deeper menu-parent"><a href="/features" title="Features">Features<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-880 current active"><a href="/features" title="Feature Articles">Feature Articles</a></li><li class="item-879"><a href="/features/must-read-articles" title="Must Read Articles">Must Read Articles</a></li></ul></li><li class="item-112"><a href="/newsletters" title="Newsletters">Newsletters</a></li><li class="item-113"><a href="/polls" title="Polls">Polls</a></li><li class="item-114 menu-deeper menu-parent"><a href="/about" title="About">About<span class="menu-toggler"></span></a><ul class="menu-child"><li class="item-234"><a href="/about/advertise" title="Advertise">Advertise</a></li><li class="item-235"><a href="/about/legal-notice" title="Legal Notice">Legal Notice</a></li><li class="item-240"><a href="/about/linuxsecurity-rss-feeds" title="RSS Feeds">RSS Feeds</a></li><li class="item-685"><a href="/contact-us" title="Contact Us">Contact Us</a></li></ul></li><li class="item-255"><a href="/security-dictionary" title="Security Dictionary">Security Dictionary</a></li></ul>
</div></div>
</div>
</div>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
// Check the main container is ready
jQuery('.advisories-top-ind').ready(function(){
    // Get each div
    jQuery('.whitebg p').each(function(){
        // Get the content
        var str = jQuery(this).html();
        // Set the regex string
        var regex = /(https?:\/\/(?:www\.|(?!www))[a-zA-Z0-9][a-zA-Z0-9-]+[a-zA-Z0-9]\.[^\s]{2,}|www\.[a-zA-Z0-9][a-zA-Z0-9-]+[a-zA-Z0-9]\.[^\s]{2,}|https?:\/\/(?:www\.|(?!www))[a-zA-Z0-9]+\.[^\s]{2,}|www\.[a-zA-Z0-9]+\.[^\s]{2,})/gi;
        // Replace plain text links by hyperlinks
        var replaced_text = str.replace(regex, "<a href='$1' target='_blank' title=\"$1\">$1</a>");
        // Echo link
        jQuery(this).html(replaced_text);
    });
    jQuery('.whitebg .drow').each(function(){
        // Get the content
        var str = jQuery(this).html();
        // Set the regex string
        var regex = /(https?:\/\/(?:www\.|(?!www))[a-zA-Z0-9][a-zA-Z0-9-]+[a-zA-Z0-9]\.[^\s]{2,}|www\.[a-zA-Z0-9][a-zA-Z0-9-]+[a-zA-Z0-9]\.[^\s]{2,}|https?:\/\/(?:www\.|(?!www))[a-zA-Z0-9]+\.[^\s]{2,}|www\.[a-zA-Z0-9]+\.[^\s]{2,})/gi;
        // Replace plain text links by hyperlinks
        var replaced_text = str.replace(regex, "<a href='$1' target='_blank' title=\"$1\">$1</a>");
        // Echo link
        jQuery(this).html(replaced_text);
    });
});
</script>

<a href="#" class="sp-scroll-up" aria-label="Scroll Up" title=""><span class="fa fa-chevron-up" aria-hidden="true"></span></a>

<script>
jQuery( document ).ready(function() {
	var loadads=[];
	jQuery(".adloader").each(function(){
		loadads.push(jQuery(this).attr("ad"));
	});
	var loadadsdata = loadads.join(",")

	jQuery.ajax({

		url : '/',
		type : 'GET',
		data : {
			'ajaxads' : 1,
			'loadads' : loadadsdata
		},
		dataType:'json',
		success : function(data) {  
			//console.log(data.large_square);
			jQuery(".adloader").each(function(){
				//console.log(data[jQuery(this).attr("ad")]);
				jQuery(this).html(data[jQuery(this).attr("ad")]);
				//data[jQuery(this).attr("ad")];
			});
			
		},
		error : function(request,error)
		{
			//alert("Request: "+JSON.stringify(request));
		}
	});
	setTimeout(function() {

		jQuery("#login button.close").on("click", function(){
		  jQuery('#login').hide("fast");
		}); 

	}, 2000);
});
</script>


<script>
    jQuery("a").on("mouseover", function() {
        var link = jQuery(this).attr("href"),
            prerenderLink = jQuery("#prerenderLink");
        if (prerenderLink.length) {
            if (prerenderLink.attr("href") === link) return;
            prerenderLink.attr("href", link);
        } else {
            jQuery('<link id="prerenderLink" rel="prefetch prerender" href="' + link + '" />').appendTo("body");
        }
    });
</script>

<div data-id="4" class="eb-inst eb-hide eb-4 eb-top-left eb-custom " data-options='{"trigger":"onClick","trigger_selector":"#sp-top1 > .sp-column > .sp-module .sp-module-title","delay":0,"scroll_depth":"percentage","scroll_depth_value":80,"firing_frequency":1,"reverse_scroll_close":false,"threshold":0,"close_out_viewport":false,"exit_timer":1000,"idle_time":10000,"animation_open":"transition.slideUpIn","animation_close":"transition.fadeOut","animation_duration":300,"prevent_default":true,"backdrop":true,"backdrop_color":"rgba(0, 0, 0, 0.5)","backdrop_click":true,"disable_page_scroll":false,"test_mode":false,"debug":false,"ga_tracking":false,"ga_tracking_id":0,"ga_tracking_event_category":"EngageBox","ga_tracking_event_label":"Box #4 - Advisories","auto_focus":false}' data-type='popup'>
<div class="eb-dialog " style="max-width:250px;background-color:rgba(255, 255, 255, 1);color:rgba(51, 51, 51, 1);border:solid 1px rgba(0, 0, 0, 0.4);padding:20px;" role="dialog" tabindex="-1">
<button type="button" data-ebox-cmd="close" class="eb-close" aria-label="Close" style="color:rgba(174, 174, 174, 1);font-size:28px">
<span aria-hidden="true">&times;</span>
</button>
<div class="eb-container">
<div class="eb-header">
Advisories </div>
<div class="eb-content">
<ul class="sp-mega-group">
<li class="item-575 menu_item item-header"><a href="/advisories/archlinux" title=" Archlinux"><img src="/images/nav/nav_archlinux.png" alt="Nav Archlinux" width="50" height="50" /><span class="image-title">ArchLinux</span></a></li>
<li class="item-576 menu_item item-header"><a href="/advisories/centos" title=" Centos"><img src="/images/nav/nav_centos.png" alt="Nav Centos" width="50" height="50" /><span class="image-title">CentOS</span></a></li>
<li class="item-578 menu_item item-header"><a href="/advisories/debian" title=" Debian"><img src="/images/nav/nav_debian.png" alt="Nav Debian" width="50" height="50" /><span class="image-title">Debian</span></a></li>
<li class="item-577 menu_item item-header"><a href="/advisories/deblts" title=" Debian Lts"><img src="/images/nav/nav_debian_lts.png" alt="Nav Debian Lts" width="50" height="50" /><span class="image-title">Debian LTS</span></a></li>
<li class="item-579 menu_item item-header"><a href="/advisories/fedora" title=" Fedora"><img src="/images/nav/nav_fedora.png" alt="Nav Fedora" width="50" height="50" /><span class="image-title">Fedora</span></a></li>
<li class="item-580 menu_item item-header"><a href="/advisories/gentoo" title=" Gentoo"><img src="/images/nav/nav_gentoo.png" alt="Nav Gentoo" width="50" height="50" /><span class="image-title">Gentoo</span></a></li>
<li class="item-582 menu_item item-header"><a href="/advisories/mageia" title=" Mageia"><img src="/images/nav/nav_mageia.png" alt="Nav Mageia" width="50" height="50" /><span class="image-title">Mageia</span></a></li>
<li class="item-975 menu_item item-header"><a href="/advisories/oracle" title="Oracle Large"><img src="/images/nav/oracle-large.png" alt="Oracle Large" width="50" height="50" /><span class="image-title">Oracle</span> </a></li>
<li class="item-588 menu_item item-header"><a href="/advisories/opensuse" title=" Opensuse"><img src="/images/nav/nav_opensuse.png" alt="Nav Opensuse" width="50" height="50" /><span class="image-title">openSUSE</span> </a></li>
<li class="item-583 menu_item item-header"><a href="/advisories/red-hat" title=" Redhat"><img src="/images/nav/nav_redhat.png" alt="Nav Redhat" width="50" height="50" /><span class="image-title">Red Hat</span></a></li>
<li class="item-584 menu_item item-header"><a href="/advisories/scilinux" title=" Scientific"><img src="/images/nav/nav_scientific.png" alt="Nav Scientific" width="50" height="50" /><span class="image-title">Scientific Linux</span></a></li>
<li class="item-585 menu_item item-header"><a href="/advisories/slackware" title=" Slackware"><img src="/images/nav/nav_slackware.png" alt="Nav Slackware" width="50" height="50" /><span class="image-title">Slackware</span></a></li>
<li class="item-586 menu_item item-header"><a href="/advisories/suse" title=" Suse"><img src="/images/nav/nav_suse.png" alt="Nav Suse" width="50" height="50" /><span class="image-title">SuSE</span></a></li>
<li class="item-587 menu_item item-header"><a href="/advisories/ubuntu" title=" Ubuntu"><img src="/images/nav/nav_ubuntu.png" alt="Nav Ubuntu" width="50" height="50" /><span class="image-title">Ubuntu</span></a></li>
<li class="item-588 menu_item item-header"><a href="/advisories/opensuse" title=" Opensuse"><img src="/images/nav/nav_opensuse.png" alt="Nav Opensuse" width="50" height="50" /><span class="image-title">openSUSE</span></a></li>
</ul> </div>
</div>
</div>
</div>
<div data-id="6" class="eb-inst eb-hide eb-6 eb-top-left eb-custom ebStickyBar" data-options='{"trigger":"onPageLoad","trigger_selector":".erer","delay":0,"scroll_depth":"percentage","scroll_depth_value":80,"firing_frequency":1,"reverse_scroll_close":true,"threshold":0,"close_out_viewport":false,"exit_timer":1000,"idle_time":10000,"animation_open":"rstbox.slideDownIn","animation_close":"rstbox.slideDownOut","animation_duration":200,"prevent_default":true,"backdrop":false,"backdrop_color":"rgba(0, 0, 0, 0.8)","backdrop_click":true,"disable_page_scroll":false,"test_mode":false,"debug":false,"ga_tracking":false,"ga_tracking_id":0,"ga_tracking_event_category":"EngageBox","ga_tracking_event_label":"Box #6 - Advisories","auto_focus":false}' data-type='pageslide'>
<div class="eb-dialog eb-shd1 eb-acm eb-acc" style="max-width:100%;background-color:rgba(10, 41, 114, 1);color:#ffffff;border-radius:0px;padding:4px;" role="dialog" tabindex="-1">
<button type="button" data-ebox-cmd="close" class="eb-close" aria-label="Close" style="color:rgba(255, 255, 255, 0.5);font-size:22px">
<span aria-hidden="true">&times;</span>
</button>
<div class="eb-container">
<div class="eb-content">
<div class="eb advisories">
<div class="eb-row-flex">
<div style="text-align: left;">Get Customized Security Advisories that Impact You Directly <a href="/profile" class="eb-btn eb-btn-primary eb-btn-medium" title="Create My Customized Advisories Now &amp;gt;&amp;gt;">Create My Customized Advisories Now &gt;&gt;</a></div>
</div>
</div> </div>
</div>
</div>
</div>
<div data-id="7" class="eb-inst eb-hide eb-7 eb-top-left eb-custom ebStickyBar" data-options='{"trigger":"onClick","trigger_selector":null,"delay":0,"scroll_depth":"percentage","scroll_depth_value":80,"firing_frequency":1,"reverse_scroll_close":true,"threshold":0,"close_out_viewport":false,"exit_timer":1000,"idle_time":10000,"animation_open":"rstbox.slideDownIn","animation_close":"rstbox.slideDownOut","animation_duration":200,"prevent_default":true,"backdrop":false,"backdrop_color":"rgba(0, 0, 0, 0.8)","backdrop_click":true,"disable_page_scroll":false,"test_mode":false,"debug":false,"ga_tracking":false,"ga_tracking_id":0,"ga_tracking_event_category":"EngageBox","ga_tracking_event_label":"Box #7 - Newsletters","auto_focus":false}' data-type='pageslide'>
<div class="eb-dialog eb-shd1 eb-acm eb-acc" style="max-width:100%;background-color:rgba(10, 41, 114, 1);color:#ffffff;border-radius:0px;padding:4px;" role="dialog" tabindex="-1">
<button type="button" data-ebox-cmd="close" class="eb-close" aria-label="Close" style="color:rgba(255, 255, 255, 0.5);font-size:22px">
<span aria-hidden="true">&times;</span>
</button>
<div class="eb-container">
<div class="eb-content">
<div class="eb advisories">
<div class="eb-row-flex">
<div style="text-align: left;">To stay up-to-date on the latest open-source security news, feature articles and Linux distribution security advisories <a href="/#section-id-1618254404657" class="eb-btn eb-btn-primary eb-btn-medium" title="Subscribe to Our Newsletters!">Subscribe to Our Newsletters!</a></div>
</div>
</div> </div>
</div>
</div>
</div>
<div data-id="8" class="eb-inst eb-hide eb-8 eb-center eb-custom become-linux-security-master" data-options='{"trigger":"onClick","trigger_selector":".btns-article-detail #btn-1636148908465","delay":0,"scroll_depth":"percentage","scroll_depth_value":80,"firing_frequency":1,"reverse_scroll_close":false,"threshold":0,"close_out_viewport":false,"exit_timer":1000,"idle_time":10000,"animation_open":"transition.slideUpIn","animation_close":"transition.fadeOut","animation_duration":300,"prevent_default":false,"backdrop":false,"backdrop_color":"rgba(0, 0, 0, 0.5)","backdrop_click":true,"disable_page_scroll":false,"test_mode":false,"debug":false,"ga_tracking":false,"ga_tracking_id":0,"ga_tracking_event_category":"EngageBox","ga_tracking_event_label":"Box #8 - Become a LinuxSecurity Master","auto_focus":false}' data-type='popup'>
<div class="eb-dialog " style="max-width:500px;background-color:rgba(255, 255, 255, 1);color:rgba(51, 51, 51, 1);border:solid 1px rgba(0, 0, 0, 0.4);" role="dialog" tabindex="-1">
<button type="button" data-ebox-cmd="close" class="eb-close" aria-label="Close" style="color:rgba(136, 136, 136, 1);font-size:30px">
<span aria-hidden="true">&times;</span>
</button>
<div class="eb-container">
<div class="eb-content">
<p> <div class="acym_module newsletter-subscribe-module" id="acym_module_formAcym54841">
<div class="acym_fulldiv" id="acym_fulldiv_formAcym54841">
<form enctype="multipart/form-data" id="formAcym54841" name="formAcym54841" method="POST" action="/component/acym/frontusers?tmpl=component" onsubmit="return submitAcymForm('subscribe','formAcym54841', 'acymSubmitSubForm')">
<div class="acym_module_form">
<div class="acym_introtext"><h3>Get the Latest News & Insights</h3>
<p>Sign up to get the latest security news affecting Linux and open source delivered straight to your inbox</p></div>
<table class="acym_form">
<tr>
<td class="onefield acyfield_1 acyfield_text"><input name="user[name]" placeholder="Name" value="" data-authorized-content="{&quot;0&quot;:&quot;all&quot;,&quot;regex&quot;:&quot;&quot;,&quot;message&quot;:&quot;Incorrect value for the field Name&quot;}" type="text" class="cell  "><div class="acym__field__error__block" data-acym-field-id="1"></div></td></tr><tr><td class="onefield acyfield_2 acyfield_text"><input id="email_field_558" name="user[email]" placeholder="Email" value="" data-authorized-content="{&quot;0&quot;:&quot;all&quot;,&quot;regex&quot;:&quot;&quot;,&quot;message&quot;:&quot;Incorrect value for the field Email&quot;}" required type="email" class="cell acym__user__edit__email  "><div class="acym__field__error__block" data-acym-field-id="2"></div></td></tr><tr><td><table class="acym_lists">
<tr>
<td>
<input type="checkbox" class="acym_checkbox" name="subscription[]" id="acylist_1_formAcym54841" checked="checked" value="1" />
<label for="acylist_1_formAcym54841">Linux Advisory Watch</label>
</td>
</tr>
<tr>
<td>
<input type="checkbox" class="acym_checkbox" name="subscription[]" id="acylist_2_formAcym54841" checked="checked" value="2" />
<label for="acylist_2_formAcym54841">Linux Security Week</label>
</td>
</tr></table></td></tr><tr>
<td class="acysubbuttons">
<noscript>
                Please enable the javascript to submit this form			</noscript>
<input type="button" class="btn btn-primary button subbutton" value="Yes, sign me up!" name="Submit" onclick="try{ return submitAcymForm('subscribe','formAcym54841', 'acymSubmitSubForm'); }catch(err){alert('The form could not be submitted '+err);return false;}" />
</td>
</tr>
</table>
</div>
<input type="hidden" name="ctrl" value="frontusers" />
<input type="hidden" name="task" value="notask" />
<input type="hidden" name="option" value="com_acym" />
<input type="hidden" name="ajax" value="1" />
<input type="hidden" name="successmode" value="replace" />
<input type="hidden" name="acy_source" value="Module n°451" />
<input type="hidden" name="hiddenlists" value="" />
<input type="hidden" name="fields" value="name,email" />
<input type="hidden" name="acyformname" value="formAcym54841" />
<input type="hidden" name="acysubmode" value="mod_acym" />
<input type="hidden" name="confirmation_message" value="" />
</form>
</div>
</div>
</p> </div>
</div>
<script>
jQuery(document).ready(function($){	
	$(document).on("click", '.btns-article-detail #btn-1636148908465', function(){
    	const box = EngageBox.getInstance(8);
		box.open();
    });
});
</script> </div>
</div><!--googleoff: all--><div class="cadre_alert_cookies" id="cadre_alert_cookies" style="opacity:1;text-align:center;position:fixed;z-index:10000;left: 0;right: 0;bottom: 0; margin:0px;"><div class="cadre_inner_alert_cookies" style="display: inline-block;width: 100%;margin:auto;max-width:100%;background-color: #ffffff;border: 0px solid #eeeeee;"><div class="cadre_inner_texte_alert_cookies" style="display: inline-block;padding:10px;color: #666666"><div class="cadre_texte "><p>We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.&nbsp;</p></div><div class="cadre_bouton "><div class=" col-md-6 col-sm-6 btn_close" style="margin:0;text-align:center"><button onclick="CloseCadreAlertCookie();" style="color:#eeeeee" class="btn btn-warning  popup-modal-dismiss">Accept</button></div><div class=" col-md-6 col-sm-6 btn_readmore" style="margin:0;text-align:center"><a style="color:#eeeeee" class="btn btn-inverse  read_more" href="/cookies">Learn More About Our Cookie Policy</a></div></div></div></div></div><!--googleon: all--><script type="text/javascript">/*<![CDATA[*/var name = "fmalertcookies" + "=";var ca = document.cookie.split(";");var acceptCookie = false;for(var i=0; i<ca.length; i++) {var c = ca[i];while (c.charAt(0)==" ") c = c.substring(1);if (c.indexOf(name) == 0){ acceptCookie = true; document.getElementById("cadre_alert_cookies").style.display="none";}}var d = new Date();d.setTime(d.getTime() + (30*(24*60*60*1000)));var expires_cookie = "expires="+d.toUTCString();function CloseCadreAlertCookie(){document.getElementById('cadre_alert_cookies').style.display='none'; document.cookie='fmalertcookies=true; '+expires_cookie+'; path=/';}/*]]>*/</script><div id="jfbcLoginModal" class="sourcecoast modal" style="display:none"><div class="modal-body">You are now being logged in using your Facebook credentials</div></div></body>
<script data-cfasync="false">
jQuery( document ).ready(function() {
	/*
	if(botCheck())
	{

	}
	else{
		
		
	jQuery("[lazy-src]").each(function(){
		////jQuery(this).attr('src',jQuery(this).attr('lazy-src'));
	});
	
	jQuery(".sppb-addon-article").each(function(){
		if(jQuery(this).attr('bgimg'))
		{
		////jQuery(this).css('background-image','url('+jQuery(this).attr('bgimg')+')');
		}
		//jQuery(this).data('content','unset !important');
		//alert(jQuery(this).css('content'));
	});
		

		//jQuery("link[hreflazy]").each(function(){
			//jQuery(this).attr('href',jQuery(this).attr('hreflazy'));
		//});
	}
	*/
});





var javascriptdone = 0;
window.addEventListener('scroll', function() {
  if(window.pageYOffset > 1 && javascriptdone==0)
  {
  javascriptdone=1;

	//jQuery("#fs_e459b78c1d0fbc2e80fdcc0644d5b57c53a858b18b61e0d929bb405026a53499").attr('src',jQuery("#fs_e459b78c1d0fbc2e80fdcc0644d5b57c53a858b18b61e0d929bb405026a53499").attr('src-lazy'));
/*
window.dataLayer=window.dataLayer||[];function gtag(){dataLayer.push(arguments);}
gtag('js',new Date());gtag('config','UA-336357-8');
*/

/*
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-NBLR8DK');
*/

  }
});
</script>
<script>
jQuery('document').ready(function(){
jQuery(window).scroll(function(e){ 
  var jQueryel = jQuery('#key-references'); 
  var isPositionFixed = (jQueryel.css('position') == 'fixed');
	var pageWidth= jQuery(document).width();

 if (pageWidth > 500)
	 {
		  if (jQuery(this).scrollTop() > 849 && !isPositionFixed){ 
			jQueryel.css({'position': 'fixed', 'top': '190px', 'z-index': '999', 'width': '28%'}); 
		  }
		  if (jQuery(this).scrollTop() < 849 && isPositionFixed){
		   jQueryel.css({'position': 'static', 'top': '0px', 'width': '100%'}); 
		  } 
	 }
 
});
});
</script>
</html>